Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Smile Ajuda Script para BackUp

    Alguem saberia como fazer um Scrip para backup automatico e que envie por email tipo com tempo para ele excutar???

  2. #2

    Padrão

    Citação Postado originalmente por heavyzin Ver Post
    Alguem saberia como fazer um Scrip para backup automatico e que envie por email tipo com tempo para ele excutar???
    Boa, também preciso desse tbm, pois tenho 2 servidores mais a RouterBoard.
    Seria muito útil, pois em 20 dias perdi meus dados 2 vezes, por causa de um HD aqui.
    Abraços.



  3. #3

    Thumbs up

    Amigo Procurei um pouco mais e arrumei um script nesse endereço
    Eduardo Lucas Pinto :: Blog :: Script de Backup para Mikrotik
    o cara explica td showwww da uma olhada lah
    mais como tenho varios MK na rede preciso que ele nomeie com o radio name de cada MK sera que eh possivel?
    Última edição por heavyzin; 05-06-2008 às 11:57.

  4. #4

    Padrão

    Citação Postado originalmente por heavyzin Ver Post
    Amigo Procurei um pouco mais e arrumei um script nesse endereço
    Eduardo Lucas Pinto :: Blog :: Script de Backup para Mikrotik
    o cara explica td showwww da uma olhada lah
    mais como tenho varios MK na rede preciso que ele nomeie com o radio name de cada MK sera que eh possivel?
    Coloque o nome de cada rádio logo após:
    /system backup save name=nome_radio



  5. #5

    Padrão

    Amigos,

    Fiz o sript e tá rodando sem problemas para gerar o backup. Meu problema está na configuração do servidor de e-mail:

    # Configura Servidor de Email do Mikrotik

    /tool e-mail set server="servidor de email" from="conta de email"


    Coloquei em server="servidor de email" o servidro smtp da conta que estou configurando.. seria isso mesmo? Porque não funcionou... o e-mail não foi enviado... se alguém puder ajudar, agradeço!

    Abs a todos!

  6. #6

    Thumbs up

    /tool e-mail set server="aki eu coloquei o ip do meu servidor de email" from="O email para onde vai ser enviado o Backup"

    amigo eu fiz assim e ficou show me enviou o email normalmente mais o servidor de email eh aki da empresa agora se for algum outro email tipo hotmail axo que basta pedir o smtp do email que vc usa q deve funcionar



  7. #7

    Padrão

    Amigo, tentei colocar o smtp, mas ele falou que o valor era inválido para o argumento server. Então dei um ping com o stmp, peguei o ip e coloquei no no set srever, aí aceitou.. ficou assim:


    /tool e-mail set server="ip do smtp" from "e-mail de origem"

    /tool e-mail send file=Backup.backup to="email de destino" subject=Backup

    Aí rodei os scripts e não deu nenhum.. mas tb não enviou o backup..rs..
    Tem alguma idéia do que possa estar errado?
    Desde já obrigado!
    Abs

  8. #8

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Amigo, tentei colocar o smtp, mas ele falou que o valor era inválido para o argumento server. Então dei um ping com o stmp, peguei o ip e coloquei no no set srever, aí aceitou.. ficou assim:


    /tool e-mail set server="ip do smtp" from "e-mail de origem"

    /tool e-mail send file=Backup.backup to="email de destino" subject=Backup

    Aí rodei os scripts e não deu nenhum.. mas tb não enviou o backup..rs..
    Tem alguma idéia do que possa estar errado?
    Desde já obrigado!
    Abs
    O seu servidor de e-mail requer autênticação? Nosso amigo hyperpotato está usando servidor próprio que não requer autênticação



  9. #9

    Padrão

    tenta assim mano!!!

    /tool e-mail set server="IP do SMPT " from="Meu email"
    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=Backup"
    /system script add name=Email_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/tool e-mail send file=Backup.backup to="Meu email" subject=Backup"
    /system scheduler add name=Gera_Backup start-time=13:24:00 on-event=Gera_Backup
    /system scheduler add name=Email_Backup start-time=13:24:10 on-event=Email_Backup

  10. #10

    Padrão

    Ummm tem isso no caso nao sei como fazer com um servidor de email que requer autenticação



  11. #11

    Padrão

    Não amigos,

    Meu servidor SMTP não requer autenticação...

  12. #12

    Padrão

    entao eu colei o script ali copia ele e modifica para ver se vai funionar mais vc va em script e da Run para ele rodar lembrande de mudar hora qele vai gerar o backup e enviar



  13. #13

    Padrão

    O seu servidor está atrás de um outro ou está ligado diretamente no modem. Verifique se as postas de comunicação do smtp não estão sendo bloqueadas.

  14. #14

    Padrão

    Amigo,
    Está ligado direto no meu roteador. Teoricamente deveria funcionar, pois utilizo esse smtp em meu outlook e tb desenvolvi uma aplicação em Delphi que através de um componente Indy envia um e-mail para mim e nas configurações desse componente uso o mesmo servidor smtp que estou tentando utilizar no Mk... entretanto, volto a frisar que ele nao deixa eu dar um set server com "smtp.dominio.com.br"... somente pelo ip.. e talvez o ip que esteja sendo retornado qnd dou o ping com esse smtp nao esteja correto... pode ser isso talvez...



  15. #15

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Amigo,
    Está ligado direto no meu roteador...
    Faça o seguinte amigo,
    Coloque tool e-mail set server=smtp.servidor.com e pressione "TAB" para vê o ip que ele retorna.

    Posta sua configurações do scrip para darmos uma visualizada.
    Última edição por Raniel; 06-06-2008 às 13:54. Razão: Acrescentar informações.

  16. #16

    Talking

    sobre a minha duvida consegui coloca no script para ele procurar o identity do radio e nomear o backup mais nao consigo startar o scrip da uma olhada na linha
    se tiver alguma coisa errada me fala a modificação esta aki name=/system identity get name"


    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=/system identity get name"



  17. #17

  18. #18

    Padrão

    Valeu amigo!
    Apertei o TAB e pegu o ip correto!
    Funcionou blza!
    Já recebi o e-mail com o arquivo!
    Muito obrigado mesmo a todos os que ajudaram!

    Abs



  19. #19

    Padrão

    Citação Postado originalmente por heavyzin Ver Post
    sobre a minha duvida consegui coloca no script para ele procurar o identity do radio e nomear o backup mais nao consigo startar o scrip da uma olhada na linha
    se tiver alguma coisa errada me fala a modificação esta aki name=/system identity get name"


    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=/system identity get name"

    Olha amigo,
    Ele não consegue setar o nome do do save com a função /system identity get name.

    Coloque assim:
    /system backup save name=Torre1
    Última edição por Raniel; 06-06-2008 às 16:04. Razão: Um errozinho

  20. #20

    Padrão

    Citação Postado originalmente por heavyzin Ver Post
    ... /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/system backup save name=/system identity get name"
    Coloque sua função deste jeito que ele vai gerar com o nome do identy:
    /system script add name=Gera_Backup policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write
    source=[/system backup save name=[/system identity get name]]


    Caso não funcione, faça este script pelo winbox (system scripts click no +):
    /system backup save name=[/system identity get name]

    Qualquer coisa...
    Última edição por Raniel; 06-06-2008 às 23:32.