Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal!!

    Depois de muito tentar... pesquisar (guia do hardware, under-linux, vivaolinux, terra postmaster, etc) fazer e refazer e fazer mais uma vez.... CANSEI.

    Não queria fazer mais um tópico sobre DNS Reverso, porque tá cheio, mas não achei outro jeito.

    O detalhe é o seguinte: nó temos um AS (Faixa de IP) um /20.
    YYY.XX.WW/20

    Nós temos autoridade sobre esta faixa. Ela é nossa (nós somos a operadora) então não é problema de pedir pra operadora liberar o reverso, achei muito disso no fórum então estou esclarecendo logo.
    Lá no Registro.br estão as opções pra eu delegar a faixa de ip pra resolver no servidor que eu quiser.

    Fui configurar o servidor de DNS pra essa rede, depois de muito bater e tentar, tá funcionando.

    Está resolvendo o nome do meu domínio pra um ip desses da faixa /20.

    tenho os servidores DNS.
    serv1.meudominio.com.br
    serv2.meudominio.com.br

    eles estão funcionando sem problema nenhum e os serviços desses dependentes dele também (página, e-mail).

    O grande problema de tudo é o REVERSO.

    Esse bem dito não funciona e isso é um problema já que tenho o servidor de e-mails e muitos e-mails estão sendo considerados spam.

    Vou passar abaixo as configurações dos meus arquivos do BIND e peço que algum iluminado ache onde está o problema.


    Detalhes: está funcionando com FEDORA 6 e o bind em CHROOT



    AQUIVO named.conf:
    ==============================================================
    // generated by named-bootconf.pl
    options {
    directory "/var/named";
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    query-source address * port 53;
    listen-on { 127.0.0.1/32; 0.0.0.0/0; };
    allow-recursion { 127.0.0.1/32; YYY.XX.WW/20; };
    };
    //
    // a caching only nameserver config
    //
    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };
    zone "." IN {
    type hint;
    file "named.ca";
    };
    zone "localhost" IN {
    type master;
    file "localhost.zone";
    allow-update { none; };
    };
    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "named.local";
    allow-update { none; };
    };

    zone "0.in-addr.arpa" {
    type master;
    file "named.zero";
    };

    zone "255.in-addr.arpa" {
    type master;
    file "named.broadcast";
    };

    zone "meudominio.com.br" IN {
    type master;
    file "db.meudominio.com.br";
    allow-transfer { YYY.XX.WW.91; };
    };

    zone "WW.XX.YYY.in-addr.arpa" {
    type master;
    file "db.YYY.XX.WW.0.rev";
    allow-update { none; };
    };
    include "/etc/rndc.key";
    =================================================================


    --X--

    ARQUIVO DO REVERSO db.YYY.XX.WW.0.rev
    =================================================================


    $TTL 86400
    @ IN SOA serv1.meudominio.com.br. hostmaster.meudominio.com.br. (
    20080600702 3H 15M 1W 1D )
    IN NS serv1.meudominio.com.br.
    IN NS serv2.meudominio.com.br.
    90 IN PTR meudominio.com.br.
    91 IN PTR serv2.meudominio.com.br.

    ================================================================

    O PROBLEMA:

    Quando vou testar com dig -x YYY.XX.WW.90
    dá a seguinte mensagem:

    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 58717
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;90.WW.XX.YYY.in-addr.arpa. IN PTR
    ;; Query time: 0 msec
    ;; SERVER: 189.90.80.90#53(189.90.80.90)
    ;; WHEN: Sat Jun 7 12:06:01 2008
    ;; MSG SIZE rcvd: 43


    esse SERVFAIL está me tirando o juizo!





    É isso.

    Alguém aponte o cocô que eu fiz.

    Sds.

  2. amigao vo tentar te ajduar mas estou espludindo de dor de cabeça


    edite o arquivo
    /etc/hosts

    127.0.0.1 localhost
    201.47.246.186 vipnet1.vipnetsul.com.br vipnet1



    edite o arquivo /etc/hostname

    vipnet1



  3. que mal me pergunte, mas
    pra que vai servir eu adicionar esses hosts??

  4. meu reverso nao funciona aqui se eu nao fazer isso

    no seu caso troque o vipnet1 pelo o nome do seu host e o ip pelo qual vc ta usando ai
    Última edição por Pirigoso; 07-06-2008 às 19:30.



  5. Citação Postado originalmente por Markey Ver Post

    zone "WW.XX.YYY.in-addr.arpa" {
    type master;
    file "db.YYY.XX.WW.0.rev";
    allow-update { none; };
    };
    Markey...
    no seu named.conf coloque assim:

    zone "AAA-BBB.WW.XX.YYY.in-addr.arpa" {
    type master;
    file "db.YYY.XX.WW.0.rev";
    };

    onde AAA-BBB são respectivamente o primeiro e último IP da sua faixa. No meu caso aqui é uma máscara /28 então está indo de 108 (ip do roteador da operadora) até 123 (ip broadcast).






Tópicos Similares

  1. cadastrar/alterar Dns Reverso
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 1
    Último Post: 27-02-2004, 15:43
  2. Problemas com o DNS reverso no serv
    Por Daniels no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-02-2004, 15:02
  3. DNS REVERSO
    Por no fórum Servidores de Rede
    Respostas: 8
    Último Post: 13-05-2003, 16:39
  4. Dns Reverso rede com mascara 192
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-05-2003, 11:05
  5. DNS Reverso
    Por Good_speed no fórum Servidores de Rede
    Respostas: 5
    Último Post: 15-09-2002, 20:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L