+ Responder ao Tópico



  1. estou com apache rodando normal na minha máquina em casa digitando:

    http://192.168.0.200:8080 mas preciso colocar minha página na internet(uso velox adsl) então fiz isso mas configutações:


    dentro de /etc/apache2/ports.conf:

    GNU nano 2.0.7 Arquivo: /etc/apache2/ports.conf

    Listen 80
    Listen 8080
    <IfModule mod_ssl.c>
    Listen 443
    </IfModule>



    dentro de /etc/apache2/sites-available/default:

    NameVirtualHost *:8080

    <VirtualHost *:8080>
    ServerName meudominio.no-ip.info
    ServerAlias www.meudominio.com.br
    ServerAdmin ti@nfa.com.br
    DocumentRoot /var/www/teste

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
    ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>

    dentro de pico /etc/apache2/sites-available/raquel:

    <VirtualHost *:8080>
    ServerName meudominio.no-ip.info
    ServerAlias www.meudominio.com.br
    DocumentRoot /var/www/teste
    </VirtualHost>

    e tenho o no-ip(usando port redirect e coloquei 8080) instalado e funcionando na máquina mas não consigo acessar externamente
    digitando http://meudominio.no-info ou http://meudominio.no-info:8080

    OBS:1 -Lembrando que já direcionei porta 8080 no modem para o ip interno de minha máquina
    2-tenho um dominio www.meudominio.com.br no resgistro.br que está direcionado(usando o site everyDNS) para o meudomino.no-ip.info por isso se pingar agora ele vai responder de qualquer forma.


    o que está faltando?
    quando tento abrir externamente dá mensagem:

    O Internet Explorer não pode exibir a página da Web

    Causas prováveis:

    • Você não está conectado à Internet.
    • O site está encontrando problemas.
    • Talvez haja um erro de digitação no endereço.

    Você pode tentar:

    https://under-linux.org/forums/bullet.png Verifique sua conexão com a Internet. Tente visitar outro site para verificar se você está conectado.

    https://under-linux.org/forums/bullet.png Digite o endereço novamente.

    https://under-linux.org/forums/bullet.png Voltar para a página anterior.

    https://under-linux.org/forums/down.png Mais informações

    Esse problema pode ser causado por vários motivos, incluindo:
    • A conectividade com a Internet foi perdida.
    • Site temporariamente indisponível.
    • O Servidor de Nomes de Domínio (DNS) não está acessível.
    • O Servidor de Nomes de Domínio (DNS) não tem uma listagem para o domínio do site.
    • Se for um endereço HTTPS (seguro), clique em Ferramentas, clique em Opções da Internet, clique em Avançadas e verifique se os protocolos SSL e TLS estão habilitados na seção de segurança.
    Última edição por lfernandosg; 07-06-2008 às 16:36.

  2. consegui resolver...só comentei a linha:

    192.168.0.200 meudominio.no-ip.info


    dentro do /etc/hosts


    agora já acesso normal externamente...mas agora preciso saber como usar o www.meudominio.com.br pois no everydns já direcionei:

    meudominio.com.br tipo A ip 64.195.x.x
    www.meudominio.com.br tipo CNAME ip meudominio.no-ip.info

    e já está respondendo a ping normalmente e alterei o arquivo: raque l default para:

    NameVirtualHost meudominio.no-ip.info

    <VirtualHost meudominio.no-ip.info>
    ServerName meudominio.com.br
    ServerAlias www.meudominio.com.br
    ServerAdmin ti@nfa.com.br
    DocumentRoot /var/www/teste



    e
    dentro de pico /etc/apache2/sites-available/raquel:

    <VirtualHost meudominio.no-ip.info>
    ServerName meudominio.com.br
    ServerAlias www.meudominio.com.br
    DocumentRoot /var/www/teste
    </VirtualHost>

    e não entra..só consigo entrar pelo: meudominio.no-ip.info


    mas se eu pingar no www.meudominio.com.br recebo resposta do meudominio.no-ip.info.

    o que pode ser?






Tópicos Similares

  1. apache+virtual hosts+no-ip
    Por nozey no fórum Servidores de Rede
    Respostas: 13
    Último Post: 02-02-2005, 00:07
  2. dns no-ip.com
    Por mabarros no fórum Servidores de Rede
    Respostas: 4
    Último Post: 09-10-2004, 11:14
  3. problema com o apache + mandrake 10 + no-ip
    Por Alexandre Oliveira no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-06-2004, 23:57
  4. WWW.NO-IP.COM Como ligo APACHE para ser visivel por fora.
    Por danielcesar no fórum Servidores de Rede
    Respostas: 5
    Último Post: 31-03-2004, 15:15
  5. iptables com NO-IP URGENTE!!!!!
    Por zeroaguiar no fórum Servidores de Rede
    Respostas: 3
    Último Post: 10-03-2004, 08:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L