Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Como falei, aqui estou novamente para trazer mais uma solução para conexão remota. Desta vez mostrarei como fazer conexão remota entre dois servidores mikrotik de forma sergura, crítica que registrei no poste anterior e eu o agradeço por tal atenção, afinal? Quem não quer realizar conexões com segurança? Valeu amigos, uma abraço, espero que desta vez... Vou logo pedindo desculpas se já existe o mesmo tópico no forum, podendo, assim, remover este.

    Nosso cenário é o seguinte:

    - Temos 2 servidores em cidades diferentes e ap-mikotik ou access point em nossa rede local, e queremos acessar da outra cidade os aps e ap-mikrotik, no caso. O que temos que fazer?
    - Criar uma conexão segura entre os servidores mikrotik e criar mais uma quando estiver com um notebook ou em outro pc
    em outra cidade que não seja onde estão os servidores mikrotik.

    Seguindo este ponto de partida vamos brincar!

    Note: Vamos apenas focar no assunto principal, o resta da configuração (masquerade, etc, etc) é por conta de vocês.


    Configuração do servidor da cidade A

    1º Passo
    Configurar nossas interfaces (se você já tiver tudo configurado, basta alterar para sua faixa de rede), atribui nomes as interfaces para um melhor entendimento.:

    /interface set ether1 name=internet
    /interface set ether2 name=network


    2º Passo
    Configurar nossos endereços IP:

    /ip address add address=172.16.2.254/24 interface=network
    /ip address add address=192.168.1.2/24 interface=internet


    3º Passo
    Criar o usuário para logar no servidor PPTP:
    /ppp secret add service=pptp name=user1 password=1234 remote-address=10.10.0.2 local-address=10.10.0.1 routes=”172.16.1.254/24 10.10.0.2 1” profile=default

    4º Passo
    Criar uma interface de entrada para o usuário remoto:
    /interface pptp-server add user=user1

    5º Passo
    Habilitar o servidor PPTP, é claro:

    /interface pptp-server server set enable=yes

    6º Passo

    Ajustar o destino para que o user1 consiga acessar a rede local:

    /ip route add dst-address 172.16.1.0/24 gateway 10.10.0.2
    (não estranhe o dst-address, é este mesmo)


    Configuração do servidor da cidade B

    Note: Serve as mesmas coisas que eu escrevi para o servidor local
    em relação às configurações que perdem o foco do post.

    1º Passo

    Configurar nossas interfaces (se você já tiver tudo configurado, basta alterar para sua faixa de rede):

    /interface set ether1 name=internet

    /interface set ether2 name=network

    2º Passo

    Configurar nossos endereços IP:

    /ip address add address=172.16.1.254/24 interface=network

    /ip address add address=192.168.1.3/24 interface=internet

    3º Passo

    Criar a interface de saída:

    /interface pptp-client add connect-to=192.168.1.2 user=user1 password=1234 disabled=no profile=default


    4º Passo

    Criar um route para o nosso servidor remote:

    /ip route add dst-address=172.16.2.0/24 gateway=10.10.0.1


    Tudo configurado!

    Testes

    Testar se está a comunicação este os servidores mikrotik está funcionando:

    /ping 10.10.0.1
    (do remoto para o local)*
    /ping 10.10.0.2 (do local para o remoto)**
    /ping 172.16.2.254 *
    /ping 172.16.1.254 **


    Configurando um computador Windows XP para acessar os dois MikroTiks

    1º Passo
    Criar mais um usuário no servidor da cidade A:

    /ppp secret add name=user2 service=pptp password="1234" profile=default local-address=172.16.2.254 remote-address=172.16.2.10

    Note:
    Na configuração acima, foi atribuído ao usuário uma ip da rede local pois é a partir daí que ele terá acesso aos ips que estam conectados a ela e saír para outras cidades, caso todos os servidores estejam conectados a este.

    2º Passo
    Criar a interface de entrada:

    /interface pptp-server add user=user2

    3º Passo

    Criar a conexão vpn para conectar com o servidor pptp

    • Iniciar - Painel de controle - Conexões de rede - Arquivo - Nova conexão...


    • Conectar-me a uma rede em meu local de trabalho
    • Conexão VPN
    • Nome da empresa
    • Nome do host ou ip: coloque o ip do gateway(ISP) onde está criado o servidor PPTP

    Agora é só testar pingando para as duas redes:

    Iniciar - executar - ping 172.16.2.254
    Iniciar - executar - ping 172.16.1.254


    Observe:
    Se não tiver conseguindo conexão, mude na interface de rede local do servidor PPTP a opção ARP para proxy-arp.
    Bem, eu vou ficando por aqui e até outra vez, espero que seja o mais breve.

    Dica: você poderá gerenciar todos* os seus mikrotiks a partir de apenas um.

    É isto aí, vou ficando por aqui e até a próxima, vão desculpando se faltou algo, mas ajeitamos ao decorrer das discussoes.

    Qualquer coisa...
    Última edição por Raniel; 14-06-2008 às 01:59.

  2. Agora sim...hehehehe.

    Obrigado pelo post. Só um detalhe (no caso especifico do Mikrotik):

    Use no seu modelo, em profile, o default-encryption, pois é o que encaixa-se melhor em PPtP.



  3. Esse post ficou muito bom, agora mata qualquer dúvida sobre o assunto.

    Abraços,

    Renato Costa.

  4. Eu nao acompanhei o tal topico anterior.

    mas seria muito mais facil apenas configurar as rotas e ips?

    ou seja apenas duas coisinhas no MK.

    flw,

    abraços!



  5. Mas isso que vc falou Danilo é roteamento, o que os amigos estão descrevendo é uma VPN, para que seu computador de onde estiver faça parte da rede em que deseja entrar.

    Abraços,

    Renato Costa.

    Citação Postado originalmente por daniloacr Ver Post
    Eu nao acompanhei o tal topico anterior.

    mas seria muito mais facil apenas configurar as rotas e ips?

    ou seja apenas duas coisinhas no MK.

    flw,

    abraços!






Tópicos Similares

  1. Tutorial DDNS para Acesso Remoto ao Mikrotik ROS
    Por magrock no fórum Tutoriais
    Respostas: 229
    Último Post: 09-01-2017, 23:04
  2. Acesso Remoto ao Mikrotik
    Por CSilva no fórum Redes
    Respostas: 12
    Último Post: 08-06-2014, 09:09
  3. Acesso remoto ao mikrotik
    Por Aredeprovedor no fórum Redes
    Respostas: 5
    Último Post: 21-05-2012, 08:54
  4. Myauth2 + Acesso remoto ao Mikrotik
    Por fabcia no fórum Redes
    Respostas: 0
    Último Post: 20-05-2011, 14:34
  5. Acesso remoto ao mikrotik - solucao
    Por Raniel no fórum Redes
    Respostas: 43
    Último Post: 09-09-2008, 12:08

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L