Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal,

    Estou criando um programinha em delphi para conectar ao mikrotik via telnet, e nele fiz uma parte para controle de horário(habilitar e desabilitar o mac do arp em tal hora, lembrando que não optei por firewall).

    O problema é o seguinte:
    Quando eu executo:

    /system script add name=controle policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/ip arp disable [/ip arp find address=192.168.0.2]"

    É retornado o seguinte erro, isto no terminal do winbox:

    invalid argument name

    E executando o mesmo comando, mas com a source diferente ele não dá erro.

    Outra coisa que gostaria de pedir pelo Amor de Deus.
    Alguém pode me mostra um exemplo de como exibir o retorno do telnet no programinha? Sei que é pelo dataAvaliable mas não estou conseguindo.

    Agradeço pessoal.

  2. Citação Postado originalmente por Mr. RG Ver Post
    Olá pessoal,

    Estou criando um programinha em delphi para conectar ao mikrotik via telnet, e nele fiz uma parte para controle de horário(habilitar e desabilitar o mac do arp em tal hora, lembrando que não optei por firewall).

    O problema é o seguinte:
    Quando eu executo:

    /system script add name=controle policy=ftp,read,ssh,test,winbox,local,policy,reboot,telnet,web,write source="/ip arp disable [/ip arp find address=192.168.0.2]"

    É retornado o seguinte erro, isto no terminal do winbox:

    invalid argument name

    E executando o mesmo comando, mas com a source diferente ele não dá erro.

    Outra coisa que gostaria de pedir pelo Amor de Deus.
    Alguém pode me mostra um exemplo de como exibir o retorno do telnet no programinha? Sei que é pelo dataAvaliable mas não estou conseguindo.

    Agradeço pessoal.


    seguinte acho q o teu problema eh o seguinte, teu programa ta mandando criar um script chamado de controle, na primeira vez tudo bem ira cria o arquivo mas na segunda em diante como ira criar o mesmo arquivo denovo? com o mesmo nome? nao tem como, o mkt acho q nao substitue entao faco o programa gerar o necessario
    /ip arp disable [/ip arp find address=192.168.0.2]

    no retorno do delphi vc simplesmente trata a variavel buffer que eh uma string se nao me engano.

    exemplo : showmessage(buffer);

    espero ter ajudado



  3. Citação Postado originalmente por gzanatta00 Ver Post
    ...
    teu programa ta mandando criar um script chamado de controle, na primeira vez tudo bem ira cria o arquivo mas na segunda em diante como ira criar o mesmo arquivo denovo? com o mesmo nome? nao tem como, o mkt acho q nao substitue entao faco o programa gerar o necessario
    /ip arp disable [/ip arp find address=192.168.0.2]

    ...
    Olá amigo,
    A regra que postei faz o seguinte, e estou executando pelo terminal do mikrotik, por veriguação:
    Cria um script no /system script que terá o código fonte /ip arp disable [....]
    Quando crio a mesma regra para o scheduler ela não dá erro, só da erro quando inserir o fonte e quando não dá erro, o fonte fica em branco, testei em outras versões e dá a mesma coisa, pode ser um bug do mikrotik.

    Citação Postado originalmente por gzanatta00 Ver Post
    ...
    no retorno do delphi vc simplesmente trata a variavel buffer que eh uma string se nao me engano.

    exemplo : showmessage(buffer);

    ...
    Vou testar este comando.

    Obrigado.

  4. Qual a versão do MK que está usando??
    Pois tem diferenca entre o MK 2.9.xx e o MK 3.xx



  5. tente esse codigo abaixo

    /system script add name="controle" \
    source="/ip arp disable \[/ip arp find address=192.168.0.2\]" \
    policy=ftp,reboot,read,write,policy,test,winbox,password






Tópicos Similares

  1. Telnet + Delphi 2007 comando WriteLn não funciona
    Por nilsonalvernaz no fórum Redes
    Respostas: 7
    Último Post: 09-10-2008, 20:01
  2. Comando SMBMOUNT nao funciona.
    Por vinidnb no fórum Servidores de Rede
    Respostas: 3
    Último Post: 19-04-2007, 23:58
  3. comando ls não funciona.
    Por Waltinhorj no fórum Sistemas Operacionais
    Respostas: 7
    Último Post: 14-03-2006, 07:41
  4. Respostas: 0
    Último Post: 12-07-2005, 15:42
  5. Comando SETUP no SUSE não funciona..
    Por rfdasilva1 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 22-10-2003, 20:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L