Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. É o seguinte pessoal, tenho um servidor com duas interfaces de rede eth1 (rede interna) eth0 (internet), a interface eth1
    está ligada em um hub onde tem x maquinas ligadas e um ap configurado em modo ap mesmo com a mesma faixa de ips, nesse ap tem
    outro ap fazendo brigde entre esse ap e um outro ap também configurado como bridge, todos usando a mesma classe de ip.

    ou seja:

    Eth0-Servidor-Eth1-Hub-Ap-Ap2(bridge)-Ap3(bridge)-Rede Secundária

    onde:
    Eth0: 201.x.x.x (Internet)
    Eth1: 192.168.2.1 (Rede Primária)
    Ap: 192.168.2.100 (Rádio em modo AP)
    Ap2: 192.168.2.110 (Rádio em modo bridge)
    Ap3: 192.168.2.120 (Rádio em modo bridge)
    Rede Secundária: 192.168.2.x (Rede Secundária)

    NetMask: 255.255.255.0


    Regras de NAT (Iptables)

    iptables --flush
    iptables --table nat --flush
    iptables --delete-chain
    iptables --table nat --delete-chain

    iptables --table nat --append POSTROUTING --out-interface eth0 -j MASQUERADE
    iptables --append FORWARD --in-interface eth1 -j ACCEPT

    echo 1 > /proc/sys/net/ipv4/ip_forward


    Agora o problema....

    a rede secundária só consegue acessar a internet utilizando proxy autenticado (squid), se pingar da Rede Secundária
    para a internet não retorna resposta alguma, para o restante da rede está respondendo normalmente. A rede primária consegue
    pingar normalmente para a internet, e também consegue acessar a internet sem o proxy, isso comprova que o nat está funcionando
    corretamente, então porque não acontece o mesmo com a rede secundária? preciso fazer roteamento no servidor mesmo usando a mesma faixa
    de ips e o mesmo netmask? como deverá ser esse roteamento? se consigo pingar da rede interna para rede secundária e vice-versa
    teóricamente o roteamento entre elas está certo, não?

    Valeu, isso está me dando dor de cabeça já há muito tempo.

  2. Você disse que a rede primária consegue pingar pra internet. De onde você testou esse ping?? de uma estação conectada ao hub?? Você tem 3 APs, o AP2 e o AP3 estão conectados ao AP certo?? O pessoal dessa "rede secundária" ta vindo de qual AP??

    Aparentemente o problema não é roteamento nem NAT...
    Última edição por Magnun; 16-06-2008 às 21:02.



  3. sim a rede primária está conectada com o hub, como eu citei o ap que está ligado no hub está como ap, os outros dois fazem bridge com a rede interna através desse ap, a rede interna acessa a rede dos aps tranquilamente e vice-versa.

    Na lista de discussão do debian eu recebi algumas dicas em relação ao firewall, parece que os pacotes que passem pelos aps vem com flags especificas, amanhã vou testar e se der certo posto aqui.

  4. O AP geralemente fazem marcação de prioridade e pra QoS, mas isso não deveria influenciar no FW a menos que você esteja especificando a permissão de apenas algumas flags...



  5. Não tem algum equipamento proxy_arp nessa sua rede não?






Tópicos Similares

  1. Respostas: 5
    Último Post: 29-06-2012, 11:44
  2. Respostas: 2
    Último Post: 15-12-2010, 13:20
  3. Respostas: 7
    Último Post: 13-06-2008, 11:19
  4. Ap mk bridge não pinga server mk o e trava o ap!!!
    Por airtonveiga no fórum Redes
    Respostas: 2
    Último Post: 25-11-2007, 12:41
  5. AP -> Client -> AP em Bridge.
    Por klemensonleal no fórum Redes
    Respostas: 11
    Último Post: 13-04-2007, 11:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L