+ Responder ao Tópico



  1. #1

    Thumbs down problemas com LB em Adsl

    galera boa tarde, é o seguinte fiz a configuração do mk com 2 adsl um sendo da gvt e outro da brt sendo os dois como router e usando o script do mikrotik mesmo para o LB sendo estes assim:
    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Lan comment="" \
    disabled=no
    add address=192.168.254.254/24 network=192.168.254.0 broadcast=192.168.254.255 interface=link2 \
    comment="" disabled=no
    add address=10.1.1.5/24 network=10.1.1.0 broadcast=10.1.1.255 interface=link1 \
    comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting in-interface=lan connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=link2 passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=lan connection-mark=link2 action=mark-routing \
    new-routing-mark=link2 passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=lan connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=link1 passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=lan connection-mark=link1 action=mark-routing \
    new-routing-mark=link1 passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=link2 action=src-nat to-addresses=192.168.254.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=link1 action=src-nat to-addresses=10.1.1.5 \
    to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=link2 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=link1 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 comment="" \
    disabled=no
    e esta muito ruim demora pra abrir paginas para carregar video e tal, sendo que quando coloco qualquer um dos dois sozinhos eles funcionam bem .... alguem pode me ajudar?

  2. #2

    Padrão

    Citação Postado originalmente por Projeto_Destino Ver Post
    galera boa tarde, é o seguinte fiz a configuração do mk com 2 adsl um sendo da gvt e outro da brt sendo os dois como router e usando o script do mikrotik mesmo para o LB sendo estes assim:
    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Lan comment="" \
    disabled=no
    add address=192.168.254.254/24 network=192.168.254.0 broadcast=192.168.254.255 interface=link2 \
    comment="" disabled=no
    add address=10.1.1.5/24 network=10.1.1.0 broadcast=10.1.1.255 interface=link1 \
    comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting in-interface=lan connection-state=new nth=1,1,0 \
    action=mark-connection new-connection-mark=link2 passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=lan connection-mark=link2 action=mark-routing \
    new-routing-mark=link2 passthrough=no comment="" disabled=no
    add chain=prerouting in-interface=lan connection-state=new nth=1,1,1 \
    action=mark-connection new-connection-mark=link1 passthrough=yes comment="" \
    disabled=no
    add chain=prerouting in-interface=lan connection-mark=link1 action=mark-routing \
    new-routing-mark=link1 passthrough=no comment="" disabled=no
    / ip firewall nat
    add chain=srcnat connection-mark=link2 action=src-nat to-addresses=192.168.254.2 \
    to-ports=0-65535 comment="" disabled=no
    add chain=srcnat connection-mark=link1 action=src-nat to-addresses=10.1.1.5 \
    to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=link2 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 routing-mark=link1 \
    comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=255 target-scope=10 comment="" \
    disabled=no
    e esta muito ruim demora pra abrir paginas para carregar video e tal, sendo que quando coloco qualquer um dos dois sozinhos eles funcionam bem .... alguem pode me ajudar?



    para funcionar o balance com links distintos eh necessario um dns que funcione para os dois links, nao adianta colokar primario 1 e secundario outro que nao funciona.
    para isso ligue o link 1 por 1 no seu pc e encontre na internet algum dns que resolva para os dois links.... flw abraços.



  3. #3

    Padrão

    Olá amigo,

    Tem esta forma que é mais simples:

    Linux: Balanceamento de carga com 2 links no MikroTik [Artigo]

    Quanto ao dns, pode usar da maneira que está, criando um dns local para o mikrotik, assim poderá colocar a rede toda nele.

    /ip dns static add name=local address=ip_do_servidor_mikrotik

  4. #4

    Padrão

    bom amigos Romeu e Mr.RG eu nõ consegui nda de progresso mesmo trocando os dns não obtive sucesso nenhum, e a questão de dividir em grupos agora ta fora de questão pois acontece que são mais de 70 clientes ir de cliente em cliente só pra trocar o gateway ta fora de cogitação. a questão é que com um link só o negocio anda bem mais colocando os dois o negocio anda mal.... se tiverem mais opniões a respeito eu agradeço.



  5. #5
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão LB

    Projeto faça um teste deixe os dois links dentro da mesma classe tipo 192.168.1.1/24 e o outro em 192.168.2.1/24.
    Tive um problema e assim resolvi.

  6. #6

    Padrão

    Citação Postado originalmente por Projeto_Destino Ver Post
    bom amigos Romeu e Mr.RG eu nõ consegui nda de progresso mesmo trocando os dns não obtive sucesso nenhum, e a questão de dividir em grupos agora ta fora de questão pois acontece que são mais de 70 clientes ir de cliente em cliente só pra trocar o gateway ta fora de cogitação. a questão é que com um link só o negocio anda bem mais colocando os dois o negocio anda mal.... se tiverem mais opniões a respeito eu agradeço.


    e garoto esqueceu de postar o resultado aqui ne...
    eh so fazer como nosso amigo aqui postou, poem dentro da mesma faxa de rede e pronto...abraços



  7. #7

    Padrão

    Citação Postado originalmente por Projeto_Destino Ver Post
    bom amigos Romeu e Mr.RG eu nõ consegui nda de progresso mesmo trocando os dns não obtive sucesso nenhum, e a questão de dividir em grupos agora ta fora de questão pois acontece que são mais de 70 clientes ir de cliente em cliente só pra trocar o gateway ta fora de cogitação. a questão é que com um link só o negocio anda bem mais colocando os dois o negocio anda mal.... se tiverem mais opniões a respeito eu agradeço.
    Com o balanceamento de carga, você não irá mudar o gateway e sim dividir a rede em dois grupos com um mesmo gateway.

  8. #8

    Padrão

    amigo vou tentar dividir em dois grupos sem mudar o gw e postu o resultado aki....