Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Proxy com servidor paralelo

    Pessoal segui esse tutorial mais nao estou conseguindo fazer funcionar
    Linux: Proxy em paralelo com o mikrotik [Artigo]

    Estou tentando fazer mais sem sucesso, vi mensagens de outras pessoas e falaram que funcionou. Mesmo sendo facil seguir o tutorial to tendo duvidas e gostaria que vcs me ajudassem.
    1ª Duvida: Tenho que cadastrar o Mac e o Ip do Debian no ARP do Mikrotik?

    2ª Duvida: Na parte de configuraçao do squid tem umas linhas que nao entendi
    #permissão de acesso ao proxy, troque 0.0.0.0/0 pela sua
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    Meus clientes usam os Ips 192.168.1.0/24 entao devo deixar:
    acl redelocal src 192.168.1.0/24 ???

    3ª Duvida: em IP- FIREWALL NAT tem uma configuraçao que pede o IP VALIDO DO SERVIDOR, mais uso adsl e nao tenho ip valido o que devo colocar?
    Conto com ajuda de vcs e desculpas tantas perguntas...

  2. #2

    Padrão

    tentando responder as suas duvidas:
    1ª= se na interface que tiver a conexão a tabela arp estiver em reply-only vc tem que cadastrar o mac e o ip do debian manual.
    2ª= vc esta correto basta mudar a origem pra sua range da rede local mesmo.
    3ª= não foi claro sua questão, se for no mikrotik, pra redirecionar pra o squid do debian, vc deve coloca ro ip do debian.

    qualquer cosia posta ae novamente



  3. #3

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    tentando responder as suas duvidas:
    1ª= se na interface que tiver a conexão a tabela arp estiver em reply-only vc tem que cadastrar o mac e o ip do debian manual.
    2ª= vc esta correto basta mudar a origem pra sua range da rede local mesmo.
    3ª= não foi claro sua questão, se for no mikrotik, pra redirecionar pra o squid do debian, vc deve coloca ro ip do debian.

    qualquer cosia posta ae novamente
    Parceiro de uma olhada nesse endereço que vc vai entender minha 3ª pergunta.
    Linux: Proxy em paralelo com o mikrotik [Artigo]
    O IP do debian é 192.168.10.2 fiz do jeito que está lá, só resta a duvida do "Ip valido do Servidor"
    Grato pela ajuda...

  4. #4



  5. #5

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    bem amigo,

    coloca o gateway de seu servidor ae,

    Coloquei, mais continua nao funcionando, nao sei mais o que fazer, qdo habilito a regra nat de redirecionamento nao navega e aparare ERROR Gateway timeout, lembrando que segui o tutorial...
    agradeço novamente sua ajuda.

  6. #6

    Padrão

    Citação Postado originalmente por simprao Ver Post
    ...
    3ª Duvida: em IP- FIREWALL NAT tem uma configuraçao que pede o IP VALIDO DO SERVIDOR, mais uso adsl e nao tenho ip valido o que devo colocar?
    Conto com ajuda de vcs e desculpas tantas perguntas...
    Quando ele falou do ip válido, é para colocar o ip da interface que recebe o link de internet.

    Última edição por Raniel; 19-06-2008 às 19:35.



  7. #7

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Quando ele falou do ip válido, é para colocar o ip da interface que recebe o link de internet.

    Obrigado pela ajuda...Tentei com esse ip tbm e nao dá certo, qdo eu habilito a NAT de redirecionamento nao navega, da erro de gatway timeout mas msn continua conectado

  8. #8

    Padrão

    coloca assim no mk:
    va no new terminal e adiciona essa regra :
    / ip firewall nat
    add chain=dstnat in-interface=Rede_Interna protocol=tcp dst-port=80 action=src-nat action=src-nat to-addresses=Ip_do_debian to-ports=3128 comment="" \



  9. #9

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    coloca assim no mk:
    va no new terminal e adiciona essa regra :
    / ip firewall nat
    add chain=dstnat in-interface=Rede_Interna protocol=tcp dst-port=80 action=src-nat action=src-nat to-addresses=Ip_do_debian to-ports=3128 comment="" \
    Amigo Josevaldo coloquei o comando que vc me passou e apareceu a seguinte mensagem:
    failure: dstnat chain can not contain masquerade/snat actions. Agradeço sua vontade de me ajudar, peço que nao desista de me ajudar, rsrsrs.

  10. #10

    Padrão

    Citação Postado originalmente por simprao Ver Post
    Amigo Josevaldo coloquei o comando que vc me passou e apareceu a seguinte mensagem:
    failure: dstnat chain can not contain masquerade/snat actions. Agradeço sua vontade de me ajudar, peço que nao desista de me ajudar, rsrsrs.

    Olá amigo,
    Este erro ocorre quando há ações de masquerade em de redirecionamento.
    Coloque assim:
    /ip firewall nat add chain=dstnat src-address=1.1.1.0/24 protocol=tcp dst-port=80 action=dst-nat to-address=10.10.10.1 to-port=28
    Última edição por Raniel; 19-06-2008 às 22:02.



  11. #11

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Quando ele falou do ip válido, é para colocar o ip da interface que recebe o link de internet.

    Boa noite Mr. RG, agradeço novamente sua ajuda. Coloquei o ip da interface do modem e nao dá certo, qdo habilito o redirecionamento aparece a mensagem no navegador:
    ERROR: Gateway Timeout
    --------------------------------------------------------------------
    Your cache administrator is webcache.
    --------------------------------------------------------------------
    Generated Fri, 20 Jun 2008 21:06:34 GMT by 10.0.0.1 (Mikrotik HttpProxy) . Lembrando que fiz as outras configuraçoes igual ao do tutorial. O Ip do debian tá 192.168.10.2 gat e dns 192.168.10.1, Ip da interface da internet 10.1.2.10, saida para os clientes 10.0.0.0/24 sendo que o gat e dns para os clientes é 10.0.0.1, igualzinho o tutorial, no campo ip valido coloquei 10.1.2.10. Não sei mais o que fazer, peço mais uma vez sua ajuda...

  12. #12

    Padrão

    meu caro,
    vou rever o tutorial, e testá-lo so assim então para verificar onde esta a falha.
    se possivel, ae da forma que está, experimenta pingar no ip do debain 192.168.10.2;
    caso não tenha resposta, acrescente um ip da mesma range no seu mikrotik, ex: 192.168.10.3.
    e vejá se depois com respsota no ip se a regra já nõa vai funcionar.



  13. #13

    Padrão

    Citação Postado originalmente por simprao Ver Post
    ...

    Coloquei o ip da interface do modem e nao dá certo, qdo habilito o redirecionamento aparece a mensagem no navegador:
    ERROR: Gateway Timeout

    ...
    Olá amigo,
    Eu achei que o seu modem estava em bridge, neste caso, você coloca o ip da interface de rede que recebe ip do modem.

  14. #14

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Olá amigo,
    Eu achei que o seu modem estava em bridge, neste caso, você coloca o ip da interface de rede que recebe ip do modem.
    Amigo, já coloquei o ip do modem, tentei tbm o ip da interface do modem e nada consta, nao tenho mais ideia do que fazer...



  15. #15

    Padrão

    Citação Postado originalmente por Josevaldo Ver Post
    meu caro,
    vou rever o tutorial, e testá-lo so assim então para verificar onde esta a falha.
    se possivel, ae da forma que está, experimenta pingar no ip do debain 192.168.10.2;
    caso não tenha resposta, acrescente um ip da mesma range no seu mikrotik, ex: 192.168.10.3.
    e vejá se depois com respsota no ip se a regra já nõa vai funcionar.
    Ok Josevaldo, se possivel qdo testar e achar onde está o meu erro posta aí faz favor, ficarei muito grato...

  16. #16

    Padrão

    Citação Postado originalmente por simprao Ver Post
    Amigo, já coloquei o ip do modem, tentei tbm o ip da interface do modem e nada consta, nao tenho mais ideia do que fazer...
    Estou falando do ip que está na interface do mikrotik.
    Ex:

    ether1 ip = 200.221.3.4
    ether2 rede local

    Falei para colocar o ip da interface que está recebendo o ip do modem, no caso, 200.221.3.4

    Se pudesse colocar seu modem em bridge...



  17. #17

    Padrão

    Olá amigo,
    Como outras pessoas podem ter a mesma dúvida, postei este material agora a pouco para que todos possam ter acesso:

    https://under-linux.org/forums/mikro...m-o-linux.html

    Dá uma conferida e veja se dá certo para seu problema.

  18. #18

    Padrão

    opa galera eu queria saber como fica nos logs do squid, se fica o ip do cliente que acessou o site, ou o ip do servidor, pois agora a justiça vai obrigar a nós provedores a guardar logs de clientes por 3 anos.

    web-proxy,debug,packet 1214364140.519 19 192.168.16.25 TCP_IMS_HIT/304 216 GET http://www.bb.com.br/docs/home/inst/...ntaPessoal.gif - NONE/- image/gif in 24-Jun 23:22:27.75 from 192.168.10.1

    podemos perceber ai que aparece o ip 192.168.16.25 solicitando o site do bb, se eu bota pra fazer um parent proxy, qual ip vai? do cliente ou do servidor?



  19. #19

    Padrão

    simprao estou com o mesmo problema que o seu consegui resolver se consegui me da uma ideia do que fazer se eu achar te falo.
    blz um abraço.


    Citação Postado originalmente por simprao Ver Post
    Boa noite Mr. RG, agradeço novamente sua ajuda. Coloquei o ip da interface do modem e nao dá certo, qdo habilito o redirecionamento aparece a mensagem no navegador:
    ERROR: Gateway Timeout
    --------------------------------------------------------------------
    Your cache administrator is webcache.
    --------------------------------------------------------------------
    Generated Fri, 20 Jun 2008 21:06:34 GMT by 10.0.0.1 (Mikrotik HttpProxy) . Lembrando que fiz as outras configuraçoes igual ao do tutorial. O Ip do debian tá 192.168.10.2 gat e dns 192.168.10.1, Ip da interface da internet 10.1.2.10, saida para os clientes 10.0.0.0/24 sendo que o gat e dns para os clientes é 10.0.0.1, igualzinho o tutorial, no campo ip valido coloquei 10.1.2.10. Não sei mais o que fazer, peço mais uma vez sua ajuda...

  20. #20

    Padrão

    Citação Postado originalmente por angelino Ver Post
    simprao estou com o mesmo problema que o seu consegui resolver se consegui me da uma ideia do que fazer se eu achar te falo.
    blz um abraço.
    Parceiro fiz aqui e agora aparenta esta funcionando mais nao tenho certeza. Meu erro estava sendo que depois de instalado o squid e configurado eu nao tinha dado o comando # "squid -z" faça isso do debian e tenta de novo...