+ Responder ao Tópico



  1. #1

    Padrão fazer alguns sites nao passar pelo proxy

    fala galera!!

    eu tenho aqui um squid em um debian fazendo cache, ta em transparent!!
    no mikrotik ativei o web-proxy dele com o ip e porta do squid em parent...
    e fiz um dstnat com redirect pra porta que configurei no web-proxy do mikrotik..
    até ai rodando tudo blza, rapidinho como deveria!

    mas tem a questão dos sites como rapidshare que utilizam o ip pra saber quem ja baixou!! e imagina todos meus clientes usando apenas 1 ip (do squid) pra baixar!!

    acontece que preciso tirar esses sites do cache, faze-los passar por fora do squid pra nao sair com o ip dele.

    como que faria isso? tentei por ip, mas o rapidshare deve ter dezenas de ranges diferentes.

    alguem me dê uam luz por favor...
    desde já, obrigado!!

  2. #2

    Padrão

    Olá

    Em IP >> Firewall >> Nat, libere o site que não quer que passe pelo proxy. Abaixo um exemplo da regra (antes da regra que redirecionar para o proxy)

    :;; Libera a rede da CEF
    chain=dstnat dst-address=200.201.174.0/24 action=accept

    ;;; Libera outra rede da CEF
    chain=dstnat dst-address=200.201.173.0/24 action=accept

    Att.



  3. #3

    Padrão

    Citação Postado originalmente por bauer Ver Post
    Olá

    Em IP >> Firewall >> Nat, libere o site que não quer que passe pelo proxy. Abaixo um exemplo da regra (antes da regra que redirecionar para o proxy)

    :;; Libera a rede da CEF
    chain=dstnat dst-address=200.201.174.0/24 action=accept

    ;;; Libera outra rede da CEF
    chain=dstnat dst-address=200.201.173.0/24 action=accept

    Att.
    sim..o problema é a quantidade imensa de ip's que o rapidshare, por exemplo, tem!!

    eu testei esse final de semana e deu certo fazendo assim:

    no web-proxy, criei uma regra na aba Direct:


    / ip web-proxy direct
    add url="rapidshare" action=allow comment="" disabled=no
    add url="rjnet" action=allow comment="" disabled=no
    add url="showip" action=allow comment="" disabled=no
    add url="megaupload" action=allow comment="" disabled=no
    add url="4shared" action=allow comment="" disabled=no


    pelo menos esta dando certo..

    mas muito obrigaado pela ajuda.
    quem tiver outras soluções, agradeço tambem.

    muito obrigado.

    abraços