+ Responder ao Tópico



  1. Boa tarde pessoal do forum, segui os tutoriais sobre como fazer o proxy em paralelo com mk e acredito que consegui fazer funcionar, mais nao tenho certeza. Fiz o seguinte teste: tenho um link de adsl de 1MB no mk liberei 2MB pra minha maquina e fiz um donwload de um arquivo, fez na velocidade de aprox. 110Kbps, todas as interfaces tinham trafegos, depois limpei historico e todos os residuos desse arquivo e fiz novamente o download. Na meu pensamento se o proxy estiver funcionando esse arquivo tem que vim do servidor paralelo e a velocidade do download tem que ser pelo menos de 200Kbps pois liberei 2MB, e isso nao esta acontecendo, ele faz o download na mesma velocidade e puxa da internet novamente.
    Alguem sabe o que pode ser? Ou estou falando bobagem?
    Última edição por simprao; 27-06-2008 às 22:09.

  2. A melhor forma de se saber se o cache está funcionando é primeiramente ter certeza que os arquivos estão sendo salvos na pasta definida no ato da configuração.

    Estando salvos basta desativar a interface de conexão à internet e tentar fazer o acesso ao site que já foi descarregado.

    Se abrir está funcionando, se não abrir existe problema na configuração. Cache é uma coisa que não tem meio termo ou está ou não está funcionando.

    No seu caso pelo que dá pra notar ele pode até estar fazendo o download para o cache mais o cache não está fornecendo as informações para as estações utilizando o link dobrado: Cliente e Servidor Cache.

    Faça o teste que lhe falei e verifique.



  3. Citação Postado originalmente por simprao Ver Post
    Boa tarde pessoal do forum, segui os tutoriais sobre como fazer o proxy em paralelo com mk e acredito que consegui fazer funcionar, mais nao tenho certeza. Fiz o seguinte teste: tenho um link de adsl de 1MB no mk liberei 2MB pra minha maquina e fiz um donwload de um arquivo, fez na velocidade de aprox. 110Kbps, todas as interfaces tinham trafegos, depois limpei historico e todos os residuos desse arquivo e fiz novamente o download. Na meu pensamento se o proxy estiver funcionando esse arquivo tem que vim do servidor paralelo e a velocidade do download tem que ser pelo menos de 200Kbps pois liberei 2MB, e isso nao esta acontecendo, ele faz o download na mesma velocidade e puxa da internet novamente.
    Alguem sabe o que pode ser? Ou estou falando bobagem?
    Para saber melhor o que está acontecendo, seria interessante que você postasse suas regras.

    Mas você pode verificar algumas coisas, por exemplo:

    1) Verifique em IP > web proxy > Settings > Status se aparece pelo menos um cliente conectado (no campo Clients)

    2) O campo Hits indica o numero de requisições encontradas em cache e repassadas aos clientes. Então, tente verificar se este numero aumenta ao iniciar o download.

    3) O campo Hits Sent To Clients indica quantos kylobytes (kibibytes, na verdade) foram enviados aos clientes, ou seja, o quanto o numeros de hits representa em quantidade de dados que não precisaram ser baixados da Internet, poupando link. Verifique se este campo tambem aumenta.

    4) Verifique se o arquivo que você está baixando para testes é menor do que o tamanho especificado em Maximum Object Size, na aba General

    Talvez falei coisas que você já sabia, mas espero ter ajudado.

    Por favor, posta aí o resultado.

  4. Ricardowz, lendo seu post, fui conferir no meu servidor se realmente estava funcionando e vi que não está... conferi no meu servidor proxy uso o squid, nas pastas do cache, ele está incrementando elas... elas estão recebendo arquivos, mas no meu mikrotik, o campo hits e hits sent to clientes, estão com 0. veja o monitor do proxy como está:
    status: running
    uptime: 3d18h1m35s
    requests: 1638150
    hits: 0
    cache-used: 0KiB
    total-ram-used: 2971KiB
    received-from-servers: 24209248KiB
    sent-to-clients: 23855389KiB
    hits-sent-to-clients: 0KiB

    E veja abaixo as configurações do meu web proxy, não sei porque não está encaminhando aos clientes os arquivos:

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 192.168.10.2
    parent-proxy-port: 5128
    cache-drive: system
    cache-administrator: "webcache"
    max-cache-size: none
    cache-on-disk: no
    max-client-connections: 5000
    max-server-connections: 5000
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    ou se preferir os scripts abaixo:

    /ip proxy
    set always-from-cache=no cache-administrator="webcache" cache-drive=system \
    cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none \
    max-client-connections=5000 max-fresh-time=3d max-server-connections=5000 \
    parent-proxy=192.168.10.2 parent-proxy-port=5128 port=3128 \
    serialize-connections=no src-address=0.0.0.0

    /ip proxy access
    add action=allow comment="" disabled=no src-address=50.10.10.0/24
    add action=deny comment="" disabled=no

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment="place hotspot rules \
    here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=50.10.10.0/24
    add action=masquerade chain=srcnat comment="masquerade proxy" disabled=no \
    src-address=192.168.10.0/24
    add action=redirect chain=dstnat comment="redirecionamento para proxy" \
    disabled=no dst-address=!201.48.16.XXX dst-port=80 in-interface=LAN \
    protocol=tcp src-address=50.10.10.0/24 to-ports=3128


    Citação Postado originalmente por ricardowz Ver Post
    Para saber melhor o que está acontecendo, seria interessante que você postasse suas regras.

    Mas você pode verificar algumas coisas, por exemplo:

    1) Verifique em IP > web proxy > Settings > Status se aparece pelo menos um cliente conectado (no campo Clients)

    2) O campo Hits indica o numero de requisições encontradas em cache e repassadas aos clientes. Então, tente verificar se este numero aumenta ao iniciar o download.

    3) O campo Hits Sent To Clients indica quantos kylobytes (kibibytes, na verdade) foram enviados aos clientes, ou seja, o quanto o numeros de hits representa em quantidade de dados que não precisaram ser baixados da Internet, poupando link. Verifique se este campo tambem aumenta.

    4) Verifique se o arquivo que você está baixando para testes é menor do que o tamanho especificado em Maximum Object Size, na aba General

    Talvez falei coisas que você já sabia, mas espero ter ajudado.

    Por favor, posta aí o resultado.



  5. Veja o monitor do proxy como está:
    status: running
    uptime: 3d18h1m35s
    requests: 1638150
    hits: 0
    cache-used: 0KiB
    total-ram-used: 2971KiB
    received-from-servers: 24209248KiB
    sent-to-clients: 23855389KiB
    hits-sent-to-clients: 0KiB

    Parceiro o meu está igual ao seu e tbm nao tenho certeza se está funcionando, e lembrando aos amigos do forum esse proxy é paralelo!!!






Tópicos Similares

  1. Respostas: 75
    Último Post: 05-05-2009, 15:38
  2. Detalhando proxy paralelo com o linux
    Por Raniel no fórum Redes
    Respostas: 124
    Último Post: 09-03-2009, 19:08
  3. Duvidas esquema de ProXy Paralelo
    Por simprao no fórum Redes
    Respostas: 17
    Último Post: 15-10-2008, 12:22
  4. MK 3.14 -> Proxy Paralelo ou Nativo do RouterOS?
    Por GEISSONHUGO no fórum Redes
    Respostas: 10
    Último Post: 14-10-2008, 10:02
  5. Proxy paralelo, qual maquina utilizar?
    Por j34nsch no fórum Redes
    Respostas: 4
    Último Post: 20-08-2008, 16:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L