Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá a todos.


    Estou com uma grande dor de cabeça no Ubuntu server 8.04 LTS

    instalei e configurei o Sistema para transmitir uma internet via satélite que possuo.

    Configurei-o com Squid+ZPH+CBQ com Bind9 (configuração padrão) e poucas regras de ip-tables


    quando liguei o cabo de rede do modem e do switch no servidor
    a internet ficou OK
    porém nao repassou para as outras máquinas da rede...

    Ja configurei o IPtables de todas as formas porém ainda nao consegui ajusta-lo para repassar a internet...

    queria saber como eu faço para configurar o DNS para ser redirecionado para o IP da máquina

    (gateway e dns ficarem 192.168.1.254)
    pois eu acho que é por isso que não está funcionando ainda...


    Quem puder dar uma luz, será muito bem vindo!!

    Um abraço a todos!!

  2. Amigo,

    Se foi o que eu entendi, você tem um gateway nessa máquina né? Sua saída terá que ser mascarada, para ter um endereço válido na saída, tente usar o iptables com MASQUARADE na saída válida para internet.

    Depois tente apontar essa máquina como default gateway do seus hosts. Faça testes e se por acaso não entendi a questão corretamente, volte a postar.

    []s


    Citação Postado originalmente por aloi Ver Post
    Olá a todos.


    Estou com uma grande dor de cabeça no Ubuntu server 8.04 LTS

    instalei e configurei o Sistema para transmitir uma internet via satélite que possuo.

    Configurei-o com Squid+ZPH+CBQ com Bind9 (configuração padrão) e poucas regras de ip-tables


    quando liguei o cabo de rede do modem e do switch no servidor
    a internet ficou OK
    porém nao repassou para as outras máquinas da rede...

    Ja configurei o IPtables de todas as formas porém ainda nao consegui ajusta-lo para repassar a internet...

    queria saber como eu faço para configurar o DNS para ser redirecionado para o IP da máquina

    (gateway e dns ficarem 192.168.1.254)
    pois eu acho que é por isso que não está funcionando ainda...


    Quem puder dar uma luz, será muito bem vindo!!

    Um abraço a todos!!



  3. Além de configurar o iptables para fazer o masquerade, edite o arquivo:

    /etc/sysctl.conf e procure pela linha:

    #net.ipv4.ip_forward=1

    Retire o comentário, salve e boa. Sua box fará o forward.

  4. Citação Postado originalmente por edsonrsjr Ver Post
    Amigo,

    Se foi o que eu entendi, você tem um gateway nessa máquina né? Sua saída terá que ser mascarada, para ter um endereço válido na saída, tente usar o iptables com MASQUARADE na saída válida para internet.

    Depois tente apontar essa máquina como default gateway do seus hosts. Faça testes e se por acaso não entendi a questão corretamente, volte a postar.

    []s

    Voce tem razão quanto a máscara, porém ja o fiz,

    o que não consegui foi redirecionar os dois DNS da minha rede para o IP 192.168.1.254 (que seria fornecido para o cliente)

    acredito que seja com o bind9 que faça isso, mas como eu posso fazer esse redirecionamento?


    repetindo: ele encontra o servidor mas quando a conexão vai se estabelecer, ela é cancelada ou recusada, não sei ao certo...



  5. Façamos com o Jack o Estripador, vamos por partes.

    Certo, já fora feito o mascaramento da saída, já seguiu a dica do amigo em habilitar o ip_forward? Isso vai permitir o roteamento.

    Tens 2 DNSs rodando dentro da sua rede? ou tem um DNS interno e um outro no próprio roteador?


    Uma boa tentativa, configure uma estação de trabalho para que tenha como roteador padrão o seu roteador que dá saída pra internet, verifique em seu roteador quais os endereços de DNS quem ele faz a pesquisa, configure nessa estação e faça o teste de internet.



    Citação Postado originalmente por aloi Ver Post
    Voce tem razão quanto a máscara, porém ja o fiz,

    o que não consegui foi redirecionar os dois DNS da minha rede para o IP 192.168.1.254 (que seria fornecido para o cliente)

    acredito que seja com o bind9 que faça isso, mas como eu posso fazer esse redirecionamento?


    repetindo: ele encontra o servidor mas quando a conexão vai se estabelecer, ela é cancelada ou recusada, não sei ao certo...






Tópicos Similares

  1. Audio de Webcam pelo NAT no MSN!!!
    Por oxito_rocha no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 02-10-2004, 00:39
  2. Respostas: 3
    Último Post: 28-08-2004, 19:50
  3. Problemas com NAT no cisco 805
    Por Skill no fórum Redes
    Respostas: 1
    Último Post: 13-05-2004, 19:15
  4. NAT no Linux X NAT no Windows
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-08-2003, 10:39
  5. Nat como redirecionar as entradas nat no meu router?
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-06-2003, 14:24

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L