Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá a todos.


    Venho a vossas senhorias novamente para retirar algumas dúvidas que me empacam em problemas a princípio insolucionáveis.


    Bom, Estou com um Servidor Squid 2.6.STABLE18 Rodando em um Duo Core @ 2.2ghz, 512MB DDR2, hd de 20GB (vou ser sincero... estou tentando trocar o mais rápido possivel) com Ubuntu 8.04LTS

    No meu Squid tem ZPH e CBQ funcionando.

    O problema é o seguinte: Quando eu acesso páginas JÁ armazenadas em cache, o retorno é quase que imediato, sem comentários, Porém se o cliente requisitar uma página de internet que ainda não esteja armazenadas, o retorno é muito demorado. Ja tentei acessar com o Link full apenas de 1 máquina para verificar o sinal de internet, porém ainda da o mesmo problema. Na barra de status que fica embaixo do Navegador, fica carregando... bem devargazinho, tem vezes que volta pro começo e começa a carregar de novo.


    Não sei se é paranóia minha, mas eu acho que meu squid está com problemas :\

    alguem pode me dar uma luz sobre o assunto?

    Segue aqui embaixo meu squid.conf:

    ######### SQUID.CONF ############

    http_port 3128 transparent
    #httpd_accel_port 80
    #httpd_accel_host virtual
    #httpd_accel_with_proxy on
    #httpd_accel_uses_host_header on
    visible_hostname cybernet-ubs.cybernet
    cache_effective_user squid
    cache_effective_group squid
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    acl apache rep_header Server ^Apache
    broken_vary_encoding allow apache
    cache_mem 256 MB
    maximum_object_size 999 KB
    cache_dir aufs /var/cache/squid 10000 16 256
    access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.org
    cache_store_log /var/log/squid/store.log
    #acl macs arp "/etc/squid/control/mac"
    acl all src 0.0.0.0/0.0.0.0
    acl clientes src "/etc/squid/control/clientes"
    acl down_arq url_regex -i "/etc/squid/control/extensoes"
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443
    acl SSL_ports port 563
    acl SSL_ports port 1863
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443
    acl Safe_ports port 70
    acl Safe_ports port 210
    acl Safe_ports port 1025-65535
    acl Safe_ports port 280
    acl Safe_ports port 488
    acl Safe_ports port 591
    acl Safe_ports port 777
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443
    acl Safe_ports port 70
    acl Safe_ports port 210
    acl Safe_ports port 1025-65535
    acl Safe_ports port 280
    acl Safe_ports port 488
    acl Safe_ports port 591
    acl Safe_ports port 777
    acl Safe_ports port 901
    acl Safe_ports port 1863
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localhost
    http_access allow all
    http_reply_access allow all
    # Controle de banda de extensões de download
    delay_pools 1
    delay_class 1 3
    delay_access 1 allow down_arq
    delay_parameters 1 32000/32000 8000/8000 4000/8000
    icp_access allow all
    # Configuracao do ZPH, eu queria saber se tem como incrementar?
    zph_tos_local 16
    zph_tos_parent off
    forwarded_for off
    error_directory /usr/share/squid/errors/Portuguese
    coredump_dir /var/cache/squid
    detect_broken_pconn on
    pipeline_prefetch on


    ######## IP TABLES ###########
    modprobe ip_tables
    modprobe iptable_nat
    iptables -F
    #iptables -F INPUT
    #iptables -F OUTPUT
    #iptables -F POSTROUTING -t nat
    #iptables -F PREROUTING -t nat
    echo > 1 /proc/sys/net/ipv4/ip_forward
    iptables -t filter -P FORWARD ACCEPT
    iptables -A POSTROUTING -t nat -o eth1 -j MASQUERADE
    iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-ports 3128
    iptables -A FORWARD -p tcp --dport 443 -j ACCEPT
    iptables -A FORWARD -p tcp --dport 1863 -j ACCEPT



    Desde já, Muito obrigado!!!






    Meus agradecimentos!

  2. Algumas perguntas básicas:

    1 - já tentou remover as configurações de CBQ e ZPH e fazer o teste de velocidade?
    2 - já tentou reconstruir a árvore do cache?
    3 - já verificou se o disco está integro ou se estão aparecendo mensagens de erro de gravação no syslog?
    4 - já verificou como fica o load da máquina? utilização de memória, disco (I/O) e swap?
    5 - já tentou acessar a internet direto, sem o Squid?
    6 - qual a velocidade do HD?




  3. Citação Postado originalmente por galahad Ver Post
    Algumas perguntas básicas:

    1 - já tentou remover as configurações de CBQ e ZPH e fazer o teste de velocidade?
    2 - já tentou reconstruir a árvore do cache?
    3 - já verificou se o disco está integro ou se estão aparecendo mensagens de erro de gravação no syslog?
    4 - já verificou como fica o load da máquina? utilização de memória, disco (I/O) e swap?
    5 - já tentou acessar a internet direto, sem o Squid?
    6 - qual a velocidade do HD?

    Grande colega galahad, aqui vão suas respostas


    1) SIM, sem CBQ sim, fica lento, sem ZPH, ainda nao testei..
    2) SIM, achei q tivesse resolvido, mas foi apenas um equívoco
    3) Não, como faço isso?
    4) Não, como faço isso?
    5) Sim.. pega com rapidez.
    6) Olha.. vo te confessar, estou preocupado com o HD que é de 20 gigabytes IDE, provavelemente funcione a 5000 RPM, mas ele está quase vazio (apenas 1,6g utilizado) será que pode influenciar tanto??

  4. Só uma nota de observação: Estou desesperadamente tentando trocar de CBQ para HTB, porém o ubuntu impossibilita por diversas dificuldades na hora do make (erros de symlink com diversos módulos) e por enquanto estou tentando resolver do jeito que está..



  5. Citação Postado originalmente por aloi Ver Post
    Só uma nota de observação: Estou desesperadamente tentando trocar de CBQ para HTB, porém o ubuntu impossibilita por diversas dificuldades na hora do make (erros de symlink com diversos módulos) e por enquanto estou tentando resolver do jeito que está..
    Ola amigo,
    Olha eu tentaria remover os delay pools!
    Isso pode estar atrasando um pouco as coisas...
    Afinal das contas essa é a função dele... delay!!

    Código :
    delay_pools 1
    delay_class 1 3
    delay_access 1 allow down_arq
    delay_parameters 1 32000/32000 8000/8000 4000/8000
    Você tambem esta fazendo controle por extenções de arquivos

    Código :
    acl down_arq url_regex -i "/etc/squid/control/extensoes
    Tenta remover isso tambem! Essas são coisas que poderiam estar causando um certo atraso na sua comunicação com a internet usando o squid! E outra coisa... se você esta usando ubuntu 8.04LTS você JÁ TEM SUPORTE A HTB!

    Só usar a ferramenta "tc" para criar as regras!
    Ela vem junto com o pacote iproute!






Tópicos Similares

  1. Internet muito lenta com sobra de banda...
    Por JotaJuh no fórum Redes
    Respostas: 6
    Último Post: 23-02-2010, 10:01
  2. Perdendo pacote "com resposta rápida"
    Por scraipt no fórum Redes
    Respostas: 3
    Último Post: 18-09-2009, 16:12
  3. Sem resposta Rapida
    Por ruyneto no fórum UnderLinux
    Respostas: 3
    Último Post: 12-10-2006, 12:10
  4. Escrita e leitura muito lenta no compartilhamento vfat
    Por rafaelstein no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-10-2003, 19:16
  5. Parte gráfica do conectiva 8.0 muito lenta
    Por Wronieri no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-02-2003, 08:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L