Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico

  1. recompilei o kernel do meu slack 12.1
    e quando fui digitar no terminal #lilo pra atualizar deu o seguinte erro
    root@slackware:/# lilo
    Warning: LBA32 addressing assumed
    Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/hda1' -> '/dev/hda1'
    part_nowrite check:: Input/output error
    root@slackware:/#

    o que poderia ser?

  2. Citação Postado originalmente por alexspe Ver Post
    Warning: LBA32 addressing assumed
    Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/hda1' -> '/dev/hda1'
    part_nowrite check:: Input/output error
    Você está fazendo acesso normal ao seu sistema? Ou está utilizando um livecd ou coisa parecida?

    A partição principal está montada em modo rw?
    execute 'mount' na shell e cole aqui o resultado.

    Você usa udev para gerenciar o /dev ou está usando o /dev estático? Se usa o udev, o udevd está rodando?
    execute os comandos:
    ps -auxwww | grep udev

    ls -la /dev/.udev

    ls -la /dev/hd*

    cat /proc/partitions

    e poste aqui os respectivos resultados.




  3. meu esquema de partições
    hda1 windows xp
    hda2 swap
    hda3 slackware

    descobri o problema após uma recompilação do meu kernel
    quando fui adicionar a nova imagem do kernel no lilo.conf
    e quando fui rodar o comando pra reinstalação
    root@slackware:/# lilo

    hoje a noite vou rodar esses comandos e posto aqui
    nao sei dizer se a partição esta montada em rw
    nem se estou usando o dev estatico ou udev

  4. o erro que ele apresentou, embora eu ache que não seja uma obstrução ao carregamento do sistema, tem a ver com diferenças entre o /proc/partitions e a estrutura do teu /dev

    quando você postar o resultado dos comandos que te passei, vai ser possível fazer uma análise melhor do problema e tentar achar a solução.

  5. ta aqui o resultado dos comandos
    ------------------------------------------------
    root@slackware:/# ps -auxwww | grep udev
    Warning: bad ps syntax, perhaps a bogus '-'? See procps - Frequently Asked Questions (FAQ)
    root 1116 0.2 0.5 2540 1196 ? S<s 18:50 0:01 /sbin/udevd --daemon
    root 2680 0.0 0.2 2060 656 pts/0 S+ 19:00 0:00 grep udev
    root@slackware:/#
    root@slackware:/#
    root@slackware:/# ls -la /dev/.udev
    total 4
    drwxr-xr-x 5 root root 120 2008-07-03 18:55 .
    drwxr-xr-x 17 root root 14180 2008-07-03 18:55 ..
    drwxr-xr-x 2 root root 13640 2008-07-03 18:55 db
    drwxr-xr-x 1340 root root 26800 2008-07-03 18:55 names
    drwxr-xr-x 2 root root 40 2008-07-04 04:50 rules.d
    -rw-r--r-- 1 root root 5 2008-07-03 18:55 uevent_seqnum
    root@slackware:/#
    root@slackware:/#
    root@slackware:/# ls -la /dev/hd*
    ls: cannot access /dev/hda1: Input/output error
    brw-r----- 1 root disk 3, 0 2008-07-04 04:50 /dev/hda
    brw-r----- 1 root disk 3, 2 2008-07-04 04:50 /dev/hda2
    brw-r----- 1 root disk 3, 3 2008-07-04 04:50 /dev/hda3
    brw-rw---- 1 root cdrom 3, 64 2008-07-04 04:50 /dev/hdb
    root@slackware:/#
    root@slackware:/#
    root@slackware:/# cat /proc/partitions
    major minor #blocks name

    3 0 19938240 hda
    3 1 6144831 hda1
    3 2 522112 hda2
    3 3 13269690 hda3







Tópicos Similares

  1. Erro no squid após atualização para versão 2.6
    Por lfernandosg no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-09-2007, 14:38
  2. Erro no Lilo, nao consegui recupera-lo.......
    Por slacklex no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-06-2006, 21:06
  3. Erro no apache apos atualização
    Por Drozzini no fórum Servidores de Rede
    Respostas: 2
    Último Post: 28-09-2005, 15:55
  4. Erro no lilo
    Por amra no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-01-2005, 03:12
  5. Erro no LIlo
    Por B4D_D0G no fórum Servidores de Rede
    Respostas: 5
    Último Post: 04-11-2002, 18:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L