+ Responder ao Tópico



  1. Olá a todos

    Uso link ADSL e estou precisando acessar meu servidor de uma outra cidade. estou precisando de um scrit que atualize o ip atual no ddns, alguém pode me ajudar?

    Desde já agradeço.

  2. Olá,



    segue:

    Código :
    :log info "DDNS: Begin"
     
    :global ddns-user "nome"
    :global ddns-pass "senha"
    :global ddns-host "nome_do_host"
    :global ddns-interface "nome_da_interface"
     
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
     
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
     
    :if ([ :typeof $ddns-ip ] = nil ) do={
     
      :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
     
    } else={
     
      :if ($ddns-ip != $ddns-lastip) do={
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ /tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
        :global ddns-lastip $ddns-ip
     
      } else={ 
     
        :log info "DDNS: No change" 
     
      }
     
    }
     
    :log info "DDNS: End"

    Abraços,



  3. O no-ip é um serviço bem melhor.

  4. MSON agradeço pela atenção mas vc poderia me enviar um exemplo do script com um usuário ficticio pois coloquei o script mas ele não está rodando.

    Desde já agradeço.



  5. ola Diagellys,

    verifica essa que é a regra postada acima, mas com ouser ficticio como vc pediu:


    :log info "DDNS: Begin"

    :global ddns-user "Pedro"
    :global ddns-pass "fa4593la"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    Lembrando que o user PEdro e a senha fa4593la, é a que você criou la no changeip.com, dae vc pode acessar o mk com o nome que vc cadsatrou la.

    qualquer duvida é so postar.






Tópicos Similares

  1. Ap Router e zonezdit.com. Script para atualizar o ip?
    Por paulinholiveira no fórum Redes
    Respostas: 1
    Último Post: 26-10-2011, 12:35
  2. Script para atualizar ip no dyndns.com
    Por deson00 no fórum Redes
    Respostas: 3
    Último Post: 16-06-2009, 20:26
  3. Script para Pegar IP, Enviar e-mail e escrever no pptp.conf
    Por Skill no fórum Linguagens de Programação
    Respostas: 21
    Último Post: 26-06-2003, 11:34
  4. Script para Pegar IP da ETH ou PPP0, e enviar por email
    Por Skill no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-03-2003, 15:55
  5. Script para pegar IP
    Por Skill no fórum Servidores de Rede
    Respostas: 6
    Último Post: 15-03-2003, 14:30

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L