Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Erro ao tentar redirecionar pagina de débito.

    Pessoal oq pode ser esse erro, somente aparece quanto tento redirecionar para pagina de débito do hotspot.

    Segue o erro:
    Erro Interno (failed to add filter-in rule: jumps to builtin chains not allowed (6))
    Arquivos Anexos Arquivos Anexos

  2. #2

    Padrão

    Pessoal, acabei com esse erro, mais o hotspot não joga pagina de debito de maneira alguma, alguem poderia me dar uma ajuda?



  3. #3

    Padrão

    Ninguem pra ajudar, tenho quase certeza q o adverting não funciona, pois ja coloquei ips de sites externos e nada de redirecionar, acho que so pode ser bug do MK pois quando usava a versão .27 funcionava, depois que comprei uma licença nivel 4, nunca mais dei conta de fazer funcionar, o adverting da versão 2.9.51 tem bug?

  4. #4



  5. #5

    Padrão

    Valeu amigo, mais ja tinha olhado esse artigo, eu acho q meu MK ta bichado!

  6. #6

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Valeu amigo, mais ja tinha olhado esse artigo, eu acho q meu MK ta bichado!
    Use a versão 2.9.50 e faça o teste.



  7. #7

    Padrão

    Onde eu encontro pra testar, no site parece que não tem...

  8. #8

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Onde eu encontro pra testar, no site parece que não tem...
    http://admin.roset.cz/Mikrotik/route...tik-2.9.50.iso



  9. #9

    Padrão

    Descobri o problema pessoal, o meu MK so aceita a pagina dele mesmo ou seja a radvert.html, se eu colocar outro nome por exemplo bloqueio.html, não vai de jeito algum, uma outra duvida quando mando a pagina de aviso, com intervalo de 20 minutos ela aparece mais num sai mais, como faço pra ela aparecer ficar um tempo e sumir?

  10. #10

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Descobri o problema pessoal, o meu MK so aceita a pagina dele mesmo ou seja a radvert.html, se eu colocar outro nome por exemplo bloqueio.html, não vai de jeito algum, uma outra duvida quando mando a pagina de aviso, com intervalo de 20 minutos ela aparece mais num sai mais, como faço pra ela aparecer ficar um tempo e sumir?
    Olá amigo,
    A pagina radvert.html é responsável por chamar a pagina de aviso, ao mudar o seu conteúdo, você deixou de usar este recurso. Para chamar a pag de aviso.html terá que deixar o radvert.html com seu conteúdo, mesmo que mude o seu visual.

    Poste as regras dos seus perfis (aviso e bloqueio) para eu dar uma olhada.



  11. #11

    Padrão

    Realmente vc tem razão, tem de deixar o conteudo do radvert.html, somente auterar o visual, a unica coisa é q os aviso são em pop-up e o IE7 barra tudo, e a pagina do radvert.html não direciona pra pagina requisitada somente se clicando pra ir manualmente, agora so falta descobrir como eu faço aparecer a tela de aviso sem ser em pop-up e fazer a tela de radvert quando aparecer sair automaticamente!

  12. #12

    Padrão

    Quando eu fiz o tutorial, do link anterior, na versão 2.9.50 ele abria como uma pagina normal. Posta as regras para eu dar uma olhada.



  13. #13

    Padrão

    Eu resetei todos os HTMLs do hotspot pro arquivo radvert original voltasse, ai nesse arquivo eu somente traduzi oq tem escrito lá, e criei o arquivo aviso.html e block.html, o radvert realmente aparece na pagina, agora o aviso e block vem em pop-up!

    ip hotspot user profile
    set Wireless name="Wireless" idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    transparent-proxy=no
    add name="Atrazo" idle-timeout=none keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    transparent-proxy=yes open-status-page=always advertise=yes \
    advertise-url=http://auth.meganet.com.br/aviso.html,http://auth.meganet.com.br/aviso.html advertise-interval=20m \
    advertise-timeout=immediately
    add name="cortado" session-timeout=1m idle-timeout=none keepalive-timeout=20s status-autorefresh=1m shared-users=unlimited \
    rate-limit="15k/15k" transparent-proxy=yes open-status-page=http-login advertise=yes \
    advertise-url=http://auth.meganet.com.br/block.html,http://auth.meganet.com.br/block.html advertise-interval=1s,1s \
    advertise-timeout=immediately

  14. #14

    Padrão

    Olá amigo,
    Coloque suas paginas dentro da pasta hotspot, se já tiver..., daí você muda o endereço http://auth.meganet.com.br/aviso.html pois se você tentar acessar, acredito que ele não vai encontrar os arquivos.

    Acredito que você colocou o dns do servidor hotspot com o endereço acima.
    Os pop-ups que você diz estão sendo bloqueados, é a pag de status.

    Faça uma alteração na suas configs:

    ■ No dns:
    /ip dns static add name=192.168.1.1 address=192.168.1.1

    ■ No perfil do servidor hotspot:
    /ip hotspot profile set "nome_profile" hotspot-address=192.168.1.1 dns-name="192.168.1.1"

    ■ Nos profiles dos usuários:
    advertise=yes advertise-url=block.html

    advertise=yes advertise-url=aviso.html

    Faça isto e veja se funciona.
    Última edição por Raniel; 10-07-2008 às 09:51.



  15. #15

    Padrão

    Não deixe de observar o material, pois muitos têm feito e dado certo:

    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]

    Principalmente na pagina 4.
    Última edição por Raniel; 10-07-2008 às 09:52.

  16. #16

    Padrão

    Fiço os testes e a unica pagina q aparece é a do radvert mesmo, mais ela não sai automaticamente e ai o cliente tem de clicar no link pra poder ir para pagina seguinte, ai sim, ao clicar aparece a tela de aviso ou bloqueio!



  17. #17

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Fiço os testes e a unica pagina q aparece é a do radvert mesmo, mais ela não sai automaticamente e ai o cliente tem de clicar no link pra poder ir para pagina seguinte, ai sim, ao clicar aparece a tela de aviso ou bloqueio!
    Está tendo algum problema, era para ele redirecionar em mesmo de 3 segundos (time=1000 em milisegundos).
    Faça um backup e use o 2.9.50 e siga o material:

    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]

    Fiz os testes novamente e redirecionou.

    Qualquer coisa entre em contato que veremos isto aí.

  18. #18

    Padrão

    Outra coisa que eu esqueci de mencionar é que a autenticação tem que está como http-chap:

    login-by=mac,http-chap



  19. #19

    Padrão

    Voltei a versão 2.0.50, e é a mesma coisa, a pagina radvert aparece e não sai automaticamente, na pagina radvert, eu coloquei a mensagem de aviso e o texto para clicar aqui, para ser redirecionado para pagina seguinte e ai sim aparece a pagina de debito ou corte!
    Tbm tentei fazer a radver e radvert1, mais sempre aparece a pagina de radivert a radivert1 não aparece de jeito nenhum, so clicando no link da pagina radvet, mais ta bom assim, valeu pela ajuda amigo.

  20. #20

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Voltei a versão 2.0.50, e é a mesma coisa, a pagina radvert aparece e não sai automaticamente, na pagina radvert, eu coloquei a mensagem de aviso e o texto para clicar aqui, para ser redirecionado para pagina seguinte e ai sim aparece a pagina de debito ou corte!
    Tbm tentei fazer a radver e radvert1, mais sempre aparece a pagina de radivert a radivert1 não aparece de jeito nenhum, so clicando no link da pagina radvet, mais ta bom assim, valeu pela ajuda amigo.
    Olá amigo,
    Vendo o seu problema, resolvi fazer umas alterações na pag do radvert.html e obtive o seguinte resultado:

    Troque a função javascript da pag por esta:

    Código :
    <script language="javascript">
        var popup = '';
        function openOrig() {
        if (focus) popup.focus();
        location.href = '$(link-orig)';
        }
        function openAd() {
        location.href = '$(link-redirect)';
        }
        function openAdvert() {
        if (name != 'hotspot_advert') {
            popup = open('$(link-redirect)', 'hotspot_advert', '');
            setTimeout("openOrig()", 1000);
            return;
        }
        setTimeout("openAd()", 1000);
        }
    </script>

    Com isto não abrirá a popup e sim pag. Teste e me diga como ocorreu contigo.