Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Para o pessoal que está começando com hotspot

    Vai minha contribuição para os que estão começando com o hotspot e queria fazer pag de aviso (atraso e bloqueio).

    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]

  2. #2

    Padrão

    Queria q vc me ajudasse em relação ao meu hotspot, pois minha máquina é um k6-2 500, 128 ram, 3 placas sis900 e meu hotspot funciona de forma intermitente, sigo os tutoriais, mas mesmo assim continua com o mesmo problema. Uso a versão 2.9.27 do mk. Não sei se é correto, mas no hosts do mk fica aparecendo outros ip/macs que não faz parte de minha rede acho qu quando aparece isso aí meu servidor mk não aparece a página de autenticação. dois links um saindo do servidor proxy e outro direto sem servidor poxy e o terceiro é minha rede 10.1.1.0/24. o que pode estar acontecendo, pois estou tentando fazer um link de sombra usando os dois links, mas o que queria mesmo é somar os dois links.

    desde já agradecido.



  3. #3

    Padrão

    De forma alguma é normal aparecer ip que não seja de sua rede.
    Para isto, não sei se já está feito, marque a opção reply-only da sua interface que liga aos clientes.
    Mas me diga como distribue os ips, como estão os perfis(do servidor e dos clientes). Poste.

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão HotSpot com Pagina de Aviso e Bloqueio

    Bom vamos as dúvidas:

    Fiz tudo que estava no tutorial, mas encontrei alguns problemas e lá vão eles.

    1 - Redirecionamento do Proxy
    Regra indicada pelo tutorial:
    Código :
    [COLOR=black][FONT=Verdana][B]/ip firewall nat add chain=pre-hotspot src-address=192.168.1.0/24 protocol=tcp dst-port=80 action=redirect to-port=3127[/B][/FONT][/COLOR]
    [COLOR=black][FONT=Verdana][/FONT][/COLOR]

    Pois com a regra indicada não aparecia a tela de login do Hotspot então alterei essa regra para:
    Código :
     
    Código :
     
    Código :
    [COLOR=black][FONT=Verdana][COLOR=black][FONT=Verdana][B]/ip firewall nat add chain=dstnat src-address=192.168.1.0/24 protocol=tcp dst-port=80 action=redirect to-port=3127[/B][/FONT][/COLOR][/FONT][/COLOR]
    [COLOR=black][FONT=Verdana][COLOR=black][FONT=Verdana][/FONT][/COLOR][/FONT][/COLOR]

    Com essa alteração funcionou começou aparecer a tela de login do Hotspot.

    2 - Fiz como indicado no tutorial e criei os arquivos de aviso.html e bloqueio.html e os coloquei no diretorio do hotspot mas, quando altero o perfil do cliente para Aviso ao conectar não aparece a tela de aviso e o mesmo navega normalmente.

    3 - Fiz como indicado no tutorial e criei os arquivos de aviso.html e bloqueio.html e os coloquei no diretorio do hotspot mas, quando altero o perfil do cliente para Bloqueado após ele tentar conectar digitando o usuario e senha, continua na tela de login e informa o seguinte erro:
    Internal error (failed to add filter-in rule: jumps to builtin chains not allowed (6)).

    Então ai está a duvida o que posso ter feito de errado.????
    Segue a configuração do server, lembro que para teste na bancada estou usando MK 2.9.27.
    Ai está o arquivo em anexo com o Export completo do MK de teste.
    Aguardo Retorno.
    Arquivos Anexos Arquivos Anexos



  5. #5
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Respostas

    Olá Mr. MG se puder ajudar agradeço o motivo que peço ajuda pois as configurações vieram do seu tutorial.
    Aos outros reportem se tiveram problemas ou ñ.

  6. #6

    Padrão

    Aqui deu o mesmo erro.... o que pode ser ?



  7. #7

    Padrão

    Olá amigos,
    Estive fora estes dias, mas sugiro que testem na versão 2.9.50.

  8. #8
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão O Grande Problema do Forum

    Bom dia.... Bom como todos podem ver o problema de sempre todos só querem aproveitar das regras postadas.... nimguem lê um post e responde ou pq o nivel de conhecimento é + que minimo ou pq o pessoal ´realmente é somente sangue suga. Ao nosso amigo Mr. MG ele postou o tutorial e gratis por isso ñ tem obrigação de postar soluções, mas quantos aos outros usuarios, realmente cada vez mais fico indignado. Muitos lêem o tópico mas ajudar, responder nada. Na maioria só entram pra ver se teve solução ou pra pega as retgras postadas. Sempre que posto dúvidas na sua maioria ñ são respondidas e o tópico é trancado pelo tempo. Mas quando o pessoal tem dúvidas sempre tentamos solucionar.....
    Mas está bom, pessoal desculpe o desabafo mas cada dia que passa o tópico se enfraquece.



  9. #9
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão

    Irei testar pra ver se resolve, grato.

  10. #10

    Padrão

    Minelli o desabafo nao foi para min nao ne ?.... porque eu ja semp. fico muito grato a toda a ajuda aqui.

    Sou leigo e to tentando resolver...

    Marcos diirr



  11. #11
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Desabafo

    Não Marcos, ñ foi pra vc ñ. Foi pro pessoal mesmo que tem conhecimento.

    Pessoal testei na versão 2.9.51 e nada tb, continua o erro.

  12. #12

    Padrão

    Pois bem pessoal, fiz alguns teste e uma mudança no javascript da radvert.html para não abrir a pop-up. Desta vez fiz com MikroTik 2.9.27.

    1: Com um editor html ou mesmo o bloco de notas do Windows, mude o code javascript para este:
    Código :
    <script language="javascript">
        var popup = '';
        function openOrig() {
        if (focus) popup.focus();
        location.href = '$(link-orig)';
        }
        function openAd() {
        location.href = '$(link-redirect)';
        }
        function openAdvert() {
        if (name != 'hotspot_advert') {
            popup = open('$(link-redirect)', 'hotspot_advert', '');
            setTimeout("openOrig()", 1000);
            return;
        }
        setTimeout("openAd()", 1000);
        }
    </script>
    Envie novamente para MikroTik, não esqucendo de fazer um backup da pasta.

    Agora vamos as regras para rodar o servidor.

    Ajustar os nomes das interfaces:

    /interface set ether1 name=link

    /interface set ether2 name=network

    Configurar o ip:

    /ip address
    add address=192.168.50.10/24 network=192.168.50.0 broadcast=192.168.50.255 interface=link actual-interface=link

    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=network actual-interface=network

    Configurar o route:

    /ip route
    add dst-address=192.168.1.0/24 pref-src=192.168.1.1 interface=network scope=10 target-scope=0

    add dst-address=192.168.50.0/24 pref-src=192.168.50.10 interface=link scope=10 target-scope=0

    add dst-address=0.0.0.0/0 gateway=192.168.50.1 interface=link gateway-state=reachable distance=0 scope=30 target-scope=10


    Configurar os dns:
    /ip dns
    set primary-dns="ip da operadora ou outro"

    static add name=192.168.1.1 address=192.168.1.1

    static add name=freirenet.com address=192.168.1.1



    Compartilhar a internet:

    /ip firewall nat
    add chain=srcnat out-interface=link src-address=192.168.1.0/24 action=masquerade


    Configurar o dhcp(opcional):
    /ip dhcp-server
    name="dhcp" interface=network lease-time=1d address-pool=dhcp_pool bootp-support=static authoritative=after-2sec-delay

    /ip pool add name="dhcp_pool" ranges=192.168.1.2-192.168.1.254


    Configurando o servidor hotspot:
    /ip hotspot
    profile add name="hsprof" hotspot-address=192.168.1.1 dns-name="freirenet.com" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=mac,http-chap split-user-domain=no use-radius=yes radius-accounting=yes radius-interim-update=received nas-port-type=ethernet radius-default-domain="" radius-location-id="" radius-location-name=""

    add name="server" interface=network address-pool=dhcp_pool profile=hsprof idle-timeout=none keepalive-timeout=none ip-of-dns-name=192.168.1.1

    /ip hotspot user profile
    add name="aviso" address-pool=dhcp_pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=10s advertise-timeout=5s

    add name="bloqueio" address-pool=dhcp_pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never

    add name="normal" address-pool=dhcp_pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=no

    /ip hotspot user
    add server=server name="aviso" password="" profile=aviso uptime=1h12m21s bytes-in=3321399 bytes-out=44065627 packets-in=28242 packets-out=41937

    add server=server name="bloqueado" password="" profile=bloqueio uptime=9m43s bytes-in=303598 bytes-out=6038427 packets-in=3304 packets-out=5227

    add server=server name="normal" password="" profile=normal uptime=1h30m30s bytes-in=1000182 bytes-out=5298406 packets-in=5384 packets-out=6481


    Ativar o web-proxy:

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "FreireNET.com"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "[email protected]"
    max-object-size: 4096KiB
    cache-drive: system
    max-cache-size: 1000000KiB
    max-ram-cache-size: 64000KiB
    status: running
    reserved-for-cache: 999424KiB
    reserved-for-ram-cache: 64000KiB

    Redirecionando o tráfego:

    /ip firewall nat
    add chain=dstnat in-interface=network src-address=192.168.1.0/24 protocol=tcp dst-port=80 action=redirect po-ports=3128

    Dá uma conferida que blz o web-proxy:
    status: running
    uptime: 46m48s
    clients: 1
    requests: 224
    hits: 3
    cache-size: 652KiB
    ram-storage-size: 636KiB
    received-from-servers: 747KiB
    sent-to-clients: 750KiB
    hits-sent-to-clients: 0KiB



    Para quem tiver algum problema, vai um anexo:
    Arquivos Anexos Arquivos Anexos
    Última edição por Raniel; 18-07-2008 às 17:46.



  13. #13

    Padrão

    Tenho uma lanhouse e gostaria de implantar o mikrotik entre o roteador e as maquinas apenas para controle de banda, posso fazer isso configurando apenas o hotspot e adicinoando o controle ou tenho que fazer todos os outros procedimentos?

  14. #14

    Padrão

    Citação Postado originalmente por casericardo Ver Post
    Tenho uma lanhouse e gostaria de implantar o mikrotik entre o roteador e as maquinas apenas para controle de banda, posso fazer isso configurando apenas o hotspot e adicinoando o controle ou tenho que fazer todos os outros procedimentos?
    Faça sem usar o hotspot ou pppoe, adicionando os ips e velocidades em queue simple.



  15. #15

    Padrão

    como não tenho esperiencia nenhuma, quero uma solução rapida para controle banda de minha rede pois quando alguem começa vendo youtube o pessoal que joga lineage fica doido de tanto leg.
    posso então apenas intalar o mikrotik e adcionar apenas os ip´s das interfaces e depois os ip dos clientes ou tenho realmente que configurar o resto com Nat firewall web-proxy e outros?
    gostaria de algo bem simples mesmo
    ether1=192.168.0.2/24
    ether2=192.168.1.1/24
    se puderem me ajudar.

  16. #16

    Padrão

    esse lance ai,, do hs
    aqui editei a pag de bloqueio, a propria radvert com o conteudo do bloqueio...
    e ta rolando aqui, file



  17. #17

    Padrão

    Citação Postado originalmente por casericardo Ver Post
    ...
    gostaria de algo bem simples mesmo
    ...

    Ajustar os nomes das interfaces:

    /interface set ether1 name=link

    /interface set ether2 name=network

    Configurar o ip:

    /ip address
    add address=192.168.50.10/24 network=192.168.50.0 broadcast=192.168.50.255 interface=link actual-interface=link

    add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=network actual-interface=network

    Configurar o route:

    /ip route
    add dst-address=192.168.1.0/24 pref-src=192.168.1.1 interface=network scope=10 target-scope=0

    add dst-address=192.168.50.0/24 pref-src=192.168.50.10 interface=link scope=10 target-scope=0

    add dst-address=0.0.0.0/0 gateway=192.168.50.1 interface=link gateway-state=reachable distance=0 scope=30 target-scope=10


    Configurar os dns:
    /ip dns
    set primary-dns="ip da operadora ou outro"

    static add name=192.168.1.1 address=192.168.1.1

    static add name=freirenet.com address=192.168.1.1



    Compartilhar a internet:

    /ip firewall nat
    add chain=srcnat out-interface=link src-address=192.168.1.0/24 action=masquerade


    Mude de acordo com sua rede

  18. #18

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    ...
    aqui editei a pag de bloqueio, a propria radvert com o conteudo do bloqueio...
    ...
    Diga-nos uma coisa: é somente a pagina de bloqueio, não é?



  19. #19

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Diga-nos uma coisa: é somente a pagina de bloqueio, não é?
    sim pq tpw, a radvert na verdade, redireciona pra outra pag neh isso, entao, nao precisa redirecionar, ela msm, a propria, é a pag q tem as infos de bloqueado talz,

    axo q oq to fazendo eh gambi, auhauh mais, ta rolando, entao ta de boa neh
    vlws

  20. #20

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    sim pq tpw, a radvert na verdade, redireciona pra outra pag neh isso, entao, nao precisa redirecionar, ela msm, a propria, é a pag q tem as infos de bloqueado talz,

    axo q oq to fazendo eh gambi, auhauh mais, ta rolando, entao ta de boa neh
    vlws
    Quis dizer se além da pag de bloqueio você não tem uma de aviso e como faria para chamá-la, já que o radvert.html está modificado.