+ Responder ao Tópico



  1. #1

    Padrão LB com 3 Links

    Olá pessoal,

    Sou novo aqui no forum e gostaria de fazer um LB em meu provedor, ja li muito aqui no forum e acabei montando um LB no meu provedor concerteza melhorou depois do LB, mas ainda estou em duvida se a maneira que fiz é a mais eficaz. Gostaria da opinião de vcs. Se meu LB esta bom ou é necessario alguma(as) modificação(ões).
    E se um dos links caise, o que aconteceira???
    Obs.: Ainda não tratei HTTPS e os links são todos da mesma operadora.

    Meu cenario é o seguinte:
    São 2 Adsl de 2MB e um Link Dedicado de 1MB.
    Gateway Link Dedicado : 200.181.10.10
    Gateway 1º ADSL : 192.168.0.251
    Gateway 2º ADSL : 192.168.0.254
    Nesse servidor só tenho 2 placas de rede.
    As interfaces são "Local" e "Internet".

    Segue os meus export:

    /ip firewall mangle
    Código :
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link1 nth=4,0 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link1 connection-mark=Link1 \
        disabled=no in-interface=Local new-routing-mark=R-Link1 passthrough=no
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link2 nth=4,1 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link2 connection-mark=Link2 \
        disabled=no in-interface=Local new-routing-mark=R-Link2 passthrough=no
    add action=mark-connection chain=prerouting comment=Link3 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link3 nth=4,2 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link3 connection-mark=Link3 \
        disabled=no in-interface=Local new-routing-mark=R-Link3 passthrough=no
    add action=mark-connection chain=prerouting comment=Link4 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link4 nth=4,3 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link4 connection-mark=Link4 \
        disabled=no in-interface=Local new-routing-mark=R-Link4 passthrough=no
    add action=mark-connection chain=prerouting comment=Link5 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link5 nth=4,4 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link5 connection-mark=Link5 \
        disabled=no in-interface=Local new-routing-mark=R-Link5 passthrough=no
    /ip firewall nat
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
        Internet
    /ip address
    Código :
    add address=200.181.163.26/29 broadcast=200.181.163.31 comment="" disabled=no \
        interface=Internet network=200.181.163.24
    add address=192.168.0.250/24 broadcast=192.168.0.255 comment="" disabled=no \
        interface=Internet network=192.168.0.0
    add address=192.168.100.250/24 broadcast=192.168.100.255 comment="" disabled=\
        no interface=Local network=192.168.100.0
    add address=192.168.101.250/24 broadcast=192.168.101.255 comment="" disabled=\
        no interface=Local network=192.168.101.0
    /ip route
    Código :
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        200.181.163.25 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        192.168.0.254 pref-src=192.168.0.250 routing-mark=R-Link4 scope=30 \
        target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        192.168.0.251 pref-src=192.168.0.250 routing-mark=R-Link1 scope=30 \
        target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        192.168.0.254 pref-src=192.168.0.250 routing-mark=R-Link5 scope=30 \
        target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        192.168.0.251 pref-src=192.168.0.250 routing-mark=R-Link2 scope=30 \
        target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        200.181.163.25 pref-src=200.181.163.26 routing-mark=R-Link3 scope=30 \
        target-scope=10
    Última edição por arkantos; 14-07-2008 às 13:44.

  2. #2

    Padrão

    Não entendi "bulufas." perdao pela minha ignorancia mas, voce diz que está balanceando 3 links e nas linhas exps mostra até o link 5, pra onde vao estes 2 ultimos?.
    Abraços.



  3. #3

    Padrão

    O que eu fiz foi o seguinte.
    A soma de todos os meus link é igual a 5 MB (2MB+2MB+1MB), como meu menor link é de 1MB, dividi 5 por 1 que é = 5. Isso foi feito pra que eu podesse dividir igualmente a carga nos links. (pelo menos foi dessa maneira que eu entendi aqui no forum, para fazer balancemento em link de velocidades diferentes). Minha maior duvida é se as rotas estão todas certas.

  4. #4

    Padrão

    Seu LB está mt bom sim. Parabéns!

    Agora comece a implementar o tratamento dos serviços!

    Aqui uso mais ou menos assim, veja meu cenário:

    3 ADSL:

    1° - 2mb
    2° - 2mb
    3° - 300kbps


    Na minha matemática(que sou péssimo) coloquei o peso de 6x6x1. Ou seja, a cada 13 conexões, 6 vão pro primeiro modem de 2mb, 6 pro segundo modem de 2 mb e 1 pro terceiro modem de 300kbps. (Entendeu o lance das conexões dele, Miranda?)

    E fiz o tratamento dos serviços: portas tcp-1863(msn) pelo primeiro modem(2mb) e tcp-443(https) pelo segundo modem(2mb) e o p2p(exceto o criptografado :/) pelo modem de 300kbps.

    Se algum dos links cair, as páginas abrirão com problemas, pois faltarão alguns pedaços delas, algumas imagens quebradas, etc. Pra resolver isso procure por "failover", eu já vi algumas coisas, mas ainda tô com preguiça de implementar aqui(rsrsrsrs).

    Abs.
    Última edição por xnetinho; 16-07-2008 às 03:35.



  5. #5

    Padrão

    Pela forma que voce descreve deve funfar legal. Mas quanto a web-proxy? dá pra rodar? esse é o grande problema do balanceamento, será que alguem ja encontrou uma forma de conciliar esses serviços?. Valeu..

  6. #6

    Padrão

    Para web-proxy o que fiz foi colocar um proxy antes do Gateway ai resolveu.



  7. #7

    Padrão

    Citação Postado originalmente por Mirandapb Ver Post
    Pela forma que voce descreve deve funfar legal. Mas quanto a web-proxy? dá pra rodar? esse é o grande problema do balanceamento, será que alguem ja encontrou uma forma de conciliar esses serviços?. Valeu..


    Para resolver esse problema eu montei uma máquinha exclusiva pra LB. E o restante dos serviços em outra(web-proxy, autenticação, firewall, controle de banda, etc...).

    Pretendo montar uma máquina exclusiva pra web-proxy tb, rodando Linux Debian + Squid.

    Abs.

  8. #8

    Padrão

    Amigo colocar um server rodando o linux para web-proxy pelo visto é uma mao na roda(show de bola), mas tenho duvida quanto a instalação, ou seja, ele ficaria intercalado entre o MK e o Hub? ou como um cliente? seli la... fico confuso com a
    sua disposição na rede. Obrigado.



  9. #9

    Padrão

    Citação Postado originalmente por Mirandapb Ver Post
    Amigo colocar um server rodando o linux para web-proxy pelo visto é uma mao na roda(show de bola), mas tenho duvida quanto a instalação, ou seja, ele ficaria intercalado entre o MK e o Hub? ou como um cliente? seli la... fico confuso com a
    sua disposição na rede. Obrigado.
    A meu ver, o ideal seria ligar o web-proxy e o LB diretamente ao seu servidor de principal.



    [ CLIENTES ]
    ^
    ||
    ||
    ||
    ============================||
    [ LINUX SQUID ]< ===== >[ MK PRINCIPAL ]< ===== > [ LOAD BALANCE ]

    Abs.

    Vc é de J. Pessoa? De onde?

  10. #10

    Padrão

    Ola Pessoal mudei a marcação do meu LB para a seguinte maneira:

    /ip firewall mangle
    Código :
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link1 nth=4,0 \
        passthrough=yes
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link1 nth=4,1 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link1 connection-mark=Link1 \
        disabled=no in-interface=Local new-routing-mark=R-Link1 passthrough=no
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link2 nth=4,2 \
        passthrough=yes
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link2 nth=4,3 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link2 connection-mark=Link2 \
        disabled=no in-interface=Local new-routing-mark=R-Link2 passthrough=no
    add action=mark-connection chain=prerouting comment=Link3 connection-state=\
        new disabled=no in-interface=Local new-connection-mark=Link3 nth=4,4 \
        passthrough=yes
    add action=mark-routing chain=prerouting comment=Link3 connection-mark=Link3 \
        disabled=no in-interface=Local new-routing-mark=R-Link3 passthrough=no
    add action=mark-routing chain=prerouting comment=Bancos disabled=no dst-port=\
        443 new-routing-mark=Bancos passthrough=no protocol=tcp
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
        1863 new-routing-mark=msn passthrough=no protocol=tcp
    add action=mark-routing chain=prerouting comment=Bradesco disabled=no \
        dst-address=200.155.84.15 new-routing-mark=Bradesco passthrough=no

    E meus contadores ficam por exemplo assim;

    Link1 --> 100
    Link2 --> 50
    Link3 --> 25

    E o que eu gostaria é que fosse na seguinte proporção:
    Link1 --> 100
    Link2 --> 100
    Link3 --> 50

    Sera que alguem pode me ajudar a descobrir o que esta errado?