+ Responder ao Tópico



  1. O problema é que está bloqueado todo trafego de MSN , e na verdade era só para bloquear o
    trafego quando o address-list fosse diferente de Msn-Liberado.

    Alguem já usou desta forma ?

    Estou usando o MK 3.x.


    /ip firewall address-list
    add address=10.10.10.2 comment="" disabled=no list=Msn-Liberado
    add address=10.10.10.3 comment="" disabled=no list=Msn-Bloqueado

    /ip firewall filter
    add action=drop chain=forward comment= "*********** Bloqueia Msn ***********" disabled=no layer7-protocol=MSN src-address-list=!Msn-Liberado

    add action=drop chain=forward comment= "*********** Bloqueia Msn ***********" disabled=no layer7-protocol=MSN_FT src-address-list=!Msn-Liberado

    /ip firewall layer7-protocol
    add comment="MSN Messanger" name=MSN regexp="ver [0-9]+ msnp[1-9][0-9]\? [\\x0\
    9-\\x0d -~]*cvr0\\x0d\\x0a\$|usr 1 [!-~]+ [0-9. ]+\\x0d\\x0a\$|ans 1 [!-~]\
    + [0-9. ]+\\x0d\\x0a\$"
    add comment="MSN File Transfer" name="MSN_FT" regexp=\
    "^(ver [ -~]*msnftp\\x0d\\x0aver msnftp\\x0d\\x0ausr|method msnmsgr"

  2. Use a address list somente para os bloqueados, daí só add os ip a serem barrados.

    /ip firewall address-list
    add address=10.10.10.3 comment="" disabled=no list=Msn-Bloqueado

    /ip firewall filter
    add action=drop chain=forward comment= "Bloqueia Msn" disabled=no layer7-protocol=MSN src-address-list=Msn-Bloqueado

    /ip firewall layer7-protocol
    add comment="MSN Messanger" name=MSN regexp="ver [0-9]+ msnp[1-9][0-9]\? [\\x0\
    9-\\x0d -~]*cvr0\\x0d\\x0a\$|usr 1 [!-~]+ [0-9. ]+\\x0d\\x0a\$|ans 1 [!-~]\
    + [0-9. ]+\\x0d\\x0a\$"

    add comment="MSN File Transfer" name="MSN_FT" regexp=\
    "^(ver [ -~]*msnftp\\x0d\\x0aver msnftp\\x0d\\x0ausr|method msnmsgr:)"
    Última edição por Raniel; 14-07-2008 às 17:40.



  3. Citação Postado originalmente por Mr. RG Ver Post
    Use a address list somente para os bloqueados, daí só add os ip a serem barrados.

    /ip firewall address-list
    add address=10.10.10.3 comment="" disabled=no list=Msn-Bloqueado

    /ip firewall filter
    add action=drop chain=forward comment= "Bloqueia Msn" disabled=no layer7-protocol=MSN src-address-list=Msn-Bloqueado

    /ip firewall layer7-protocol
    add comment="MSN Messanger" name=MSN regexp="ver [0-9]+ msnp[1-9][0-9]\? [\\x0\
    9-\\x0d -~]*cvr0\\x0d\\x0a\$|usr 1 [!-~]+ [0-9. ]+\\x0d\\x0a\$|ans 1 [!-~]\
    + [0-9. ]+\\x0d\\x0a\$"

    add comment="MSN File Transfer" name="MSN_FT" regexp=\
    "^(ver [ -~]*msnftp\\x0d\\x0aver msnftp\\x0d\\x0ausr|method msnmsgr"
    O que fiz para resolver , foi o seguinte :

    :for x from=2 to=254 do={
    :global tipo;
    :if (x=2) do={:set tipo "Msn-Liberado"} else={:set tipo "Msn-Bloqueado"};
    /ip firewall address-list add address="10.10.10.$x" list="$tipo"}}
    }

    /ip firewall filter
    add action=drop chain=forward comment= "*********** Bloqueia Msn ***********" disabled=no layer7-protocol=MSN src-address-list=Msn-Bloqueado

    add action=drop chain=forward comment= "*********** Bloqueia Msn ***********" disabled=no layer7-protocol=MSN_FT src-address-list=Msn-Bloqueado






Tópicos Similares

  1. Respostas: 6
    Último Post: 14-07-2008, 09:17
  2. Bloquear Ultrasurf com layer7
    Por dsxxsd no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-05-2008, 10:16
  3. Bloquear MSN com Squid e Dansguardian
    Por albernaz no fórum Servidores de Rede
    Respostas: 7
    Último Post: 30-10-2007, 09:23
  4. Bloquear MSN e Orkut com Squid
    Por dmgamer no fórum Servidores de Rede
    Respostas: 5
    Último Post: 28-02-2007, 14:11
  5. Bloquear video, arquivos no MSN com IPTABLES
    Por andrefs no fórum Servidores de Rede
    Respostas: 6
    Último Post: 25-10-2006, 13:07

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L