+ Responder ao Tópico



  1. #1

    Padrão Ja li outros posts e nao resolvi. Redirecionamento web rede interna sem PPPOE/Hotspot

    Amigos, preciso de uma ajuda.

    - Eu nao uso Hotspot nem PPPoE (digo isso pois já achei soluções para quem os utiliza, mas essas soluções não serviram para mim). Eu uso apenas IPxMAC

    - Pois bem, se eu faco a seguinte regra:

    / ip firewall nat
    add chain=dstnat action=dst-nat to-addresses=200.98.249.120 to-ports=80 \
    src-address=10.0.0.248 dst-address=!10.0.0.2 dst-port=80 protocol=tcp \
    connection-limit=!1,24 comment="" disabled=no

    legenda:
    10.0.0.248 = minha máquina
    10.0.0.2= meu gateway
    200.98.249.120= ip do UOL

    Com isso fica certinho: qdo eu abro o navegador, a primeira pagina que aparece é a do UOL, depois disso ele navega normalmente.

    Agora, se eu direcionar para uma máquina interna da rede com um servidor web não funciona:

    / ip firewall nat
    add chain=dstnat action=dst-nat to-addresses=10.0.0.200 to-ports=80 \
    src-address=10.0.0.248 dst-address=!10.0.0.2 dst-port=80 protocol=tcp \
    connection-limit=!1,24 comment="" disabled=no

    Se eu digitar no browser http://10.0.0.200 ele entra na página normalmente, ou seja, é alguma coisa no MK que não deixa fazer isso.

    Aí vem o mais legal, se eu fizer:

    / ip firewall nat
    add chain=dstnat action=dst-nat to-addresses=10.0.0.2 to-ports=889 \
    src-address=10.0.0.248 dst-address=!10.0.0.2 dst-port=80 protocol=tcp \
    connection-limit=!1,24 comment="" disabled=no

    Ele coloca a página de administração do MK apenas uma vez e depois navega direitinho!

    Entao percebi que o direcionamento dessa forma funciona apenas para máquinas FORA da minha rede ou para o PROPRIO MK, mas não para máquinas dentro da minha rede!

    Alguém sabe como faço para que esse redirecionamento funcione dentro da minha rede?

    Importante: Já dei disable em tudo que era regra de DROP que tinha no firewall

    Muito obrigado!!
    Fabricio

  2. #2
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Regras

    Olá Fabricio, acho que posso te ajudar.........rss..... esperimenta ai:
    Em baixo da sua regra de nat adicione a seguinte regra e teste ai depois poste o resultado e se tiver exito agradeça.

    Código :
    add chain=srcnat out-interface=[COLOR=red]Interface[/COLOR] action=masquerade comment="NAT - Server Web Interno" disabled=no

    *** Obs.: Onde está em vermelho altere para o nome da Interface que está a faixa de ip a ser usada tipo Clientes.



  3. #3

    Padrão

    Oi!
    Obrigado.. Mas não funcionou...
    Alguma idéia?

    Valeu!
    Fabricio

  4. #4
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Regras

    Bom vamos por parte explique bem detalhado o que precisa fazer, para podermos ajuda-lo.



  5. #5

    Padrão

    Olá amigo,
    Use a função jump, assim ele irá direto para seu servidor web local.
    Caso tenha dúvidas, dê uma olhada aqui:

    https://under-linux.org/forums/mikro...tml#post329025

  6. #6

    Padrão redirecionamento para o MK

    Desculpa amigo eu não sei a resposta para sua pergunta, mais a sua dica me ajudou muito, estava precisando do redirecionamento externo, só que a regra de redirecionamento para página interna do MK não funcionou comigo

    / ip firewall nat
    add chain=dstnat action=dst-nat to-addresses=10.1.1.2 to-ports=889 \
    src-address=192.168.2.254 dst-address=!10.1.1.2 dst-port=80 protocol=tcp \
    connection-limit=!1,24 comment="" disabled=no

    interface dos clientes 192.168.2.1
    meu ip para teste 192.168.2.254
    gateway (MK) 10.1.1.2

    o resultado é que quando ativo a regra eu não navego mais, vc sabe aonde está o erro? desde já obrigado



  7. #7

    Padrão

    Consegui fazer funcionar direitinho. É que a minha interface interna estava reply-only e o mac da maquina com o servidor nao estava na tabela ARP.

    Mas mesmo assim só funcionou qdo coloquei a regra do Minelli! Valeu Cara!

    Antes acontecia como o amigo sgctrobson havia dito!

    Abraço!
    Fabricio

  8. #8

    Padrão

    Blz amigo fico feliz que tenha conseguido atingir seu objetivo, vc sabe me dizer para que serve esse item
    connection-limit=!1,24 (parece que tem haver com a quantidade de vezes que a pessoa vai ser direcionada ao site) mais quando coloco 1,24 a minha página aparece toda distorcida e se aumento para 4,24 aparece legal mais a pessoa fica presa ao site por algumas vezes. me de uma ajuda ai amigão.



  9. #9

    Padrão

    o problema é justamente esse, ele nao controla direito de qto em qto tempo deve "prender o cara na pagina"...

    O meu, passava uma vez e depois ficava normal, mas depois de alguns segundos ja fazia novamente.. Ai fica muita coisa!

    Vou aplicar o Hotspot mesmo!