+ Responder ao Tópico



  1. #1

    Unhappy Liberar acesso total para um ip

    Galera tudo bem?
    bom sou iniciante com mikrotik, e tenho minhas duvidas...
    mais a principal delas é a respeito de torrents e todo tipo de p2p...
    ja li e algumas materias aki a respeito de limitar p2p e tal, mais preciso liberar acesso total p2p em geral(incluindo torrent)
    ja consegui uma vez liberar as portas para o torrent, mais acho que tem algo de errado, pois assim que abro o programa torrent a navegacao fica horrivel e os downloads no torrent nao atingem nem metade da metade do que fazia quando so usava o modem sem nenhum controle.
    alguem pode me dar uma luz?

  2. #2

    Padrão

    Citação Postado originalmente por striteiro Ver Post
    ...
    alguem pode me dar uma luz?
    Faça marcação de pacotes e gere uma queue tree para estes com o limite tx/rx desejado.



  3. #3

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Faça marcação de pacotes e gere uma queue tree para estes com o limite tx/rx desejado.
    mais como faco isso?
    so me da uma ideia de como por favor?

  4. #4

    Padrão

    Primeiro coloque esta regra no firewall:
    /ip firewall filter
    add chain=forward src-address=192.168.1.0/24 p2p=all-p2p out-interface=link action=drop comment="dropar p2p" disabled=no

    Para liberar alguns ips para que usem p2p na rede, adicionar esta regra acima da regra de bloqueio para todos:
    /ip firewall filter
    add chain=forward src-address=192.168.1.5/32 p2p=all-p2p out-interface=link action=accept comment="aceitar p2p para fulano" disabled=no

    Para marcar os pacotes do ip:
    /ip firewall mangle
    chain=prerouting src-address=192.168.1.5/32 p2p=all-p2p action=mark-connection new-connection-mark=p2p_fulano passthrough=yes

    chain=prerouting connection-mark=p2p_fulano action=mark-packet new-packet-mark=p2p-fulano passthrough=no

    Para controlar o p2p de fulano:
    /queue tree
    add name=p2p-fulano-in parent=global-in packet-mark=p2p-fulano limit-at=3000 max-limit=64000
    add name=p2p-fulano-out parent=global-out packet-mark=p2p-fulano limit-at=3000 max-limit=64000

    Isto aí, aqui você controlou o ip 192.168.1.5 para que o p2p dele trafegue a 64/64 (tx/rx).
    Lembrando que pode fazer um limite para toda a rede, mas o valor definido para tx/rx será compartilhado pela mesma.



  5. #5

    Padrão

    ok, melhorou um pouco, mais mesmo assim a taxa de transferencia continua baixa...
    ex: tenho um link de 1mb, depois q implementei o Mk com p2p nao faço download a mais de 40kbs, e de download http nao passa dos 60kbs...
    sera q tem algo que posso fazer pra melhorar essa taxa?

  6. #6

    Padrão

    Quantos seeds e quantos leechers? Pode ser que não há suficientes para manter alta taxa...



  7. #7

    Padrão

    Citação Postado originalmente por zaphodbr Ver Post
    Quantos seeds e quantos leechers? Pode ser que não há suficientes para manter alta taxa...
    por volta de 35 a 50, varia mais nunca menos de 30!
    nao creio q seja problema de seeders ou leechers...pq no programa q uso tem um icone vermelho onde era pra ficar verde(lugar onde mostra que estou conectavel)
    e outra, é so abrir o programa q a internet fica mto lenta, basicamente nao navega

  8. #8

    Padrão

    Deve ser um limite de conexões simultâneas agindo... Diminuir o máximo de conexões pelo utorrent deve minimizar isso, mas quanto a velocidade, eu não saberia explicar. Continuo com a opinião (só uma das hipóteses) dos poucos seeders, pois em tracker aberto poucos liberam um upload legal.