Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Instalei o Mandriva ONE 2008.1 - spring
    apache 2.2.8-6mdv2008.1

    no http.conf coloquei:
    <Directory "/arquivos/www">
    Options -Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>


    DefaultLanguage pt-BR

    AddDefaultCharset ISO-8859-1



    AddCharset ISO-8859-1 .iso8859-1 .latin1
    AddCharset ISO-8859-2 .iso8859-2 .latin2 .cen
    AddCharset ISO-8859-3 .iso8859-3 .latin3
    AddCharset ISO-8859-4 .iso8859-4 .latin4
    AddCharset ISO-8859-5 .iso8859-5 .latin5 .cyr .iso-ru
    AddCharset ISO-8859-6 .iso8859-6 .latin6 .arb
    AddCharset ISO-8859-7 .iso8859-7 .latin7 .grk
    AddCharset ISO-8859-8 .iso8859-8 .latin8 .heb
    AddCharset ISO-8859-9 .iso8859-9 .latin9 .trk
    AddCharset ISO-8859-10 .iso8859-10 .latin6
    AddCharset ISO-8859-13 .iso8859-13
    AddCharset ISO-8859-14 .iso8859-14 .latin8
    AddCharset ISO-8859-15 .iso8859-15 .latin9
    AddCharset ISO-8859-16 .iso8859-16 .latin10
    AddCharset ISO-2022-JP .iso2022-jp .jis
    AddCharset ISO-2022-KR .iso2022-kr .kis
    AddCharset ISO-2022-CN .iso2022-cn .cis
    AddCharset Big5 .Big5 .big5

    restartei o apache, rebutei a máquina e nada.

    Se alguém tiver alguma sugestão.

  2. e nada o que?

    qual era o comportamento esperado e exatamente o que não aconteceu?

    Tem algum arquivo index.html no diretório? O apache está inicializando junto com o sistema?

    O que ele mostra nos arquivos access_log e error_log?

    Tenta trocar o -Indexes por Indexes nas permissões acima e veja se pelo menos ele mostra a listagem do conteúdo do diretório.



  3. Caro Frederico

    A acentuação continua a não funcioar, mostrando caracteres estranhos.
    Existe um arquivo html com várias letras acentuadas para teste.
    O apache está rodando. As log não mostram nada, pois não é erro do sistema.
    Já fiz todas as sugestões e procedimentos padrões adotados, creio que seja alguma coisa de diferente no Mandriva.

  4. Foi mal! Não tinha prestado atenção ao título do tópico e não me atentei que o seu problema era de acentuação. Vamos lá:

    Você colocou como charset padrão do seu apache, o ISO-8859-1 que é o formato latin1. Se os acentos estão aparecendo de forma "esquisita", faça o seguinte teste no seu navegador, se for o firefox, vá em "Exibir / Codificação" e veja qual é a codificação que está configurada, se for ISO-8859-1, coloque para UTF-8 e veja se os acentos aparecem normalmente, se estiver como UTF-8, coloque para ISO-8859-1 e veja se os acentos aparecem normalmente.

    Verifique o código fonte do seu arquivo html, veja qual é o formato que ele foi gravado ou que está especificado no header dele. Procure por linhas que configurem o charset, que podem ser tags do tipo META ou mesmo no DocType. Por último, tente converter o formato do arquivo com o comando:

    Código :
    iconv -f utf-8 -t latin1 acentos.html > acentos2.html

    ou ao contrário com o comando:

    Código :
    iconv -f latin1 -t utf-8 acentos.html > acentos3.html

    e tente acessar estes arquivos acentos2.html 2 acentos3.html e veja como fica a acentuação neles.

    Informe os resultados.



  5. Já fiz todos estes teste e não mudou nada.
    Como este será um site aberto com blog, não posso simplesmente mudar a codificação das páginas, pois o conteúdo que será postado pode trazer dor de cabeça.
    Acho que vou migrar para o Debian que já testei e não apresentou estes problemas.
    Agradeço a atenção de todos.






Tópicos Similares

  1. Acentuação no Apache???
    Por thelast no fórum Servidores de Rede
    Respostas: 10
    Último Post: 19-10-2005, 09:41
  2. acentuacao no apache
    Por rlucatto no fórum Servidores de Rede
    Respostas: 3
    Último Post: 26-05-2004, 17:20
  3. Acentuação no Slack
    Por MarGer no fórum Servidores de Rede
    Respostas: 2
    Último Post: 23-09-2002, 20:35
  4. Estatísticas no apache
    Por ediguedes no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-07-2002, 10:56
  5. Mod_SSL No apache 2.0.36
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-04-2002, 01:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L