Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Exclamation Cache Full no 3.11, funcionando blz!!!

    Olá pessoal, é o seguinte!!!
    peguei umas regras(pra versoes mais antigas do MK) postadas por alguns colegas do forum, e observando o funcionamento eu fui adaptando conforme minha necessidade. Pois minha experiencia é pouquissima!

    Já tinha procurado aki no under mas nao encontrei, resolvi postar pra vcs testarem.
    Obs: no meu aki ta funcionando como esperado!!!

    ip firewall mangle
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="cache full" packet-mark=proxyfull parent=global-out priority=8 queue=default

    Espero estar ajudando!!!
    Se funcioanr pra vc, agradeça!!!

  2. #2

    Padrão

    é ouvi muitos amigos aqui dizendo que o cache ful na 3.11 não tava fazendo, essas suas regras vai ajudar muito



  3. #3

    Padrão

    isso ai voce liberou o trafego WWW todo !!!
    independente de o objeto estar no cache ou nao

  4. #4

    Padrão

    Citação Postado originalmente por PowerNet Ver Post
    Olá pessoal, é o seguinte!!!
    peguei umas regras(pra versoes mais antigas do MK) postadas por alguns colegas do forum, e observando o funcionamento eu fui adaptando conforme minha necessidade. Pois minha experiencia é pouquissima!

    Já tinha procurado aki no under mas nao encontrei, resolvi postar pra vcs testarem.
    Obs: no meu aki ta funcionando como esperado!!!

    ip firewall mangle
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="cache full" packet-mark=proxyfull parent=global-out priority=8 queue=default

    Espero estar ajudando!!!
    Se funcioanr pra vc, agradeça!!!
    Prá ver se está usando mesmo o proxy, baixa um arquivo, depois limpa o cache do navegador e apaga o arquivo e baixa de novo. Se tiver no proxy a diferença na velocidade vai ser grande.



  5. #5
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    isso ai voce liberou o trafego WWW todo !!!
    independente de o objeto estar no cache ou nao
    Alexandre, na 3.x os HITs do cache são marcados com TOS diferente (4). De acordo com o wiki da Mikrotikls funciona. É o que está postado acima pelo colega e conforme link abaixo.

    Queue with Masquerading and Internal Web-Proxy - MikroTik Wiki

  6. #6

    Padrão

    Colegas blz...
    sei que é uma pergunta besta, mas estou tentando digitar as regras acima e o meu terminal está completando as palavras e algumas coisas ele não deixa digitar.
    Como desativar?



  7. #7

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    Prá ver se está usando mesmo o proxy, baixa um arquivo, depois limpa o cache do navegador e apaga o arquivo e baixa de novo. Se tiver no proxy a diferença na velocidade vai ser grande.


    Já fiz isso!!! e tá funcionando corretamente ate o momento!!!

  8. #8

    Thumbs up

    Citação Postado originalmente por alexandrecorrea Ver Post
    isso ai voce liberou o trafego WWW todo !!!
    independente de o objeto estar no cache ou nao
    Caro colega!!!
    Como o Sergio disse, a marcação do webproxy na versão 3.xx é diferente da 2.xx
    O cache full ta funcionado aki sem afetar o controle de banda.
    Baixei um arquivo com taxa de transferencia de 15k/s e ao terminar fui em outra maquina na rede e baixei o mesmo arquivo ( que agora estava em cache) a 670k/s de taxa de transferencia. Tudo isso em bancada de testes e usando um ap em modo "B".
    Faça um teste e verá que funciona!!!



  9. #9

    Question Web-proxy

    Citação Postado originalmente por PowerNet Ver Post
    Olá pessoal, é o seguinte!!!
    peguei umas regras(pra versoes mais antigas do MK) postadas por alguns colegas do forum, e observando o funcionamento eu fui adaptando conforme minha necessidade. Pois minha experiencia é pouquissima!

    Já tinha procurado aki no under mas nao encontrei, resolvi postar pra vcs testarem.
    Obs: no meu aki ta funcionando como esperado!!!

    ip firewall mangle
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=proxyfull disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no

    queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name="cache full" packet-mark=proxyfull parent=global-out priority=8 queue=default

    Espero estar ajudando!!!
    Se funcioanr pra vc, agradeça!!!
    ? E as configs do web-cache ?
    Aqui num funfou! No que será que estou errando? Utilizo a 3.10.
    Agradeço qualquer que seja.

  10. #10

    Thumbs up Ctrol + v

    Citação Postado originalmente por NetoGO23 Ver Post
    Colegas blz...
    sei que é uma pergunta besta, mas estou tentando digitar as regras acima e o meu terminal está completando as palavras e algumas coisas ele não deixa digitar.
    Como desativar?

    Neto, vc deve ter utilizado o recurso ctrol+c / ctrol+v para copiar as regras para o terminal correto?
    Não utilize ctrol+v para colar, pois é nesse momento na janela do terminal que o recurso é ativado!
    Utilize o botão direito do mouse e clique em colar! Para desativar o recurso basta pressionar novamente ctrol+v.

    Atenciosamente,
    Atus Informática Ltda



  11. #11

    Padrão

    Citação Postado originalmente por Atus Ver Post
    ? E as configs do web-cache ?
    Aqui num funfou! No que será que estou errando? Utilizo a 3.10.
    Agradeço qualquer que seja.
    Meu proxy tá assim!
    /ip proxy
    set always-from-cache=no cache-administrator="webmaster" \
    cache-drive=first-sata-drive cache-hit-dscp=4 cache-on-disk=yes enabled=\
    yes max-cache-size=unlimited max-client-connections=600 max-fresh-time=\
    3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 \
    port=3128 serialize-connections=yes src-address=0.0.0.0

    /ip firewall nat
    add action=redirect chain=dstnat comment=" REDIRECIONA WEB PROXY" disabled=\
    no dst-port=80 in-interface=CLIENTES protocol=tcp src-address=IP do seu servidor hotspot/24 \
    to-ports=3128

    Lembrando que estou fazendo os testes usando hotspot, e essa regra nat acima vem depois do mascaramento do hotspot.

    E se funcionou no 3.11, provavelmente funcione em todas as 3.xx.





    Espero ter ajudado!
    Última edição por PowerNet; 27-07-2008 às 10:56.

  12. #12

    Padrão Conf web proxy - HD - sata

    Boa tarde, estou com uma dúvida. Coloquei um hd no meu gateway para gerar o proxy, ae qdo seleciono o mesmo para trabalhar com o proxy, o cache-drive sempre volta para system e não fica marcado o fist-sata-drive. Mas acredito que as informações estão sendo gravadas nele, pois minha flesh não está diminuindo o tamanho livre de arquivos dela.

    O q pode ser?? Muito obrigado.



  13. #13

    Padrão

    Citação Postado originalmente por baldim Ver Post
    Boa tarde, estou com uma dúvida. Coloquei um hd no meu gateway para gerar o proxy, ae qdo seleciono o mesmo para trabalhar com o proxy, o cache-drive sempre volta para system e não fica marcado o fist-sata-drive. Mas acredito que as informações estão sendo gravadas nele, pois minha flesh não está diminuindo o tamanho livre de arquivos dela.

    O q pode ser?? Muito obrigado.

    Boa noite! e desculpe a demora!!!
    mas vc ta usando qtos HDs nessa makina?
    se for só um, ta td certo!
    pois com uma só unidade a cache é criada dentro de system.



  14. #14

    Padrão

    Citação Postado originalmente por PowerNet Ver Post
    Boa noite! e desculpe a demora!!!
    mas vc ta usando qtos HDs nessa makina?
    se for só um, ta td certo!
    pois com uma só unidade a cache é criada dentro de system.




    To usando um flash memory e um hd de 160 gb sata.



  15. #15

    Padrão

    E aí Alexandre... funfa ou não funfa o cache-full na 3.11?
    Você já fez algum teste?

    Obrigado.

  16. #16

    Padrão

    funciona com o webproxy (lixo) do mikrotik 3.x mas o foda eh.. o cache do mk 3.. enche.. e começa a ficar lento ...

    vou fazer mais testes.. estou sem routerboard pra fazer testes.. precisei usar a minha para fazer uma reposição em uma torre q deu problema..



  17. #17

  18. #18

    Padrão

    Amigo, tendo em vista que a regra do proxy-full mudou, não teriam mudado outras regras de marcação de pacotes ?
    como:
    MSN
    P2P
    HTTP
    VOIP
    UDP .. etc etc.. tem como vc postar suas regras de mangle completas aqui ?



  19. #19

    Padrão Tentando

    Olá, ja consegui fazer o cache full no mk 2.9, mas estou tentando conseguiur sem sucesso no 3.13, segui as suas instruçoes e alterei conforme necessario para a minha rede mas nao funcionou, tentei de varias formas, mas os pcotes não são marcados, provavelmente porque eu estou usando um proxy em paralelo com o mikrotik, alguem ai tem alguma idéia?? alteria as portas de acordo com a minha rede, testei de varias formas, mas os pacotes nem se quer são marcados.
    Valeu galera.

  20. #20

    Padrão

    Tem como voce postar as regras do teu WEB-PROXY ????? Tô apanhando....o meu não para de dar a msg INVALID ANDRESS