Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Ajuda Telnet

    Ola galera,

    tenho o red hat 4 enterprise instalado e uso o ssh para acesso devido a segurança, porem eu necessito do telnet para acesso ao sistema da empresa que eu trabalho.

    No ssh o sistema fica desfigurado e tem algumas coisas que nao funcionam.

    Preciso rodar o servidor telnet... ele ja veio instalado no red hat... no /etc eu vejo apenas o xinetd.conf com algumas linhas... tento rodar no /usr/sbin/xinetd mas nada... tentei liberar no iptables e nada...

    alguem poderia me ajudar?

    valeu

  2. #2

    Padrão

    Cara, faz muito tempo que mexi com redhat, mas ele tinha um comando muito legal que é o service. Dá um "service telnet start" ai e ve o que dá.

    Se ele acusar que não conhece telnet ai você tenta esse:
    Código :
    chkconfig --list | grep telnet

    Esse eu nem conhecia, achei na net! ele deve te retornar o status do servidor telnet.

    Caso ele encontre o telnet verifique o arquivo /etc/xinetd.d/telnet. Tem que ter essas linhas:
    Código :
    # default: on
    disable = no

    Se estiver diferente altere e depois reinicie o serviço:
    Código :
    /etc/rc.d/init.d/xinetd restart


    Depois pra restartar só o telnet você pode user o service:
    Código :
    service telnet stop
    service telnet start
    Acho que era isso ai...
    Última edição por Magnun; 24-07-2008 às 17:40.



  3. #3

    Padrão

    Magnum,

    entao olha antes de eu fazer as instrucoes

    [[email protected] ~]# chkconfig --list | grep telnet
    krb5-telnet: desligado
    [[email protected] ~]#

    depois fiz o que vc falo

    dei um ./xinetd start

    [[email protected] init.d]# chkconfig --list | grep telnet
    krb5-telnet: ligado
    [[email protected] init.d]#


    nao consigo acessar... será iptables? to achando estranho

  4. #4

    Padrão

    tu ta sem o servidor telnet cara... Vai ter que instalar ele... Como te disse não tenho muito conhecimento em redhat. Então recorri ao google! Achei isso aqui: Linux: Como faço p/ configurar o telnet no meu... [Pergunta]

    É pro redhat 9... Acho que também se aplica. Vou continuar pesquisando pro redhat 4... Se achar algo posto aqui! Tenta instalar a partir desse ai....



  5. #5

    Padrão

    pois é magnun to só com cliente instalado... eu achei que a instalacao full do cd vinha tudo...

    [[email protected] etc]# rpm -qa|grep telnet
    telnet-0.17-30

    [[email protected] etc]# rpm -q telnet-server
    o pacote telnet-server não está instalado


    ta vendo

    nossa esse artigo que vc acho ta muito bem explicado... vou tentar.

    é dificil achar suporte pro red hat 4... to acostumado com outroas distribuicoes... to estranhando mto essa

    é uma versao mto boa... eu que preciso me adaptar

    vo tentar aqui ai eu posto
    valeu mesmo!

    att
    Paulo

  6. #6

    Padrão

    vixi cara... fui baixar o telnetd-server ... sem chance... vira uma bola de neve... ele depende de outros sources... ai vc baixa os outros e esses outros precisam de mais outros...

    estranho nao ter instalado ... fiz a instalacao full



  7. #7

    Padrão

    esse é um dos motivos de eu ter fugido do redHat... no debian um apt-get resolve tudo... Amanha pesquiso alguma coisa, não achei muito hoje...

  8. #8

    Padrão

    pois é eu uso slack em casa... e eu gosto mto ... mas pra trabalhar com servidor corporativo... o red hat é melhor... pelo menos eu acho.

    instalei o ftpd hoje... foi tranquilo... agora soh falta o telnet.

    to na correria atras

    me cadastrei naquela lista linux-br... ai eu mando email... eu recebo falando que nao foi autorizado... estranho... vc é cadastrado nessa lista?

    bom falow

    valeu
    att

    Paulo



  9. #9

    Padrão

    Citação Postado originalmente por engpaulo Ver Post
    pois é eu uso slack em casa... e eu gosto mto ... mas pra trabalhar com servidor corporativo... o red hat é melhor... pelo menos eu acho.

    instalei o ftpd hoje... foi tranquilo... agora soh falta o telnet.

    to na correria atras

    me cadastrei naquela lista linux-br... ai eu mando email... eu recebo falando que nao foi autorizado... estranho... vc é cadastrado nessa lista?

    bom falow

    valeu
    att

    Paulo
    Conheço o linux-br, mas nunca tentei me cadastrar na lista... Cara, pesquisando por ai, li que no CD do redhat 4 tem o telnet-server e as dependencias... Vi falar também de uma tal de redhat network (link: https://rhn.redhat.com/) você tem acesso a ela? Achei nessa FAQ (em ingles: redhat.com | Red Hat Support) um gua pra instalar o telner-server usando o comando up2date que usa essa red hat network (rhn) pra instalar pacotes... pra mim parece uma adaptação do apt-get

    Dá uma olhada talvez ajude... Não tem um comando pra resolver dependencias no redhat não?!

    de volta pro google...

  10. #10

    Padrão

    Fala Magnun blz??

    entao cara... muito bom esse link da redhat que vc me passou... eu li tudo e instalei no red hat rhn...

    ai eu dei

    up2date telnet-server telnet


    ele abre uma tela azul pra mim me registrar... pra mim entrar com usuario, senha e email.

    Nao fiz isso ainda pois quero ter a certeza que nao vai ter problemas... pq o rehl 4 é como se tivesse um serial... ele nao é gratuito... será que se eu criar essa conta na red hat nao vai ter problemas na empresa que eu trabalho?

    parece que por ali é batata pra instalar o telnet server.

    o que vc acha?

    falow



  11. #11

    Padrão

    Cara, infelizmente conheço muito pouco de redhat... às vezes la na área de redhat do forum alguém pode te ajudar sobre isso...

    Foi mal...

  12. #12

    Padrão

    brigadao magnun vc me ajudo muito


    valeusss

    falowww



  13. #13

    Padrão

    Se conseguir resolver posta ai a solução ok?!

    Valew...

  14. #14

    Padrão

    Fala Magnun blz??

    eu to apanhando aqui pq nao sou acostumado com essa distro do rehl4... to tendo que me adaptar... mas ta rolando legal.

    Entao hoje eu peguei o cd de instalacao do REHL4 e copiei o rpm telnet-server-0.17-30.i386.rpm .

    dei um rpm -i telnet-server-0.17-30.i386.rpm e einstalei o pacote.

    O telnet server esta instalado agora... antes ele tava pendindo arquivos dependentes pq era uma outra versao do rpm do telnet-server...

    esse que ta ai nao tive problemas e ele ta instalado

    [[email protected] ~]# rpm -qa | grep -i telnet
    telnet-server-0.17-30
    telnet-0.17-30

    foda que eu tento startar o servico com service telnetd start ou service telnet-server start
    e ele da um erro
    telneted: unrecognized service

    estranho...

    do um find
    [[email protected] ~]# find / -name telnetd
    /usr/kerberos/sbin/telnetd

    e ele soh acha o server telnet do kerberos... era pra achar no /usr/sbin/telnetd tb nao era?

    falow



  15. #15

    Padrão

    Acho que era pra achar sim...
    ve se não tem nenhum script de inicialização do telnet no /etc/init.d

  16. #16



  17. #17

    Padrão

    e em /etc/xinetd.d/ tem o arquivo de configuração chamado telnet??

  18. #18

    Padrão

    entao magnun

    achei isso

    /etc/xinetd.d/telnet

    dei um nano telnet

    # default: on
    # description: The telnet server serves telnet sessions; it uses \
    # unencrypted username/password pairs for authentication.
    service telnet
    {
    flags = REUSE
    socket_type = stream
    wait = no
    user = root
    server = /usr/sbin/in.telnetd
    log_on_failure += USERID
    disable = NO
    }


    a opcao disable esta YES... ai eu coloquei NO.

    agora eu nao sei se esse é o cliente ou o servidor...

    mas tava desabilitado e eu habilitei;;; o duro é como subir esse processo.

    [[email protected] sbin]# service telnet start
    telnet: unrecognized service

    estranho

    falow



  19. #19

    Padrão

    magnun,

    rapaiz era isso... habilitei no xinetd.conf ...

    ta rodando o telnet agora

    dei um kill -HUP no xinetd e ja era... ta rodando

    to comecando a gostar dessa rehl 4 em hehe

    faloww

  20. #20

    Padrão

    Blz então... é isso ai!