Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão User Manager + Hotspot (Artigo)

    Olá pessoal, mais uma vez venho, de acordo com algumas dúvidas de amigos, trazer mais um material sobre o MikroTik.
    O User Mananger, para quem não sabe, é uma forma de suprir a falta de um servidor radius externo*. Também é uma maneira de gerenciar sytemas como:

    Bem, eu vou mostrar apenas com fazê-lo rodar e acessar a web interface, agora add clientes, créditos entre outro é com vocês.


    Vamos dá início a nosso material.

    Materiais que eu usei:

    1. Duas interfaces de redes


    • wlan1 - wireless, na qual recebo sinal.
    • ether1 - ethernet, na qual repasso o sinal.
    • mikrotik 2.9.50, podendo ser em qualquer outra versão.


    Passo 1 - Como de costume, eu renomeio as interfaces:

    /interface set wlan1 name=internet
    /interface set ether1 name=network


    Passo 2 - Configurar os ips:

    /ip add add address=192.168.5.3/24 interface=internet
    /ip add add address=192.168.1.1/24 interface=network


    Passo 3 - Configurar o route:

    /ip route add gateway=192.168.5.1


    Passo 4 - Configurar o dns:

    /ip dns set primary-dns="seu dns"
    /ip dns static add name="mikrotik-ba.net" address=192.168.1.1



    Passo 5 - Compartilhar conexão:

    /ip firewall nat add chain=srcnat src-address=192.168.1.0/24 out-interface=internet action=masquerade comment="compartilhamento" disabled=no


    Passo 6 - Configurar servidor hotspot:

    /ip hotspot profile add name=server-pro dns-name=mikrotik-ba.net use-radius=yes hotspot-address=192.168.1.1

    Note: Não adicione usuários ao servidor hotspot ao menos que queira usar.


    Passo 7 - Configurando o radius:

    /radius add service=hotspot address=192.168.1.1 secret=123456

    Note: A senha(sercret) deve ser a mesma para o router que será criado no user manager, bem como o endereço. Caso o endereço do user manager seje de outra maquina, basta informar.


    Passo 8 - Configurando o user manager:

    1. Criar um administrador para o sistema, que usará a web interface:

    /tool user-manager customer add login="Mr. RG" password="12345" permissions=owner

    2. Criar uma lista de assinantes(assinatura):

    /tool user-manager router add subscriber="MikroTik" ip-address=192.168.1.1 shared-secret=123456

    Passo 9 - Criar um usuário de teste, o que, no caso, não terá nenhum limite:

    /tool user-manager user add username=demo password=demo subscriber=MikroTik

    Passo 10 - O truque para entrar na web interface:

    /ip service set www port=8008

    Note: Isto aqui não irá interferir no uso da internet.

    Passo 11 - Acessar a web interface e configurar o user manager ao seu dispor:

    http://192.168.1.1:8008/userman


    É isto aí, dúvidas e sugestões serão bem-vindas.

    Façam bom uso do user manager e não esqueçam de postar as experiencias, será de grande ajuda.

  2. #2

    Padrão

    Cara, você é fera mesmo viu.
    Eu ti falei que iria formatar o PC tal..
    mas lendo seu tópico, eu resolvi experimentar rodar o comando do Passo 10 "O truque para entrar na web interface:"
    Porque de todos os tópicos que já li aqui ou no orkut, em nenhum momento falaram deste "truque".

    Só sei que o bicho abriu aqui e logou. heuheuhe

    Bravo... Salve Mr. RG !!!


    Bem... eu vou fuçar agora neste user manager, e caso não tenha qualquer problema eu dou o meu problema como solucionado. Senão irei formatar zerando as configurações e vou refazer do zero seguindo o seu tópico.

    Peço por gentileza aos moderadores do fórum para que este tópico ganhe status de fixo. Pois aqui tem tudo para que as pessoas consigam ter seu MK com hotspot e user manager, dispensando o uso (pra quem não pode $$) o uso de um segundo servidor.

    Valeu mesmo Mr. RG !!!





  3. #3

    Padrão

    MR. RG

    Cara isto é de muita utilidade sim !!!! vamos testar com gosto !!!!
    a exemplo do alencar merece um fixo.

  4. #4

    Padrão

    Amigo vc esta de parabens ...

    mas aqui ta quando chego nesta parte

    "Passo 8 - Configurando o user manager:

    1. Criar um administrador para o sistema, que usará a web interface:

    /tool user-manager customer add login="Mr. RG" password="12345" permissions=owner

    2. Criar uma lista de assinantes(assinatura):

    /tool user-manager router add subscriber="MikroTik" ip-address=192.168.1.1 shared-secret=123456"

    da o seguinte erro

    input does not match any value of subscriber

    o que pode esta errado ?



  5. #5

    Padrão

    Citação Postado originalmente por marcosdiirr Ver Post
    ...
    da o seguinte erro

    input does not match any value of subscriber

    ...
    Geralmente, suponho que esteja usando uma versão 3.x, já vem um subscriber chamado admin, só colocar isto aí e em parent também.

  6. #6

    Padrão

    A minha versão é 3x também..
    então nesses passos eu fiz o seguinte, a cada palavra eu apenas digitava algumas letras e dava TAB, não me recordo quais foram os passos, mas em alguns nao precisei usar as aspas no nome e senha.



    No mais estou usando o User Manager pefeitamente, consigo criar usuários, creditos, etc..
    Vou dá uma lida no Wiki do MK sobre o User Manager... mais tarde abuso mais.
    rs

    =)
    Última edição por alencar2; 29-07-2008 às 11:40.



  7. #7
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão UserMan

    Bom minha versão é 2.9.xx porém ao terminar a configuração e tento entrar via web ele fica dando o erro:
    error fetching data.

  8. #8

    Padrão

    Citação Postado originalmente por minelli Ver Post
    ...
    error fetching data.
    Olá amigo, este é um erro de dados. O sistema não encontrou os dados. Sugiro que reveja suas configs.



  9. #9

    Padrão

    Meus parabéns .... estou em ambiente de testes ... rodando uma semana e no proximo fim de semana vou colocar em produção !

  10. #10

    Padrão

    Queria uma orientação.
    A partir do MK 3.10 zerado, fiz a configuração seguindo orientações do tópico com sucesso;;; Está tudo funcionando beleza.
    Agora gostaria de prosseguir adelante muchacho.


    Pergunto!
    No user manager eu ja criei créditos, usuarios etc.
    Então criei o usuario fictício jose com senha 123... e dei a ele 1 hora de internet..

    Mas como "jose" irá se logar? Eu preciso criar um servidor Hotspot (ip / hotspot / hotspot setup) e em seguida criar o usuario jose (ip / hotspot / users / + ) e definir uma senha a ele?
    Nao tem como eu apenas criar os usuarios no user manager, e no hotspot ele importar os usuarios permitidos (com respectivos creditos) do user manager ? Se sim, qual seria o caminho, porque estou me mordendo todo aqui rsrsrs

    Abraços



  11. #11

    Padrão

    Citação Postado originalmente por alencar2 Ver Post
    ...criar o usuario jose (ip / hotspot / users / + )...
    Opa amigo,
    Você não cria os usuários no hotspot, apenas no user manager. O hotspot loga os users da base de dados do user manager. Faça o teste depois que logar, /ip hotspot active pri e observer que depois do 0 haverá um "R" indicando o radius.

  12. #12

    Padrão

    ola amigo


    eu ja trabalho com hotspot , eu posso implementar esse pacote na minha versao 2.9.51 que nao ira ter problema algum?
    ou terei que desabilitar o hotspot e depois criar tudo novamente , ou é somente criar o user-manager que ira funcionar tudo redondo ?

    desde ja agradeço o seu retorno T+



  13. #13

    Padrão

    Citação Postado originalmente por airtonveiga Ver Post
    ola amigo


    eu ja trabalho com hotspot , eu posso implementar esse pacote na minha versao 2.9.51 que nao ira ter problema algum?
    ou terei que desabilitar o hotspot e depois criar tudo novamente , ou é somente criar o user-manager que ira funcionar tudo redondo ?

    desde ja agradeço o seu retorno T+
    Pode sim, o que você tem que faser é criar os usuários e estes não estejam cadastrados no hotspot, apenas no user manager. Só seguir os passos para ativação do user manager e não esquecer de ativar o uso do radius no profile do servidor hotspot.

  14. #14

    Padrão

    ola mr gr

    só pra ver se entendi mesmo ...

    se eu tenho o usuario airton com senha 1234 no hotspot com mac xx:xx:xx:xx:xx:xx e ip 192.168.5.200

    vou ter que deletar esse usuario e criar no user manager ? ou posso criar em paralelo no user-manager?

    qual seria o passo correto ? pois tenho mk apenas 1 ano e nao tenho muita experiencia com ele , tudo que aprendi devo a galera do under-linux .e tenho medo de fazer cagada !!!! rsss.

    gosto do hotspot pois tenho muita opçao nele , advertise pagina de debito essas coisa.


    se puder ajudar fico muit agradcido.

    valew.



  15. #15
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.409
    Posts de Blog
    10

    Padrão Erro Dados

    Olá Mr. MG sim eu sei que erro de dados o que quis perguntar se tem alguma ideia de onde pode estar o problema?

  16. #16

    Padrão

    Citação Postado originalmente por airtonveiga Ver Post
    ...
    gosto do hotspot pois tenho muita opçao nele , advertise pagina de debito essas coisa.
    ...
    Olá amigo,
    Infelizmente você não poderá usar em paralelo, pois o hotspot faz uma busca primeiro na base de dados local, ou seja, em sua propria, depois que procurar em outro local. Se tiver cadastrado no hotspot, ele não irá logar com o do user manager.
    O user manager será a base de dados do hotspot, que servirá apenas de servidor.



  17. #17

    Padrão

    Citação Postado originalmente por minelli Ver Post
    ...alguma ideia de onde pode estar o problema?
    Este erro pode ser falha de cadastro ou mesmo por duplo cadastro. Peço-lhe que reveja as confs.

  18. #18

    Padrão

    Pronto... o artigo já rendeu seu primeiro filho hehehehe..
    Após meses de labuta meu MK está com Hotspot + User Manager.
    show.
    Agora vou correndo salvar essa config no backup

    De agora em diante vou incrementa-lo, com página de débito y unas cositas mas.


    Salve Mr. RG !
    Última edição por alencar2; 31-07-2008 às 09:52.



  19. #19

    Padrão

    Com o UserManeger tem como o cliente alterar a senha dele?

  20. #20

    Padrão

    Citação Postado originalmente por alancp Ver Post
    Com o UserManeger tem como o cliente alterar a senha dele?
    Não. O user mananger é apenas um banco de dados. É como se você fizesse um servidor radius separado. O hotspot busca na base de dados do user manager.