Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Talking 2 links e 2 serviços distintos

    olá estou iniciando no under e gostaria q vcs me ajudem.... Eu tenho 1 link de 2 mega e 1 adsl de 1 mega e uso mikrotik, tenho um servidor com 3 interfaces, gostaria de q meus amigos abrissem as paginas http no adsl e todo restante no link... eu fiz da seguinte forma so q nao deu certo...
    /ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=HTTPpassthrough=yes comment="" disabled=no /ip route add gateway=x.x.x.x/x routing-mark=HTTP comment="HTTP Traffic" disabled=no

    /ip route rule add src-address=0.0.0.0/0 table=HTTP action=lookup me ajudem por favor... aguardo anciosa

  2. #2



  3. #3

    Padrão

    mr. rg eu lhe agradeço muito mais eu gostaria de saber uma coisa..... eu sei fazer lad balance da seguinte forma......eu tenho 1 link e 1 adsl eu divido do ip 1 ao 60 no link e do 60 ao 100 no link... faço isto criando uma regra no mangle com ip por ip q esta em minha adsl... gostaria de saber se pra fazer este outro balanceamento q divide os serviços é muito diferente e se alguem poderia me dar umas dicas.... mas agradeço viu fofo!!!!!!!!!

  4. #4

    Smile 2 links e 2 serviços distintos

    Ola Vitoria,

    Tenho em produção um Load Balancing com 2 ADSL rodando normal.. em 1 cliente
    e tenho outro rodando Embromatel + ADSL Velhox rodando legal... Posso te ajudar
    a montar suas regras... meu msn : [email protected]

    Se quiser posso te mandar exemplos....

    Bom Dia...





  5. #5

    Padrão ta adicionado

    ta adicionado........... me ajuda ta fofo!!!!!!!!!!!

  6. #6

    Padrão

    Citação Postado originalmente por vitoria Ver Post
    ...gostaria de saber se pra fazer este outro balanceamento q divide os serviços...
    Você quer que divida apenas os serviços e não a rede, certo? Pois o que citou, está dividindo a rede também.
    Você tem que fazer divisão apenas para os serviços saírem pelo link desejado.
    Ex: Se você tiver um serviço para o grupo de ip de 1 a 60 saindo pelo link 1 e o grupo dois acessasse o mesmo serviço?
    Ou será que você faria a divisão dos mesmo serviços para ambos os grupos?
    Ex: Serviços da porta 23. Grupo 1 sai pelo link 1 e gurpo 2 pelo link dois. Seria isto?



  7. #7

    Padrão

    MR>RG
    eu tenho uma classe de ip q vai do 192.168.0.1 a 192.168.0.250 o ip 192.168.0.254 é o gatewai dos meus clientes eu gostaria q não mudasse isso... so alterace para o link downlods e adsl para abrir paginas de internet... entendeu...lindo!!

  8. #8

    Padrão

    Citação Postado originalmente por vitoria Ver Post
    MR>RG
    eu tenho uma classe de ip q vai do 192.168.0.1 a 192.168.0.250 o ip 192.168.0.254 é o gatewai dos meus clientes eu gostaria q não mudasse isso... so alterace para o link downlods e adsl para abrir paginas de internet... entendeu...lindo!!
    Entendido.



  9. #9

    Padrão

    vc pode me dar uma luz por favor estou perdida..... so algumas dicas!!!!!!!!!!!!!!

  10. #10

    Padrão

    Citação Postado originalmente por vitoria Ver Post
    vc pode me dar uma luz por favor estou perdida..... so algumas dicas!!!!!!!!!!!!!!
    /ip firewall mangle add chain=prerouting src-address=192.168.1.0/24 protocol=tcp dst-port=80 action=mark-routing new-routing-mark=HTTP passthrough=no comment="" disabled=no

    /ip firewall mangle add chain=prerouting src-address=192.168.1.0/24 protocol=tcp dst-port=!80 action=mark-routing new-routing-mark=NOHTTP passthrough=no comment="" disabled=no

    /ip route add gateway=ipadsl routing-mark=HTTP disabled=no

    /ip route add gateway=ipoutro routing-mark=NOHTTP disabled=no

    Qualquer coisa, poste as confs de interface, ip e tals para olharmos.



  11. #11

    Padrão

    Ah, para vê se funcionou, faça um tracert para um site http(80) e outro para https(443).

  12. #12

    Padrão mr. rg lhe agradeço muito

    como vc me pediu vou postar as regras de como esta meu servidor ta lindo!
    aguardo sua resposta

    interfaces
    4 interfaces
    ether 1 clientes
    ether 2 adsl1
    ether 3 link
    ether 4 adsl2
    addresses
    192.168.4.254 gateway clientes
    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade comment="" disabled=no
    add chain=srcnat out-interface=ether2 action=masquerade comment="" disabled=no
    add chain=srcnat out-interface=ether3 action=masquerade comment="" disabled=no
    add chain=srcnat out-interface=ether4 action=masquerade comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=P2P_com passthrough=yes comment="Controle p2p" \
    disabled=no
    add chain=prerouting connection-mark=P2P_com action=mark-packet new-packet-mark=P2P passthrough=yes comment="" disabled=no
    add chain=prerouting src-address=192.168.4.7 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="" \
    disabled=no
    add chain=prerouting src-address=192.168.4.152 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="link2" \
    disabled=no
    add chain=prerouting src-address=192.168.4.153 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="" \
    disabled=no
    add chain=prerouting src-address=192.168.4.197 action=mark-routing new-routing-mark=GrupoC passthrough=no \
    comment="usuarios link 3" disabled=no
    add chain=prerouting src-address=192.168.4.198 action=mark-routing new-routing-mark=GrupoC passthrough=no comment="" \
    disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=201.89.xxx.xxx scope=255 target-scope=10 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=GrupoB comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.253.254 scope=255 target-scope=10 routing-mark=GrupoC comment="" disabled=no



  13. #13

    Padrão

    Olá Vitória,
    Você gostaria de separar os ips ou os serviços?
    Explica melhor aí.

  14. #14

    Padrão

    olha só eu precisava que meus clientes abrissem pagina no adsl e fizessem downloads no link somente isso ...somente separar os links com serviços diferentes
    ficarei aguardando



  15. #15

    Padrão

    Pessoal, o que ela está pedindo não é tão simples, olha só:

    Ela quer que a navegação dos clientes dela seja em um link, e os downloads sejam em outro, MAS QUER MANTER O MESMO GATEWAY para os dois link's e consequentemente para os clientes dela, (?)

    vou tentar simplificar o seu trabalho;

    Que tal fazer a marcação no mangle do que você quer e direcionar para uma interface (link1), só que para isso você tem que criar uma sub-rede em seu MK, onde você terá que determinar em que situação os dados serão entregues a partir de um link, ou de outro.

    pega esse manual em espanhol que postei a muito tempo aqui no forum que nele tem como você fazer o que quer,mas leia com atenção.

    https://under-linux.org/forums/mikrotik/97309-como-prometido-tutorial-mk-no-word.html


    Bom, se serviu um agradecimento basta, sem essa de lindo ou fofo (kkkkkkkkkkkk)
    Última edição por Roberto21; 03-08-2008 às 15:43.

  16. #16

    Padrão

    Citação Postado originalmente por vitoria Ver Post
    como vc me pediu vou postar as regras de como esta meu servidor ta lindo!
    aguardo sua resposta

    interfaces
    4 interfaces
    ether 1 clientes
    ether 2 adsl1
    ether 3 link
    ether 4 adsl2
    addresses
    192.168.4.254 gateway clientes
    / ip firewall nat
    add chain=srcnat out-interface=ether1 action=masquerade comment="" disabled=no (Isso aqui está errado)
    add chain=srcnat out-interface=ether2 action=masquerade comment="" disabled=no
    add chain=srcnat out-interface=ether3 action=masquerade comment="" disabled=no
    add chain=srcnat out-interface=ether4 action=masquerade comment="" disabled=no
    / ip firewall mangle
    add chain=prerouting p2p=all-p2p action=mark-connection new-connection-mark=P2P_com passthrough=yes comment="Controle p2p" \
    disabled=no
    add chain=prerouting connection-mark=P2P_com action=mark-packet new-packet-mark=P2P passthrough=yes comment="" disabled=no
    add chain=prerouting src-address=192.168.4.7 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="" \
    disabled=no
    add chain=prerouting src-address=192.168.4.152 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="link2" \
    disabled=no
    add chain=prerouting src-address=192.168.4.153 action=mark-routing new-routing-mark=GrupoB passthrough=no comment="" \
    disabled=no
    add chain=prerouting src-address=192.168.4.197 action=mark-routing new-routing-mark=GrupoC passthrough=no \
    comment="usuarios link 3" disabled=no
    add chain=prerouting src-address=192.168.4.198 action=mark-routing new-routing-mark=GrupoC passthrough=no comment="" \
    disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=201.89.xxx.xxx scope=255 target-scope=10 comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10 routing-mark=GrupoB comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.253.254 scope=255 target-scope=10 routing-mark=GrupoC comment="" disabled=no


    Essa regra da interface dos clientes está errada.



  17. #17

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Essa regra da interface dos clientes está errada.
    roberto porque esta errada essa regra ?
    tenho que masquerar somente as ether de link
    a dos clientes não ?


    vou analizar aquele tutorial ve se serve para oque eu quero
    muito abrigada roberto
    Última edição por vitoria; 04-08-2008 às 12:01.

  18. #18

    Padrão

    A resposta a você é:

    SRC-NAT permite o redirecionamento dos dados em sua origem a porta de direção local e consequentemente a porta do roteador (emascaramento), ou alguma outra direção de porta específica para o tráfego.

    A aplicação típica do SCR-NAT é esconder uma rede privada atraz de uma ou mais direções publicas, ou seja, seus (link's).

    Então analizando a regra, pra que fazer o NAT de sua interface local ?
    Última edição por Roberto21; 05-08-2008 às 00:28.



  19. #19

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    A resposta a você é:

    SRC-NAT permite o redirecionamento dos dados em sua origem a porta de direção local e consequentemente a porta do roteador (emascaramento), ou alguma outra direção de porta específica para o tráfego.

    A aplicação típica do SCR-NAT é esconder uma rede privada atraz de uma ou mais direções publicas, ou seja, seus (link's).

    Então analizando a regra, pra que fazer o NAT de sua interface local ?

    Nossa não precisava ser tão duro assim comigo. rsrsss

    to brincando entendi obrigada.

    mas a respeito dos links e serviços até agora não consegui nada

  20. #20

    Padrão

    não sei o porque fui inventar de mexer com isso.
    agora meu patrão fica me enlouquecendo com isso.

    ele ve isso funcionando em outros provedores e chega em mim e quer q eu faça o mesmo
    mas infelismente não tenho o mesmo conhecimento que muitos de voces ai da under.

    sou iniciante acho q ja deu pra voces perceberem se der para alguem me ajudar com essa parte
    eu agradeceria muito .
    oque ele quer q eu faça é colocar os cientes para abrir pagina em 1 adsl de 4mb e os downloads em 1 link de 2mb
    ja fritei minha meus neuronios ja não aguento mais ele na minha cabeça .

    sou muito grata até o momento a todos que coloboraram comigo...
    bjsss...