+ Responder ao Tópico



  1. #1

    Padrão alguem ja usou esse balanceamento?

    alguem ja usou esse balanceamento?? axei essas regras para aplicar que fiquei até com medo!!!! poi tenho 1 link dedicado e 1 adsl e queria implantar de madruga, para nao ter problema, q vcx axam , tem 2 modos que axei:::

    BALANCEAMENTO ENTRE 2 LINKS

    / ip firewall mangle
    add chain=prerouting in-interface= Local connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface= Local connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= Local connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= Local connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.15.199 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=192.168.241.73 to-ports=0-65535 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=255 target-scope=10 routing-mark=odd comment="Gateway SttarNet" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.251.254 scope=255 target-scope=10 routing-mark=even comment="Gateway INova" disabled=no

    add dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=255 target-scope=10 comment="principal" disabled=yes

    MODDOOOOO 2 QUE AXEI

    BALANCEAMNETO DE PORTAS

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=255 target-scope=10 \
    routing-mark=link1 comment="Pacotes marcados redirecionados para o link1" \
    disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.251.254 scope=255 target-scope=10 \
    routing-mark=link2 comment="Pacotes marcados redirecionados para o link2" \
    disabled=no

    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="Portas redirecionada para o link2" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=1863 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=6891 action=mark-routing new-routing-mark=link2 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Pacotes marcados do Link2" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link1 passthrough=yes \
    comment="Pacotes marcados do Link1" disabled=no
    add chain=prerouting protocol=tcp dst-port=21 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="Portas redirecionada para o link1" disabled=no
    add chain=prerouting protocol=tcp dst-port=22 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=23 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=25 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=53 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=110 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=1080 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="" disabled=no
    add chain=prerouting protocol=tcp p2p=all-p2p action=mark-routing new-routing-mark=link1 passthrough=yes \
    comment="p2p 1 redirecionado link1" disabled=no


    ESSE segundo axei axo mais legal, pois como tenho 1 link dedicado seria massa garantir algumas coisa para meu link, o que vcx axam , sao simples assim mesmo?? tem algo a mais ou a menos?

  2. #2

    Padrão

    amigo eu ja usei os dois e tive plena certeza q a opçao 2 é a mais estavel q se pode ter, pois o balanceamento por nth da muito problema e é muito instavel, uma hora abre pagina e outra nao abre nada e alem do mais vc tem q fazer redirecionamentos para poder acessar paginas de banco....

    NA MINHA OPNIAO VAI DE OPÇAO DOIS



  3. #3

    Padrão

    NA MINHA OPNIAO VAI DE OPÇAO DOIS[/quote]

    Amigo Schramm tenho um proxy linux em paralelo, com esse tipo de balanceamento funciona normalmente o com o proxy?

  4. #4

    Padrão

    Citação Postado originalmente por simprao Ver Post
    NA MINHA OPNIAO VAI DE OPÇAO DOIS
    Amigo Schramm tenho um proxy linux em paralelo, com esse tipo de balanceamento funciona normalmente o com o proxy?[/quote]

    Tambem gostaria de saber



  5. #5

    Padrão

    funciona sim pois vc usara apenas um link para saida de trafego da porta 80

  6. #6

    Padrão

    Aqui não funcionou, bastou ativar as rotas o proxy-squid parou a navegação, só funciona se desabilitar o proxy-squid.



  7. #7

    Padrão

    Citação Postado originalmente por EdilsonLSouza Ver Post
    Aqui não funcionou, bastou ativar as rotas o proxy-squid parou a navegação, só funciona se desabilitar o proxy-squid.
    Qual divisao correta para 1 link dedicado 2 mb e 2 link adsl de 4mb?? assim digo as portas ali, pensei em deixar somente no link 1 (dedicado) a porta 80 ai o resto divido para os 2 link??? tem algumar porta para o downloads, , ou é tudo feito pela porta 80?

  8. #8

    Padrão

    amigo tem muitas portas para serrem redirecionadas, nao apenas a porta 80(http) temos ainda a porta 443(https) e assim por diante, por isso vc deve fazer um estudo bem abrangente sobre as portas mais comuns e analizar o uso dessas portas em sua rede assim ir aos poucos afinando esse redirecionamento, pelo menos foi assim q fiz aqui em minha rede e estou tendo um resultado muito satisfatorio...

    aqui em minha rede eu usava hotspot, mas percebi q por causa de suas regras dinamicas todos os tipos de balanceamento nao funcionavam de forma estaveis, entao resolvi mudar para pppoe e estou tendo muito mais mobilidade com os redirecionamentos e sempre ficam estaveis, aqui eu fiz varios grupos de usuarios para melhor redirecionar o trafego, cada grupo com um range diferente de ip....

    DEU TRABALHO PRA CARAMBA MAS AGORA JA ESTOU COMEÇANDO A PERCEBER AS MELHORIAS



  9. #9

    Padrão ...

    Desculpe a falta de conhecimento mas uso a versão 2.9.27 e na opção IP/Routes esta assim:


    https://under-linux.org/forums/attac...amento-kjh.jpg
    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.15.254 scope=255 target-scope=10 \
    routing-mark=link1 comment="Pacotes marcados redirecionados para o link1" \
    disabled=no
    Não encontrei as opções marcadas em vermelho...

    Poderiam me dar uma ajuda!!!

    Vlws Galera...
    Última edição por datalinenet; 04-09-2008 às 12:09.

  10. #10

    Padrão

    Citação Postado originalmente por datalinenet Ver Post
    ... scope=...target-scope...routing-mark...
    Esta opções não são visualizadas no winbox nesta versão. Use o new terminal.



  11. #11

    Padrão Grato mais uma vez...

    Citação Postado originalmente por Mr. RG Ver Post
    Esta opções não são visualizadas no winbox nesta versão. Use o new terminal.



    ...e aproveitando o topico, posso deixar um link sendo autenticado pelo MK( sendo discado pelo mk) e outro em modo router? Ou devem estar os dois em router?... Outra coisinha,onde refere-se à Link1 e Link2 são os nomes dados as interfaces dos modens correto?

    Desculpa pedir algo tao simples,mas é que caso aja algum problema akee na implantação desse sistema eu nao fique com essas duviadas ae.

    Mais uma vez muito obrigado!!
    Última edição por datalinenet; 04-09-2008 às 14:56.

  12. #12

    Padrão

    Citação Postado originalmente por datalinenet Ver Post
    ...e aproveitando o topico, posso deixar um link sendo autenticado pelo MK( sendo discado pelo mk) e outro em modo router? Ou devem estar os dois em router?... Outra coisinha,onde refere-se à Link1 e Link2 são os nomes dados as interfaces dos modens correto?

    Desculpa pedir algo tao simples,mas é que caso aja algum problema akee na implantação desse sistema eu nao fique com essas duviadas ae.

    Mais uma vez muito obrigado!!
    Link1 ou Link2 é o nome dado ao marcar um routing em /ip firewall mangle e os dois têm que está em /ip route



  13. #13

    Padrão

    OBS : Se as ADSLs são da mesma operadora, tem que ser uma em bridge e a outra roteada, porque em bridge irão ter o mesmo gateway...

  14. #14

    Padrão

    Citação Postado originalmente por schramm Ver Post
    NA MINHA OPNIAO VAI DE OPÇAO DOIS
    Amigo Schramm, tendo em vista que a porta mais utilizada pelos usuarios e a porta 80, nao corre risco de sobrecaregar o link que aponta para ela?
    aqui eu fiz meu LB diferente, criei dois grupos de clientes e joguei e cada um grupo para sair por um GW. ai fui no olhometro equilibrando a banda com relaçao a usuarios, quem usava mais quem usava menos, deu certo as vezes um Gw trafega mais dados, as vezes o outro. diferença de poucos megas.
    to pensado em mudar pra este LB por portas para ver o desempenho aqui.
    como fica o trafego ai amigo Schramm? o link da porta 80 passa muito mais trafego do que o outro?