+ Responder ao Tópico



  1. Olá pessoal, estou tendo um problema com o samba no ubuntu server 8.04.

    Configurei o samba para compartilhar os arquivos na rede onde todos os computadores utilizam windows XP, porém o acesso e controlado por usuario e senha. O problema e que tem horas que faço logon no windows e ai consigo acessar o compatilhamento no samba, porém outras vezes não consigo. Todos os usuarios estão cadastros e com a senha correta, e as permissões nas pastas também estão ok.

    Meu smb.conf ficou assim

    [global]
    workgroup=Technos
    netbios name=ServerDados
    server string=Dados Technos
    preferred master=yes
    master browser=yes
    os level=100
    security=user
    encrypt passwords=yes
    interfaces=eth0
    hosts allow=192.168.0.
    hosts deny=192.168.1.

    [home]
    comment=Diretorio Home
    public=no
    browseable=no
    available=no

    [claudio]
    comment=Arquivos Claudio
    path=/home/serverdados/claudio
    browseable=yes
    valid users=claudio, james
    writeable=yes
    available=yes

    [james]
    comment=Arquivos James
    path=/home/serverdados/james
    browseable=yes
    valid users=james
    writeable=yes
    available=yes

    [caixa]
    comment=Arquivos Caixa
    path=/home/serverdados/caixa
    browseable=yes
    valid users=caixa, james
    writeable=yes
    available=yes

    [secretaria]
    comment=Arquivos Secretaria
    path=/home/serverdados/secretaria
    browseable=yes
    valid users=secretaria, james, claudio
    writeable=yes
    available=yes

  2. Citação Postado originalmente por cabatista Ver Post
    Olá pessoal, estou tendo um problema com o samba no ubuntu server 8.04.

    Configurei o samba para compartilhar os arquivos na rede onde todos os computadores utilizam windows XP, porém o acesso e controlado por usuario e senha. O problema e que tem horas que faço logon no windows e ai consigo acessar o compatilhamento no samba, porém outras vezes não consigo. Todos os usuarios estão cadastros e com a senha correta, e as permissões nas pastas também estão ok.

    Meu smb.conf ficou assim

    [global]
    workgroup=Technos
    netbios name=ServerDados
    server string=Dados Technos
    preferred master=yes
    master browser=yes
    os level=100
    security=user
    encrypt passwords=yes
    interfaces=eth0
    hosts allow=192.168.0.
    hosts deny=192.168.1.

    [home]
    comment=Diretorio Home
    public=no
    browseable=no
    available=no

    [claudio]
    comment=Arquivos Claudio
    path=/home/serverdados/claudio
    browseable=yes
    valid users=claudio, james
    writeable=yes
    available=yes

    [james]
    comment=Arquivos James
    path=/home/serverdados/james
    browseable=yes
    valid users=james
    writeable=yes
    available=yes

    [caixa]
    comment=Arquivos Caixa
    path=/home/serverdados/caixa
    browseable=yes
    valid users=caixa, james
    writeable=yes
    available=yes

    [secretaria]
    comment=Arquivos Secretaria
    path=/home/serverdados/secretaria
    browseable=yes
    valid users=secretaria, james, claudio
    writeable=yes
    available=yes
    Batista,

    Bom dia. Deixa eu te fazer uma pergunta: cadastrasse os usuários no linux e depois no samba? Pois o samba na tem controle de grupos de usuários, ele utiliza o controle do linux. utilize o comando # adduser [nome do usuário], após ter criado o usuário, crie a senha # passwd [nome do usuário]. depois basta criar o usuários no Samba, lembrando que é obrigatório antes de criar os usuários no Samba ele já exsitir no Linux. para criar no Samba -> # smbpasswd -a [nome do usuário].

    acrescente também as seguintes linhas de comando no teu smb.conf:

    [global]
    workgroup=Technos
    netbios name=ServerDados
    server string=Dados Technos
    preferred master=yes
    master browser=yes # modifique esta opção para domain master = yes
    os level=100
    security=user
    encrypt passwords=yes
    interfaces=eth0 # remova está opção pois com isso estais restringingo o acesse por interface de rede.
    hosts allow=192.168.0.
    hosts deny=192.168.1.
    smb passwd file = /etc/samba/smbpasswd # esse parâmetro informa onde serão geradas as senhas

    [home]
    comment=Diretorio Home
    public=no
    browseable=no
    available=no

    [claudio]
    comment=Arquivos Claudio
    path=/home/serverdados/claudio
    browseable=yes
    valid users=claudio, james
    writeable=yes
    available=yes
    force create mode = 777
    force directory mode = 777

    [james]
    comment=Arquivos James
    path=/home/serverdados/james
    browseable=yes
    valid users=james
    writeable=yes
    available=yes
    force create mode = 777
    force directory mode = 777

    [caixa]
    comment=Arquivos Caixa
    path=/home/serverdados/caixa
    browseable=yes
    valid users=caixa, james
    writeable=yes
    available=yes
    force create mode = 777
    force directory mode = 777

    [secretaria]
    comment=Arquivos Secretaria
    path=/home/serverdados/secretaria
    browseable=yes
    valid users=secretaria, james, claudio
    writeable=yes
    available=yes
    force create mode = 777
    force directory mode = 777


    Acho que isso resolve o teu problema. Qualquer coisa, informe o resultado ok?

    Atenciosamente,



  3. Dantas, os usuarios já estavam criados no linux, e as suas senhas estavam cadastradas como você me aconcelhou.

    Porém o erro continuava acontecendo, mas com as linhas que você me falou para editar realmente resolveu meu problema.

    Valeu pela força.

    Atenciosamente,
    Claudio A. Batista






Tópicos Similares

  1. Problemas com SAMBA no Ubuntu server
    Por edileyoliveira no fórum Sistemas Operacionais
    Respostas: 8
    Último Post: 23-04-2009, 07:12
  2. Problemas com Raid1 no ubuntu server 7.10
    Por Jhoe no fórum Sistemas Operacionais
    Respostas: 2
    Último Post: 25-02-2008, 16:10
  3. Problemas com SAMBA no FEDORA K12
    Por centralservice no fórum Servidores de Rede
    Respostas: 0
    Último Post: 30-11-2005, 13:49
  4. Problema com Samba no Linux Red Hat 3.0 ES
    Por fatesil no fórum Servidores de Rede
    Respostas: 6
    Último Post: 20-05-2005, 15:08
  5. Problema com Samba no Linux Red Hat 3.0 ES
    Por fatesil no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-05-2005, 09:52

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L