Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Mikrotik não envia o ip para o DynDns

    Estou tentando usar script para enviar o ip para o dyndns, no-ip e changeip, mais nenhum desses eu consegui, tentei usar varias scripts encontrado aki no forum mais sem resultado, no log aparece DDNS: Begin, no winbox aparece a mensagem de erro "Missing RouterOS WinBox plugins, uso a versão 2.9.27. O que poderia ser?

  2. #2

    Talking

    Olá amigo vc esta usando adsl acredito certo? Se sim, me diga se vc esta usando ele em modo bridge ou router?
    Abraços!



  3. #3

    Padrão

    Citação Postado originalmente por marcelopontox Ver Post
    Estou tentando usar script para enviar o ip para o dyndns, no-ip e changeip, mais nenhum desses eu consegui, tentei usar varias scripts encontrado aki no forum mais sem resultado, no log aparece DDNS: Begin, no winbox aparece a mensagem de erro "Missing RouterOS WinBox plugins, uso a versão 2.9.27. O que poderia ser?

    Preste atenção quando você copia e cola o script ele cola com um erro, copie e cole o script no bloco de notas, depois procure o erro que você vai encontrar, depois é só fazer manualmente a parte que se corrompe durante o copiar e colar.

    Aqui está o erro, observe que ao colar o teexto do script aqui ele aparece uma carinha no lugar do caractere:

    EXEMPLO ABAIXO
    :log info "DDNS: Begin"

    :global ddns-user "torre"
    :global ddns-pass "suasenha"
    :global ddns-host "torre.ns01.info"
    :global ddns-interface "interface_de_internet"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Última edição por Roberto21; 22-08-2008 às 02:08.

  4. #4

    Padrão

    O moldem está em modo bridge, vou tentar esse script mais acho que eu ja teste ele, mais vou tentar denovo, agradeço desde já a ajuda de todos.



  5. #5

    Padrão

    /tool dns-update name=TESTE.dyndns.org address=127.0.0.255 key-name=ALENCAR2 key=123456


    Aqui eu uso apenas este script e fufa blz blz.

    TESTE.dyndns.org = o nome da minha conta dyndns
    ALENCAR2 = usuario (fictício obvio)
    123456= senha

    --------------------------------------------------

    Para complementar..

    Vá em system / schudler
    e faz um regra com o nome:
    atualiza ip

    start date: jan/01/2008
    start time: 00:00:00
    interval: 00:10:00
    on event: dyndns (no meu caso ela se chama dyndns, porque o script acima também se chama dyndns)

    De ok.
    Assim, a cada 10min ele vai atualizar seu IP.

    Aqui funciona, sem problemas.
    Última edição por alencar2; 22-08-2008 às 10:09.

  6. #6

    Padrão

    amigo, faça esse script q dará certo ok!

    :log info "DDNS: Begin"
    :global ddns-user "nome do seu usuário no change ip"
    :global ddns-pass "senha do seu usuário no change ip"
    :global ddns-host "seu endereço no changeip"
    :global ddns-interface "pppoe-out1"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] keyname=$
    ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"

    bbs: onde tem ddns vc coloca seu nome do redirecionamento
    Última edição por multlink; 22-08-2008 às 11:10.