+ Responder ao Tópico



  1. Bom dia Pessoal;

    É o seguinte estou tendo problemas na geraçao de relatorios com o sarg, eu fiz um script com o seguintes dados, o nome do script é sarg.sh

    _____________________________________
    #!/bin/bash

    sarg
    _____________________________________

    Ja dei um chmod 777 sarg.sh e chmod +x sarg.sh tambem.

    Adicionei no /etc/crontab a seguinte linha:

    55 23 * * * root /etc/squid/scripts/sarg.sh

    O problema é que tem dia que ele gera normalmente, e tem dia que nao, como aconteceu esses dias ele gerou o relatorio dia 15/08, 16/08, 18/08, 19/08 , 20/08, 21/08, 23/08 , 24/08 ,25/08.
    Ou seja ele nao gerou o relatoria dia 17, 22 e dia 26 eu nao entendo o que esta acontecendo isso ta me dando uma dor de cabeça danada aqui no serviço.

    Ai esta meu sarg.conf
    ___________________________________________________________________________________________________
    language Portuguese

    access_log /var/log/squid/access.log

    title "Relatorios de Acessos Sarg"

    font_face Arial
    header_color darkblue
    header_bgcolor blanchedalmond
    header_font_size -1
    background_color white
    text_color black
    text_bgcolor beige
    title_color green

    temporary_dir /tmp

    output_dir /Sarg_Logs

    topuser_sort_field BYTES reverse

    user_sort_field BYTES reverse

    exclude_users /etc/squid/exclude.users

    exclude_hosts /etc/squid/exclude.hosts

    date_format e

    lastlog 0

    remove_temp_files yes

    index yes

    overwrite_report yes

    records_without_userid ip

    use_comma no

    top_sites 100

    topsites_sort_order BYTES D

    exclude_codes /etc/squid/sarg.exclude_codes

    max_elapsed 28800000

    report_typie topsites users_sites sites_users date_time auth_failures site_user_time_date denied

    long_url no

    exclude_string /etc/squid/exclude.strings

    show_sucessful_message no

    topuser_fields NUM DATE_TIME USERID CONNECT BYTES %BYTES IN-CACHE-OUT USED_TIME MILISEC %TIME TOTAL AVERAGE

    topuser_num 0



    _________________________________________________________________________________________________

    Desde ja agradeço a todos;

  2. Cara, dá uma olhada nesse tópico. Talvez te ajude...
    https://under-linux.org/forums/proxy...quid-sarg.html



  3. Valeu cara, creio que o problema seja esse ai mesmo, to dando uma lida e tentando entender qual é a soluçao.To meio confuso sobre esse logrotate.No meu caso o logrotate.conf esta assim:

    _______________________________________________________________________________
    # see "man logrotate" for details
    # rotate log files weekly
    weekly

    # keep 4 weeks worth of backlogs
    rotate 4

    # create new (empty) log files after rotating old ones
    create

    # uncomment this if you want your log files compressed
    #compress

    # packages drop log rotation information into this directory
    include /etc/logrotate.d

    # no packages own wtmp, or btmp -- we'll rotate them here
    /var/log/wtmp {
    missingok
    monthly
    create 0664 root utmp
    rotate 1
    }

    /var/log/btmp {
    missingok
    monthly
    create 0664 root utmp
    rotate 1
    }

    # system-specific logs may be configured here

    _________________________________________________________________________________________


    e o squid dentro de logrotate.d esta assim


    _________________________________________________________________________________________
    #
    # Logrotate fragment for squid.
    #
    /var/log/squid/*.log {
    daily
    compress
    delaycompress
    rotate 2
    missingok
    nocreate
    sharedscripts
    prerotate
    test ! -x /usr/sbin/sarg-maint || /usr/sbin/sarg-maint
    endscript
    postrotate
    test ! -e /var/run/squid.pid || /usr/sbin/squid -k rotate
    endscript
    }


    ________________________________________________________________________________________
    Nao estou conseguindo entender a logica desse logrotate no que se diz respeito a daily weekly.To meio confuso de como resolver, vou tentar da mais uma pesquisada por ai..Se alguem souber de mais alguma coisa responde ai por favor.

    Desde ja agradeço;






Tópicos Similares

  1. problema com o sarg
    Por Mr_Mind no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-02-2005, 12:59
  2. problemas com o sarg!!!
    Por r3nat0 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 16-09-2004, 13:19
  3. Problema com o SARG - Muito estranho
    Por Antelo no fórum Servidores de Rede
    Respostas: 5
    Último Post: 13-09-2004, 12:59
  4. Por favor, da um help ai :D problema com o sarg
    Por Rafael Cristian no fórum Servidores de Rede
    Respostas: 3
    Último Post: 13-09-2004, 12:31
  5. Problemas com o sarg no Slackware 10
    Por Rafael Cristian no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-08-2004, 16:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L