Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Monitor de rede - alerta SMS

    Bom pessoal, estou mais uma vez para trazer um poste no qual pretendo ajudá-los a identificar locais em sua rede que estão com problema de conexão.

    O que vou apresentar:
    Supomos que você tenha uma transmissão de sinal entre as cidades A, B e C. E que nestas cidades há mais de 3 rádios aps ou mikrotiks. Por algum motivo um desses rádios páram. É aí onde entra o que vou apresentar.


    Requisitos:
    Modem GSM
    Mikrotik com porta serial ou usb
    ☼ Conexão com a Internet

    No exemplo:
    Cidade A - 192.168.1.1/24 - Mikrotik A
    Cidade B - 192.168.2.1/24 - Mikrotik B
    Cidade C - 192.168.3.1/24 - Mikrotik C

    Passo 1 - Configurar rede
    É toda a configuração da rede, ou seja, todas as cidades já estão se comunicando. Isto será por conta de todos.

    Passo 2 - Conectar o modem
    Aqui você irá conectar o modem GSM numa das portas do mikrotik (serial ou usb).

    Passo 3 - Configurar o mikrotik
    No mikrotik temos o netwatch que fará a função de cão-farejador.
    Submenu: /tool netwatch


    Para ficar melhor:

    Supomos que o servidor da cidade B, que é fornecida pela cidade A, parou de enviar. Como o netwatch detectou um erro na resposta, logo enviará uma mensagem para o seu celular, a configuração ficará da seguinte forma:

    /tool netwatch add host=192.168.2.1 interval=10s timeout=150 \
    up-script=”tool sms send serial0 "9909890908" message="O servidor da cidade B voltou a responder. Tudo normal" \
    down-script=/tool sms send serial0 "9909890908" message="O servidor da cidade B acabou de cair" \


    Explicação:
    up-script - será executado quando o servidor voltar a responder
    down-script - será executado quando o servidor cair

    Daí por diante é só você fazerem como desejar. Um coisa seria deixar o up-script em branco, pois a cada intervalo você irá receber a msg de up-script.

    Bem pessoal, é isto aí.

  2. #2

    Padrão

    vou esperar os amigos falarem algo sobre os testes



  3. #3

    Padrão

    Onde consigo comprar esse modem GSM??

    Tem algum modelo específico pra funcionar junto ao MK?? Ele reconhece qualquer marca ??

    Qual marca/modelo você usou ???

    Ja testou se funciona um daqueles modens GSM pcmcia dae é só colocar um adaptador pra pci e ligar !!

    Somente encontrei USB e PCMCIA....

    Abraço !!
    Última edição por olivionet; 09-09-2008 às 19:02.

  4. #4

    Padrão

    Faço das perguntas do Olivionet as minhas...



  5. #5

    Padrão

    Dá pra fazer isso no ubuntu ou somente em mikrotik?

  6. #6

    Padrão

    Citação Postado originalmente por portalink Ver Post
    Faço das perguntas do Olivionet as minhas...
    Citação Postado originalmente por olivionet Ver Post
    Onde consigo comprar esse modem GSM??

    Tem algum modelo específico pra funcionar junto ao MK?? Ele reconhece qualquer marca ??

    Qual marca/modelo você usou ???

    Ja testou se funciona um daqueles modens GSM pcmcia dae é só colocar um adaptador pra pci e ligar !!

    Somente encontrei USB e PCMCIA....

    Abraço !!
    O requerimento é que seje um modem GSM, não importando modelo/marca* e tem que ser junto ao mikrotik.
    Para comprar: MercadoLivre: MODEM GSM GPRS EDGE USB - INTERNET RURAL - R$ 350.00
    Especificação: http://www.daruma.com.br/pdfs_catgs/..._Modem_GSM.pdf



  7. #7

    Padrão

    Citação Postado originalmente por netosdr Ver Post
    Dá pra fazer isso no ubuntu ou somente em mikrotik?
    Foi feito sobre o mikrotik, mas você pode tentar fazer no ubunut.

  8. #8

    Padrão

    o Mikrotik adicionou suporte a modem usb conforme no proprio site

    What's new in 3.6:

    *) fixed booting for x86;
    *) initial support for MPLS Traffic Engineering tunnels;
    *) added support for ZTE AC8700 USB modem; >>>>>>>>> esse e o modem, so que nao consegui achar, se os colegas conseguirem achar e se tive algum outro com suporte a tecnologica 3G seria melhor ainda!

    valew T+



  9. #9

    Padrão Harware

    Listado de hard suportado por mikrotk e muitos cartoes 3g Supported Hardware - MikroTik Wiki

  10. #10

    Padrão

    Olá amigo muito boa essas configurações.......mais e ai? Quais os modelos, marcas, operadoras.......

    Estamos no aguardo. Vlw?



  11. #11

    Padrão

    Não há espeficação de modelo/marca.

  12. #12

    Padrão

    boa ideia mesmo, isso facilitaria e muito a vida nossa, já penso parou e ir direto pra la já sem se preocupar onde foi.



  13. #13

    Padrão

    Mr. RG nao teria como fazer isso sem utilizar um modem GSM?

    Vi em um topico do BFW que ele utiliza algo semelhante só que mandava para o email, hoje em dia existem sites e programas que enviam sms gratuito, talvez até daria para desenvolver um programa que substituiria o modem...

  14. #14

    Padrão

    Citação Postado originalmente por arson Ver Post
    Mr. RG nao teria como fazer isso sem utilizar um modem GSM?

    Vi em um topico do BFW que ele utiliza algo semelhante só que mandava para o email, hoje em dia existem sites e programas que enviam sms gratuito, talvez até daria para desenvolver um programa que substituiria o modem...

    Operadoras como claro, vivo e tim disponibilizam um serviço para o cliente que quando se envia um email para [email protected] por exemplo, chega um torpedo SMS no celular com o conteudo do e-mail.. talvez seja o que vc precise...



  15. #15

    Padrão

    Entao acho que isso funcionaria, pelo menos no bfw existe a opcao mail to será que o MK teria algo semelhante ou até mesmo esse o script do bfw funcione no MK....

    Se funcionar poderia ficar assim o script

    /tool netwatch add host=192.168.2.1 interval=10s timeout=150 \
    up-script=”mail to
    [email protected]" message="O servidor da cidade B voltou a responder. Tudo normal" \
    down-script=”mail to
    [email protected]" message="O servidor da cidade B acabou de cair" \

    ou no caso o email que o amigo citou acima...

    E ai MR. será que isso funciona??

  16. #16

    Padrão

    eu posso estar errado, mais se o pop parar como ele iria mandar email.
    por isso iria precisar de outro sistema paralelo, tipo o gsm



  17. #17

    Padrão

    No caso isso vai funcionar com mais de um MK

    Ex. temos dois MK o A e o B

    O B fica verificando se o A está mandando sinal e vice versa...

    Se um deles nao receber mais o sinal do outro ele enviara um aviso, dizendo que o outro parou de funcionar...isso ajudará e muito....

  18. #18

    Padrão

    Citação Postado originalmente por arson Ver Post
    Entao acho que isso funcionaria, pelo menos no bfw existe a opcao mail to será que o MK teria algo semelhante ou até mesmo esse o script do bfw funcione no MK....

    Se funcionar poderia ficar assim o script

    /tool netwatch add host=192.168.2.1 interval=10s timeout=150 \
    up-script=”mail to
    [email protected]" message="O servidor da cidade B voltou a responder. Tudo normal" \
    down-script=”mail to
    [email protected]" message="O servidor da cidade B acabou de cair" \

    ou no caso o email que o amigo citou acima...

    E ai MR. será que isso funciona??
    Neste caso ficaria assim:

    /system script add name=link_down policy=ftp,read,telnet,web,write,reboot,ssh,test,winbox,local source="/tool e-mail send [email protected] subject=Aviso body="O link da cidade B caiu""


    /system script add name=link_up policy=ftp,read,telnet,web,write,reboot,ssh,test,winbox,local source="/tool e-mail send [email protected] subject=Aviso body="O link da cidade B voltou""

    /tool netwatch add host=192.168.2.1 interval=10s timeout=150 down-script=link_down up-script=link_up

    Mas o aconselhável é usar o modem gsm, pois o geral pode cair e não terá como enviar o aviso.



  19. #19

    Padrão

    MR mais se o MK cair mesmo com o modem nao funcionará...

    Esse esquema nao seria mais em caso de pane no proprio MK e nao no sinal da internet correto?

    Normalmente os problema acontecem no proprio MK correto?

    Depois que eu implantar o segundo MK aqui usarei esse script...parabens MR.

  20. #20

    Padrão

    Keep it simple.
    Nagios.

    Regards,