Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão tela inicial hotspot

    ola pessoal, estou com uma duvida na tela de autenticação do hotspot, eu editei o codigo fonte e fiz algumas alterações testo e esta tudo ok, mas quando coloco no mikrotik e tento logar, abre primeiro a padrao do mikrotik ai digito a login e senha.. quando teclo enter cai na minha tela de altenticaçao que criei. Meus passos sao os seguintes:

    winbox ----> file -------> copiei o arquivo (alogin.html) modifiquei ele,
    apaguei o original e colei o meu no mesmo lugar.

    não seria só isso? porque sera que aparece a original e quando logo aparece a minha pra se logar nela?

    desde ja agradeço a todos,

  2. #2

    Padrão

    Desabilite o servidor mikrotik, e conecte por um cliente ftp e altere os arquivos da pasta hotspot.
    Dá uma olhada nisto aqui:
    Linux: Configurando servidor MikroTik com Hotspot e páginas de aviso (atraso e bloqueio) [Artigo]



  3. #3

    Padrão

    Citação Postado originalmente por ddllss Ver Post
    ola pessoal, estou com uma duvida na tela de autenticação do hotspot, eu editei o codigo fonte e fiz algumas alterações testo e esta tudo ok, mas quando coloco no mikrotik e tento logar, abre primeiro a padrao do mikrotik ai digito a login e senha.. quando teclo enter cai na minha tela de altenticaçao que criei. Meus passos sao os seguintes:

    winbox ----> file -------> copiei o arquivo (alogin.html) modifiquei ele,
    apaguei o original e colei o meu no mesmo lugar.

    não seria só isso? porque sera que aparece a original e quando logo aparece a minha pra se logar nela?

    desde ja agradeço a todos,

    Amigo, o arquivo "alogin.html" é chamado quando o cliente loga no Hotspot. O arquivo responsável pela página de autenticação é o "login.html". Modifique este arquivo e mantenha todas as strings originais (caso você mude-as poderá ter problemas).

  4. #4

    Padrão

    Você também pode setar o cookie para que fique armazenado os dados por 24hs, assim o cliente só precisaria fazer a autenticação uma vez ao dia. Ou mesmo pode setar outro valores e configurar o IP Binding.



  5. #5
    deniss
    Visitante

    Padrão

    vc so deve editar o arquiivo (login) q ele é q tema essa funcao
    ok




    valeu

  6. #6
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Amigo, o arquivo "alogin.html" é chamado quando o cliente loga no Hotspot. O arquivo responsável pela página de autenticação é o "login.html". Modifique este arquivo e mantenha todas as strings originais (caso você mude-as poderá ter problemas).
    valeu amigo obrigado, vou testar aki



  7. #7
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    Você também pode setar o cookie para que fique armazenado os dados por 24hs, assim o cliente só precisaria fazer a autenticação uma vez ao dia. Ou mesmo pode setar outro valores e configurar o IP Binding.
    ohh! cara essa é uma boa ideia mas como faço isso??
    desde ja agradeço a atençao, abraços!

  8. #8

    Padrão Ajuda

    Bom Galera Sou Iniciante Nessa Area Gostaria de Ajuda! Quero Cria Um Tela De Longin Em Html Como Vi Em Ums Post Aqui Mesmo Alguem Poderia FAzer Isso Pra Mim...Ou Em Flash

    Pago Pelo Serviço !


    Muito Obrigada ... Anaelson*



  9. #9

    Padrão

    Citação Postado originalmente por aecioteco Ver Post
    Bom Galera Sou Iniciante Nessa Area Gostaria de Ajuda! Quero Cria Um Tela De Longin Em Html Como Vi Em Ums Post Aqui Mesmo Alguem Poderia FAzer Isso Pra Mim...Ou Em Flash

    Pago Pelo Serviço !


    Muito Obrigada ... Anaelson*
    Hotspot em flash
    https://under-linux.org/forums/mikro...-em-flash.html

  10. #10

    Padrão

    isso mesmo cara tem um topico aqui mesmo mostrando em pagina de long em html muito bacana gostaria de saber como fazer isso na minha ou se alguem fazer ?



  11. #11

    Padrão

    se vc quizer tenho uma pronta aqui ....

  12. #12

    Padrão informativo na pagina de redirecionamento??

    Boa noite a todos! quero aproveitar o post do amigo p postar uma duvida,
    creio que pode ser útil aos outros tambem, adicionei um Informativo na tela de redirecionamento (aloguin do hotspot) e alterei a tag:
    meta http-equiv="refresh" content="3;URL= url=../../hotspot/$(link-redirect)">
    para
    meta http-equiv="refresh" content="59;URL= url=../../hotspot/$(link-redirect)">
    em teoria deveria esperar os "59" segundos e depois redirecionar,e é o que acontece quando faço o teste no navegador mas quando envio para o servidor, imediatamente que encontra a pagina ele já redireciona sem esperar e ai nao dá pra ler o informativo... o que eu estaria fazendo errado ??
    Última edição por egservice; 03-12-2008 às 20:08. Razão: complemento



  13. #13

    Padrão

    Citação Postado originalmente por egservice Ver Post
    Boa noite a todos! quero aproveitar o post do amigo p postar uma duvida,
    creio que pode ser útil aos outros tambem, adicionei um Informativo na tela de redirecionamento (aloguin do hotspot) e alterei a tag:
    meta http-equiv="refresh" content="3;URL= url=../../hotspot/$(link-redirect)">
    para
    meta http-equiv="refresh" content="59;URL= url=../../hotspot/$(link-redirect)">
    em teoria deveria esperar os "59" segundos e depois redirecionar,e é o que acontece quando faço o teste no navegador mas quando envio para o servidor, imediatamente que encontra a pagina ele já redireciona sem esperar e ai nao dá pra ler o informativo... o que eu estaria fazendo errado ??
    O que voce esta fazendo eh nao colocar o advertise timeout com 59 segundos na configuracao do profile do hotspot.

  14. #14

    Padrão

    Citação Postado originalmente por Mr. RG Ver Post
    O que voce esta fazendo eh nao colocar o advertise timeout com 59 segundos na configuracao do profile do hotspot.
    Olá Mr. RG, na verdade nao estou usando advertise, apenas adicionei um informativo na pagina que redireciona o cliente(aquela: aguarde, redirecionando se nada acontecer...) e alterei a meta tag refresh, o que em teoria deveria atualizar a pagina apenas no tempo atribuído mas assim que encontra a pagina-destino ele já direciona e nao dá pra ler o aviso...
    essa tá meio cabulosa!! vamos ver no que vai dar ne.. valeu.



  15. #15
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por egservice Ver Post
    Olá Mr. RG, na verdade nao estou usando advertise, apenas adicionei um informativo na pagina que redireciona o cliente(aquela: aguarde, redirecionando se nada acontecer...) e alterei a meta tag refresh, o que em teoria deveria atualizar a pagina apenas no tempo atribuído mas assim que encontra a pagina-destino ele já direciona e nao dá pra ler o aviso...
    essa tá meio cabulosa!! vamos ver no que vai dar ne.. valeu.

    to tentando a mesma coisa amigo.. ja fiz de tudo e nao vai.. fora do hotspot o tempo
    funciona legal.. mas quando joga no hotspot ele nao obedece o tempo..

  16. #16

    Padrão

    Dá uma observada nela para vê se não há uma outra regra. Ou mesmo crie uma individual substituindo esta aí.



  17. #17

    Padrão

    Citação Postado originalmente por egservice Ver Post
    Boa noite a todos! quero aproveitar o post do amigo p postar uma duvida,
    creio que pode ser útil aos outros tambem, adicionei um Informativo na tela de redirecionamento (aloguin do hotspot) e alterei a tag:
    meta http-equiv="refresh" content="3;URL= url=../../hotspot/$(link-redirect)">
    para
    meta http-equiv="refresh" content="59;URL= url=../../hotspot/$(link-redirect)">
    em teoria deveria esperar os "59" segundos e depois redirecionar,e é o que acontece quando faço o teste no navegador mas quando envio para o servidor, imediatamente que encontra a pagina ele já redireciona sem esperar e ai nao dá pra ler o informativo... o que eu estaria fazendo errado ??
    O problema ta no espaço que vc sumiu logo depois do ;


    <meta http-equiv="refresh" content="5; url=$(link-redirect)">

  18. #18

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    O problema ta no espaço que vc sumiu logo depois do ;


    <meta http-equiv="refresh" content="5; url=$(link-redirect)">

    cara fiquei até animado... mas ainda nao deu... coloquei o espaço lá mas n deu certo não... de qualquer maneira valeu, o que mais poderia ser?



  19. #19

    Padrão

    Citação Postado originalmente por egservice Ver Post
    meta http-equiv="refresh" content="3;URL= url=../../hotspot/$(link-redirect)">


    cara fiquei até animado... mas ainda nao deu... coloquei o espaço lá mas n deu certo não... de qualquer maneira valeu, o que mais poderia ser?
    <meta http-equiv="refresh" content="2; url=$(link-redirect)">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <meta http-equiv="pragma" content="no-cache">
    <meta http-equiv="expires" content="-1">
    Alterar daqui pra baixo


    * Você pode alterar toda pagina com qualquer propaganda, mas não deve mexer nos comandos meta, apenas o content"X"; pois eles comandam todo processo do redirecionar base do mikrotik.
    Última edição por cesarpsa; 04-12-2008 às 17:00.

  20. #20

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    <meta http-equiv="refresh" content="2; url=$(link-redirect)">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <meta http-equiv="pragma" content="no-cache">
    <meta http-equiv="expires" content="-1">
    Alterar daqui pra baixo


    * Você pode alterar toda pagina com qualquer propaganda, mas não deve mexer nos comandos meta, apenas o content"X"; pois eles comandam todo processo do redirecionar base do mikrotik.

    Exatamente, é somente isso o que preciso! dar um "retardo" na pagina aumentando o valor de content mas a bendita redireciona imediatamente e nao tem nada que faça ela esperar !!!
    mas vamos lá acho que logo descobrimos a solução! pelo nível do pessoal aqui!