+ Responder ao Tópico



  1. #1

    Padrão Debian + W2k Professional no mesmo hd

    Olá

    Tenho um hd com Debian e também Windows 2000 Professional, eu não consigo inicializar ele certo, está na IDE0 sendo que assim que é carregado ele só mostra uma linha escrita GRUB e mais nada.

    Com um livecd do ubuntu eu inicializei a maquina, aí vi as partições e aparentemente está tudo ok. No devices.map e ta certinho com a linha:

    (hd0) /dev/hda

    E no arquivo de config. do grub ... menu.lst está assim ...

    title Debian GNU/Linux, kernel 2.6.8-2-686
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.8-2-686 root=/dev/hda3 ro
    initrd /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    title Debian GNU/Linux, kernel 2.6.8-2-686 (recovery mode)
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.8-2-686 root=/dev/hda3 ro single
    initrd /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root

    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1

    title Microsoft Windows 2000 Professional
    root (hd0,0)
    savedefault
    makeactive
    chainloader +1

    Aparentemente tudo certo né, só que quando ligo a máquina só aparece uma tela escrito GRUB e nada acontece.

    Alguma dica? Nesse caso eu necessito mais do Ruindows do que Linux, formatar a MBR adiantaria?

  2. #2

    Padrão

    Citação Postado originalmente por adritec Ver Post
    Olá

    Tenho um hd com Debian e também Windows 2000 Professional, eu não consigo inicializar ele certo, está na IDE0 sendo que assim que é carregado ele só mostra uma linha escrita GRUB e mais nada.

    Com um livecd do ubuntu eu inicializei a maquina, aí vi as partições e aparentemente está tudo ok. No devices.map e ta certinho com a linha:

    (hd0) /dev/hda

    E no arquivo de config. do grub ... menu.lst está assim ...

    title Debian GNU/Linux, kernel 2.6.8-2-686
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.8-2-686 root=/dev/hda3 ro
    initrd /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    title Debian GNU/Linux, kernel 2.6.8-2-686 (recovery mode)
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.8-2-686 root=/dev/hda3 ro single
    initrd /boot/initrd.img-2.6.8-2-686
    savedefault
    boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST

    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title Other operating systems:
    root

    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1

    title Microsoft Windows 2000 Professional
    root (hd0,0)
    savedefault
    makeactive
    chainloader +1

    Aparentemente tudo certo né, só que quando ligo a máquina só aparece uma tela escrito GRUB e nada acontece.

    Alguma dica? Nesse caso eu necessito mais do Ruindows do que Linux, formatar a MBR adiantaria?

    Dá um boot com o live CD e reinstala o grub:

    #mount /dev/hda0 /mnt
    #chroot /mnt
    #grub-install /dev/hda



  3. #3

    Padrão

    Magnun,

    Aí que ta tentei de várias formas já (Grub - Ubuntu Brasil) só que ele nem chega a montar, ao executar:

    sudo mount /dev/hda0 /mnt

    Ele já retorna mensagem:

    mount: special device /dev/hda0 does not exist

    Só que ele existe sim tanto que postei como está no devices.map e também no menu.lst, sendo que na bios reconhece o HD na IDE0 como master

    Também consigo visualizar todas as partições quando acesso com live cd (ubuntu).

    Alguma outra dica?

  4. #4

    Padrão

    Magnun,

    O que consegui fazer foi:

    sudo grub

    find /boot/grub/stage1

    root (hd0, 2)

    setup (hd0)

    Aí antes aparecia uma tela preta escrito somente GRUB, agora nada aparece mas também não inicializa nem Linux nem Windows 2000.



  5. #5

    Padrão

    é.. está faltando um estudo aí.

    "hda0" só existe para a configuração do grub, para ponto de montagem é "hda1"