+ Responder ao Tópico



  1. Olá amigos!

    Baixei um template para meu site, mas ao rodá-lo surge somente a seguinte mensagem na tela:

    Parse error: syntax error, unexpected $end in C:\wamp\www\joomla\templates\siteground102\index.php on line 84

    Como não entendo bulhufas de PHP, resolvi pedir a ajuda de vocêspara tentar encontrar onde pode estar o erro. Segue o código do arquivo index.php em questão: (coloquei também os números correspondentes às linhas para auxiliar)

    1 <?php
    2 defined( '_VALID_MOS' ) or die( 'Direct Access to this location is not allowed.' );
    3 // needed to seperate the ISO number from the language file constant _ISO
    4 $iso = split( '=', _ISO );
    5 // xml prolog
    6 echo '<?xml version="1.0" encoding="'. $iso[1] .'"?' .'>';
    7 ?>
    8 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    9 <html xmlns="http://www.w3.org/1999/xhtml">
    10 <head>
    11 <?php
    12 if ( $my->id ) {
    13 initEditor();
    14 }
    15 ?>
    16 <?php mosShowHead(); ?>
    17 <meta http-equiv="Content-Type" content="text/html; <?php echo _ISO; ?>" />
    18 <?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/template_css.css\" type=\"text/css\"/>" ; ?>
    19 <!--[if lte IE 6]>
    20 <?php echo "<link rel=\"stylesheet\" href=\"$GLOBALS[mosConfig_live_site]/templates/$GLOBALS[cur_template]/css/ie6.css\" type=\"text/css\"/>" ; ?>
    21 <![endif]-->
    22
    23 <link rel="alternate" type="application/rss+xml" title="<?php echo $mosConfig_sitename?>" href="<?php echo $mosConfig_live_site;?>/index.php?option=com_rss&feed=RSS2.0&no_html=1" />
    24 </head>
    25
    26 <body class="body_bg">
    27 <div class="bg">
    28 <div id="wrapper">
    29 <div id="header_3">
    30 <div id="header_2">
    31 <div id="header_1">
    32 <div id="header">
    33 <div id="logo">
    34 <h1><?php echo $GLOBALS['mosConfig_sitename']?></h1>
    35 </div>
    36 </div>
    37
    38 </div>
    39 </div>
    40 </div>
    41 <div id="top_menu">
    42 <?php include'menu.php'; ?>
    43 <div class="clr"></div>
    44 </div>
    45 <div class="content_b">
    46 <div id="content">
    47 <div id="leftcolumn">
    48 <?php mosLoadModules('left' , '-3'); ?>
    49 <? $sg = 'banner'; include "templates.php"; ?>
    50 <div class="clr"></div>
    51 </div>
    52 <?php if (mosCountModules('right')){ ?>
    53 <div id="main">
    54 <? } else { ?>
    55
    56 <div id="main_full">
    57 <? } ?>
    58 <?php mosMainBody(); ?>
    59 </div>
    60 <?php if (mosCountModules('right')){ ?>
    61 <div id="search">
    62 <?php mosLoadModules('user4'); ?>
    63 <div class="clr"></div>
    64 </div>
    65 <div id="rightcolumn">
    66 <?php mosLoadModules('right' , '-3'); ?>
    67 </div>
    68 <? } ?>
    69 <div class="clr"></div>
    70 </div>
    71 </div>
    72 <div class="clr"></div>
    73 </div>
    74 <div id="footer">
    75 <p class="copyright"><? $sg = ''; include "templates.php"; ?></p>
    76 </div>
    77
    78 </div>
    79 </div>
    80
    81
    82 </body>
    83 </html>

  2. Começo a desconfiar que pode ser configuração do PHP. Eu fiz o upload, só para teste, para o servidor web que está com site no ar. O template funcionou direitinho. Não pode ser erro no código.

    Alguém sabe qual configuração ou módulo do PHP poderia causar esse erro?

    Obrigado pela ajuda!!!!



  3. e onde apareçe esse erro?
    na shell?

  4. Na verdade aparecia no próprio navegador.
    Mas eu troquei o servidor e funcionou.
    Estava usando o WAMP e troquei pro Easy-PHP e deu certo.
    Como é somente para testes, não faz diferença isso.
    Mesmo assim, muito obrigado por querer ajudar.






Tópicos Similares

  1. Squid error
    Por Casp no fórum Servidores de Rede
    Respostas: 9
    Último Post: 27-12-2003, 08:33
  2. read_data: read failure for 4. Error = No route to host
    Por cantisan no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-02-2003, 13:00
  3. rc.squid: Line 54: syyntax error near unexécted token `*)´
    Por rafaelpazcolles no fórum Servidores de Rede
    Respostas: 1
    Último Post: 19-01-2003, 17:45
  4. Error Interbase 6 RH 8
    Por PedroNasc no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-12-2002, 12:18
  5. Uvscan error antivirus
    Por marcfee no fórum Servidores de Rede
    Respostas: 8
    Último Post: 18-12-2002, 16:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L