+ Responder ao Tópico



  1. Pessoal ontem desenvolvi um simples sistema de backup das minhas torres, na nescessidade de automatização do download dos arquivos de *.backup gerado pelo mikrotik, desenvolvi esse SCRIPT.

    No meu caso Usarei o Ubuntu Server 7

    Com o SAMBA e nada mais.

    No Mikrotik criaremos:

    - Criando o grupo
    Código :
    / user group 
    add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!tes\
        t,!winbox,!password,!web,!sniff
    - Criando o User
    Código :
    / user 
    add name="ftp" group=ftp address=0.0.0.0/0 comment="" disabled=no
    - Criar uma senha no user "FTP".

    - Criando o Script de Backup
    Código :
    /system script
    add name=backup policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/system backup save"


    - Automatizado o script.
    Código :
    /system scheduler
    add comment="" disabled=no interval=5d name=backup on-event=backup start-date=oct/20/2008 start-time=16:00:00
    NESTE PASSO VC PODE ALTERAR O INTERVALO DO BACKUP.

    Aparti de agora, o mikrotik gerar o backup automaticamente.

    Vamos agora gerar criar o script no Linux.

    - Vamos Criar os diretorios, observação criar 1 diretorio para cada torre e logo na frete modifica no script.
    Código :
    1 - apt-get install samba
    2 - mkdir /backup
    3 - mkdir /backup/Server
    4 - mkdir /backup/Alcides
    5 - chmod 777 /backup *
    - Vamos Criar o Script
    Código :
    1 - cd /backup
    2 - nano ftp
    Código :
    #!/bin/bash
    # SCRIPT PARA DOWNLOAD DOS BACKUPS
     
    # ZERA TODAS A VARIAVES E ARQUIVOS
    FTP_HOST=0
    FTP_USER=0
    FTP_PASS=0
    PASTAFILES=0
     
    ############################### CONFIGURAÇÕES GERAIS ###########################################
     
    ###### SERVER
     
    ARQUIVO="*.backup"                                         # Extenssão
    FTP_HOST="180.0.0.254"                                     # IP DO MIKROTIK
    FTP_USER="ftp"                                             # USUARIO DO FTP  DO MIKROTIK
    FTP_PASS="SENHA DO USER FTP AQUI"                          # SENHA DO FTP DO MIKROTIK
    PASTAFILES="/backup/Server"                                # PASTA DE ARMAZENAMENTO LOCAL
    cd $PASTAFILES
     
    # ROTINA FTP DE DOWNLOAD DOs ARQUIVOS
    cd $PASTAFILES
    ftp -in <<EOF
    open $FTP_HOST
    user $FTP_USER $FTP_PASS
    mget $ARQUIVO
    bye
    EOF
     
    ###### Alcides
     
    ARQUIVO="*.backup"                                         # Extenssão
    FTP_HOST="180.0.0.193"                                     # IP DO MIKROTIK
    FTP_USER="ftp"                                             # USUARIO DO FTP  DO MIKROTIK
    FTP_PASS="SENHA DO USER FTP AQUI"                          # SENHA DO FTP DO MIKROTIK
    PASTAFILES="/backup/Alcides"                               # PASTA DE ARMAZENAMENTO LOCAL
    cd $PASTAFILES
     
    # ROTINA FTP DE DOWNLOAD DOs ARQUIVOS
    cd $PASTAFILES
    ftp -in <<EOF
    open $FTP_HOST
    user $FTP_USER $FTP_PASS
    mget $ARQUIVO
    bye
    EOF
    Código :
    3 - chmod +x ftp
    - Automatizando o backup

    Código :
    1 - crontab -e
    2 - Adicionar a linha 05 15 * * * ./backup/ftp
    - E por ultimo o SAMBA

    Código :
    1 - Editar o arquivo "/etc/samba/smb.conf", adicioando as seguite linhas:
     
     
    [backup]
    comment = backup das torres
    path = /backup
    public = yes
    browseable = yes
    writable = yes
    read only = no
    create mask = 0700 
    directory mask = 0700
    dpois da um reboot no linux e testar.


    Enfim é isso, qualquer coisa tamos por ai

  2. Citação Postado originalmente por jonydboy Ver Post
    Pessoal ontem desenvolvi um simples sistema de backup das minhas torres, na nescessidade de automatização do download dos arquivos de *.backup gerado pelo mikrotik, desenvolvi esse SCRIPT.

    No meu caso Usarei o Ubuntu Server 7

    Com o SAMBA e nada mais.

    No Mikrotik criaremos:

    - Criando o grupo
    Código :
    / user group 
    add name="ftp" policy=ftp,!local,!telnet,!ssh,!reboot,!read,!write,!policy,!tes\
        t,!winbox,!password,!web,!sniff
    - Criando o User
    Código :
    / user 
    add name="ftp" group=ftp address=0.0.0.0/0 comment="" disabled=no
    - Criar uma senha no user "FTP".

    - Criando o Script de Backup
    Código :
    /system script
    add name=backup policy=ftp,reboot,read,write,policy,test,winbox,password,sniff source="/system backup save"

    - Automatizado o script.
    Código :
    /system scheduler
    add comment="" disabled=no interval=5d name=backup on-event=backup start-date=oct/20/2008 start-time=16:00:00
    NESTE PASSO VC PODE ALTERAR O INTERVALO DO BACKUP.

    Aparti de agora, o mikrotik gerar o backup automaticamente.

    Vamos agora gerar criar o script no Linux.

    - Vamos Criar os diretorios, observação criar 1 diretorio para cada torre e logo na frete modifica no script.
    Código :
    1 - apt-get install samba
    2 - mkdir /backup
    3 - mkdir /backup/Server
    4 - mkdir /backup/Alcides
    5 - chmod 777 /backup *
    - Vamos Criar o Script
    Código :
    1 - cd /backup
    2 - nano ftp
    Código :
    #!/bin/bash
    # SCRIPT PARA DOWNLOAD DOS BACKUPS
     
    # ZERA TODAS A VARIAVES E ARQUIVOS
    FTP_HOST=0
    FTP_USER=0
    FTP_PASS=0
    PASTAFILES=0
     
    ############################### CONFIGURAÇÕES GERAIS ###########################################
     
    ###### SERVER
     
    ARQUIVO="*.backup"                                         # Extenssão
    FTP_HOST="180.0.0.254"                                     # IP DO MIKROTIK
    FTP_USER="ftp"                                             # USUARIO DO FTP  DO MIKROTIK
    FTP_PASS="SENHA DO USER FTP AQUI"                          # SENHA DO FTP DO MIKROTIK
    PASTAFILES="/backup/Server"                                # PASTA DE ARMAZENAMENTO LOCAL
    cd $PASTAFILES
     
    # ROTINA FTP DE DOWNLOAD DOs ARQUIVOS
    cd $PASTAFILES
    ftp -in <<EOF
    open $FTP_HOST
    user $FTP_USER $FTP_PASS
    mget $ARQUIVO
    bye
    EOF
     
    ###### Alcides
     
    ARQUIVO="*.backup"                                         # Extenssão
    FTP_HOST="180.0.0.193"                                     # IP DO MIKROTIK
    FTP_USER="ftp"                                             # USUARIO DO FTP  DO MIKROTIK
    FTP_PASS="SENHA DO USER FTP AQUI"                          # SENHA DO FTP DO MIKROTIK
    PASTAFILES="/backup/Alcides"                               # PASTA DE ARMAZENAMENTO LOCAL
    cd $PASTAFILES
     
    # ROTINA FTP DE DOWNLOAD DOs ARQUIVOS
    cd $PASTAFILES
    ftp -in <<EOF
    open $FTP_HOST
    user $FTP_USER $FTP_PASS
    mget $ARQUIVO
    bye
    EOF
    Código :
    3 - chmod +x ftp
    - Automatizando o backup

    Código :
    1 - crontab -e
    2 - Adicionar a linha 05 15 * * * ./backup/ftp
    - E por ultimo o SAMBA

    Código :
    1 - Editar o arquivo "/etc/samba/smb.conf", adicioando as seguite linhas:
     
     
    [backup]
    comment = backup das torres
    path = /backup
    public = yes
    browseable = yes
    writable = yes
    read only = no
    create mask = 0700 
    directory mask = 0700
    dpois da um reboot no linux e testar.


    Enfim é isso, qualquer coisa tamos por ai


    Blz purissima rs...
    Vou testar amanha de manha, depois posto os resultados, aqui usarei fedora 8 para receber o becaup.
    Parabens ae parceiro, continuemos assim a contribuir e ajudar o forum.



  3. to tentado criar ele mais inteligente, pra o script n fik tão grande.

  4. Boa solução, seria interessante também se o próprio mikrotik conectasse no servidor FTP e enviasse o arquivo pra lá... como uma segunda opção...



  5. é verdade...






Tópicos Similares

  1. Respostas: 0
    Último Post: 20-11-2013, 08:18
  2. Respostas: 1
    Último Post: 05-06-2011, 17:31
  3. Script para backup via ftp (utilizem)
    Por spectrum no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 09-03-2007, 16:46
  4. Script de backup de usuarios, ascentos linux
    Por L3C4 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-04-2006, 08:34
  5. Script para backup via ftp entre 2 servidores
    Por tecman no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 22-01-2006, 11:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L