+ Responder ao Tópico



  1. #1

    Padrão Ip proxy + linux cache paralelo

    Boa tarde pessoal, sou novato na area e estava tentando efetuar um servidor mikrotik com cache em paralelo
    bem o problema e o seguinte ja procurei no forun muitos e muitos topicos mas nao consegui com que o meu cache funcione. A minha rede esta dividida da seguinte forma:

    internet -------->modem modo brigde-------->routerboard rb133------->cliente

    a routerboard tem 3 lan a lan1 esta recebedo o link do modem a lan2 e lan3 esta enviando para os clientes e um cartao minipci atheros r52 esta enviando tambem para os cliente junto a uma antena hiperlink 90º. Ai surge a minha duvida como faço para colocar o linux em paralelo por umas dessas lan e como configurar o ip proxy sendo que o meu mikrotik não tem web proxy. Agradeço e muito a ajuda se possivel.

  2. #2
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Em primeiro lugar você precisa ativar o Web proxy do seu Mikrotik. Em segundo, configure o proxy do Mikrotik e ponha o IP do Linux no Web proxy. Em terceiro, em IP firewal NAT faça o redirecionamento da porta 80 para porta configurada tanto no Mikrotik quanto no Linux.



  3. #3

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Em primeiro lugar você precisa ativar o Web proxy do seu Mikrotik. Em segundo, configure o proxy do Mikrotik e ponha o IP do Linux no Web proxy. Em terceiro, em IP firewal NAT faça o redirecionamento da porta 80 para porta configurada tanto no Mikrotik quanto no Linux.
    Bem amigo vou postar uma tela dizendo o que acontece afinal.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         tela mikrotik.JPG
Visualizações:	264
Tamanho: 	157,2 KB
ID:      	2935  

  4. #4
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Prezado,

    em Port você pôs 3128 e em Parent Port 5128. Por que???



  5. #5

  6. #6



  7. #7

    Padrão

    Amigo, utilize-se de um DNAT:
    /ip firewall nat add chain=dstnat dst-address=!ip_linux src-address=!ip_linux protocol=tcp dst-port=80 action=dst-nat to-address=ip_linux to-ports=port_proxy_linux

    Ou mesmo utilize-se do ip proxy:
    /ip proxy set enabled=yes port=8080 parent-proxy=iplinux:port maximal-client-connecions=500 maximal-server-connectons=500

    Assim irá economizar memória utilizada pelo web-proxy.

    Lembre-se: Ao utilizar o dnat, nem o web-proxy nem o ip proxy podem está ativados e ao utilizar-se do ip proxy, tem-se que fazer a regra de redir para a porta determinada no ip proxy.

  8. #8

    Padrão

    recentemente tentei fazer esse proxy paralelo e não consegui com este momento.



  9. #9

    Padrão

    recentemente tentei fazer esse proxy paralelo e não consegui com este mesmo .

  10. #10

    Padrão

    recentemente tentei este mesmo tutorial a fazer o proxy em paralelo e não consegui, fiz do mesmo jeito do tuto mas a rede ficou foi lenta d+++



  11. #11

    Padrão Forumweb.com

    Amigo entra neste forum e ver lá tem como vc fazer é muito facil.
    Portal

  12. #12

    Padrão

    Citação Postado originalmente por multlink Ver Post
    recentemente tentei este mesmo tutorial a fazer o proxy em paralelo e não consegui, fiz do mesmo jeito do tuto mas a rede ficou foi lenta d+++

    entre no forumweb.com que lá tem