+ Responder ao Tópico



  1. #81

    Padrão em outro topico :

    olha so galera

    em outro topico conversando com o Raniel ele deu a seguinte dica:

    Citação:
    Postado Originalmente por Raniel https://under-linux.org/forums/image...s/viewpost.gif
    Para usar com o hotspot, faça o seguinte:
    Use regra de dnat (fiz um post no vivaolinux, mikrotik + squid 2.6).
    Não uso o Transparent proxy nos profiles dos users.
    Desta forma funciona tranquilamente.


    Raniel obrigado pela dica:

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    por favor esse ip 10.111.1.2 e o ip do debian ,modem ou dos clientes??

    minhas redes
    mk10.1.1.0/24
    debian 10.10.10.0/24
    modem 192.168.254.0/24


    resposta :

    Este ip 10.111.1.2, é do debian.
    A sua regra pode ficar assim:
    Código:
    /ip firewall nat add chain=dstnat action=dst-nat to-addresses=10.111.1.2 to-ports=3128 src-address=!10.111.1.2 dst-address=!10.111.1.2 dst-port=80 protocol=tcp

    no caso ficaria assim:

    /ip firewall nat add chain=dstnat src-address=10.10.10.11 dst-address=10.10.10.11 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=
    10.10.10.11 to-ports=3128

    aki olink para o viva o linux
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]

    aki so a parte da regra com o dnat

    Configurando o mikrotik

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    Configuração de firewall mangle:

    /ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT

    /ip firewall mangle chain=forward action=mark-packet new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits

    /ip firewall mangle chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes tos=48

    /ip firewall mangle chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits


    Queue tree:

    /queue tree add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=0 queue=default priority=8 max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s

    /queue tree add 27 name="cache" parent=global-out packet-mark=cache-hits limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    vamos testar

    vou postar os resultados assim q tiver um parecer

    abraços

  2. #82

    Padrão

    Citação Postado originalmente por ivovid Ver Post
    olha so galera

    em outro topico conversando com o Raniel ele deu a seguinte dica:

    Citação:
    Postado Originalmente por Raniel https://under-linux.org/forums/image...s/viewpost.gif
    Para usar com o hotspot, faça o seguinte:
    Use regra de dnat (fiz um post no vivaolinux, mikrotik + squid 2.6).
    Não uso o Transparent proxy nos profiles dos users.
    Desta forma funciona tranquilamente.


    Raniel obrigado pela dica:

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    por favor esse ip 10.111.1.2 e o ip do debian ,modem ou dos clientes??

    minhas redes
    mk10.1.1.0/24
    debian 10.10.10.0/24
    modem 192.168.254.0/24


    resposta :

    Este ip 10.111.1.2, é do debian.
    A sua regra pode ficar assim:
    Código:
    /ip firewall nat add chain=dstnat action=dst-nat to-addresses=10.111.1.2 to-ports=3128 src-address=!10.111.1.2 dst-address=!10.111.1.2 dst-port=80 protocol=tcp

    no caso ficaria assim:

    /ip firewall nat add chain=dstnat src-address=10.10.10.11 dst-address=10.10.10.11 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=
    10.10.10.11 to-ports=3128

    aki olink para o viva o linux
    Linux: MikroTik + Squid 2.6 com cache full [Artigo]

    aki so a parte da regra com o dnat

    Configurando o mikrotik

    Configuração de firewall nat:

    /ip firewall nat add chain=dstnat src-address=10.111.1.2 dst-address=10.111.1.2 protocol=tcp dst-port=80 action=accept

    /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-address=10.111.1.2 to-ports=3128


    Configuração de firewall mangle:

    /ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passthrough=yes content=X-Cache: HIT

    /ip firewall mangle chain=forward action=mark-packet new-packet-mark=cache-hits passthrough=no connection-mark=forward-hits

    /ip firewall mangle chain=postrouting action=mark-connection new-connection-mark=proxy-hits passthrough=yes tos=48

    /ip firewall mangle chain=postrouting action=mark-packet new-packet-mark=proxy-squid passthrough=no connection-mark=proxy-hits


    Queue tree:

    /queue tree add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=0 queue=default priority=8 max-limit=8000000 burst-limit=0 burst-threshold=0 burst-time=0s

    /queue tree add 27 name="cache" parent=global-out packet-mark=cache-hits limit-at=0 queue=default priority=8 max-limit=4000000 burst-limit=0 burst-threshold=0 burst-time=0s


    vamos testar

    vou postar os resultados assim q tiver um parecer

    abraços

    pô naum deu certo

    as regras de nat deu certo porem as mangle e Queue tree naum deram

    qdo dou o comando pra executar da esse erro

    Terminal vt102 detected, using multiline input mode
    [[email protected]] > ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passth
    rough=yes content=X-Cache: HIT
    no such command or directory (chain)
    [[email protected]] >



  3. #83
    Avatar de stevens144
    Ingresso
    Oct 2007
    Localização
    Campo Grande MS
    Posts
    313
    Posts de Blog
    3

    Padrão

    qual versao do mk vc esta usando
    dependendo muda o comando
    quando for assim vai fazendo pelo winbox
    e seguindo os passos
    ex:
    /ip firewall nat
    add
    chain=srcnat

    entendeu? so q vc vai pelo winbox vai achar td... as vezes a parte de TOS esta entre parenteses e a variavel esta com outro nome..

  4. #84

    Padrão

    Citação Postado originalmente por stevens144 Ver Post
    qual versao do mk vc esta usando
    dependendo muda o comando
    quando for assim vai fazendo pelo winbox
    e seguindo os passos
    ex:
    /ip firewall nat
    add
    chain=srcnat

    entendeu? so q vc vai pelo winbox vai achar td... as vezes a parte de TOS esta entre parenteses e a variavel esta com outro nome..

    valew a dica amigo + tentei via terminal depois via winbox mesmo assim
    + naum deu certo naum



  5. #85

    Padrão Show

    Citação Postado originalmente por wifiinternet Ver Post
    primero vc vai usar :

    1 Mikrotik (qualquer versão) funcionando 3 placas de redes (com a placa de rede que vai para a Debian (ip=192.168.10.1/30)
    1 Debian Com 1 placa de rede editado assim (ip=192.168.10.2/mask=255.255.255.255.252/gw q eo mikrotik=192.168.10.1)


    Essa regra e para o mikrotik conversar com a Debian

    Vá em Firewall, dentro da aba NAT, clique em + , na janela a seguir, na primeira aba chamada GENERAL, no campo CHAIN escolha a opção SRCNAT, na opção SRC. ADDRESS coloque 192.168.10.0/30, vá até a aba ACTION E selecione MASQUERADE.



    primeiro a rede vai ficar assim

    internet
    !
    Mikrotik------Debian
    !
    !
    clientes

    agora instale o squid3 e tbm se vc precisar ssh para acessar-lo na sua rede(preferencial)( #apt-get update ) eu uso o putty no windows
    (#apt-get install ssh )vou disponixar para download
    #apt-get update
    #apt-get install squid3

    der permissões as pastas do proxy

    #chmod 777 /var/spool/squid3
    #chmod 777 /var/log/squid3
    #chown proxy.proxy /var/spool/squid3
    #chown proxy.proxy /var/log/squid3


    agora vc tem que apagar seu squid.conf
    #rm -rf etc/squid3/squid.conf
    agora criar-lo
    #vi etc/squid3/squid.conf
    ou use o mcdit
    se tiver em modo grafico va em pelo gedit

    agora leia o squid.conf e altere de acordo com seus hardware e seus clientes e edite do sua preferencia


    #Squid.conf gerado por Adriano Soluções - Adriano Jorge Vitorino Melo Junior
    #Contato (82) 9909-3868
    #
    # regras de segurança, iptables, etc. executadas no mikrotik.

    http_port 5128
    visible_hostname webproxy


    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigão
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS

    #permissão de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espaços.
    acl redelocal src 192.168.10.1
    http_access allow localhost
    http_access allow redelocal

    #bloquear todos outros acessos.
    http_access deny all

    #access log
    cache_access_log /var/log/squid3/access.log

    #cache.log
    cache_log /var/log/squid3/cache.log

    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e não mais.
    cache_mem 80 MB

    #máximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB

    #máximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB

    #regra que começa a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90

    #indicação de localização da pasta de arquivos cache e em sequência valor
    #total em MB de espaço no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 50048 16 256

    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560

    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF

    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0

    #########################################################################################################
    qual quer duvida desse squid.conf pode falar .

    agora seu squid ta funcionado

    abra seu mikrotik vá em IP > WEB PROXY> SETTINGS

    port:3128
    parent proxy:192.168.10.2
    parent port proxy:5128
    cache driver:system
    cache adriministrador"sua preferencia"
    max. cache size:none
    max client conection :1000
    " server """""""" :1000

    Pronto, seu proxy tem comunicação com o mikrotik e está apto a atender clientes, vamos as configurações para que os clientes passem pelo proxy.

    Vamos supor que a rede que você tem configurada para seus clientes é 10.0.0.0/24 (cliente 1 = 10.0.0.2/24, cliente 2 =10.0.0.3/24 etc...), também vamos pegar o primeiro ip desta classe como o configurado em IP ADDRESS ou seja 10.0.0.1/24.

    Precisamos primeiro permitir que esta classe acesse o proxy:

    Vá em IP > WEB PROXY, na aba ACCESS clique em +, já janela seguinte adicione a classe 10.0.0.0/24 no campo SRC-ADDRESS, na opção action deixe em ALLOW.

    Agora vamos barrar qualquer outra classe para acesso ao proxy:

    Clique novamente no + e na deixe todos os campos como estão, somente altere a opção action para DENY.

    Precisamos agora direcionar todo o trafego da porta 80 para o proxy, vá em IP > FIREWALL > aba NAT clique em + e coloque exatamente como esta na imagem abaixo:
    http://www.vivaolinux.com.br/imagens...rect-proxy.JPG

    Nas imagens acima, na aba GENERAL temos um campo marcado com um [!] escrito IP VÁLIDO DO SEU SERVIDOR,no seu caso o ip daDebian 192.168.10.2 , troque esta mensagem pelo IP válido que você está utilizando nesta máquina e mantenha o [!], no campo interfaces, onde na imagem aparece REDE_8 troque pela interface que atende diretamente seus clientes (ex: ether3).

    Agora temos que bloquear o acesso externo ao proxy, esta regra é muito importante, clique na aba FILTER RULES e clique no +, coloque exatamente como na figura abaixo:http://www.vivaolinux.com.br/imagens...erno-proxy.JPG

    e esse vc estiver no mk 2.9.27 tem que clicar em !x!transparent proxy

    eu tenho 15 anos foi moleza fazer o proxy e pq começei um dias desses
    coloquei esse proxy em uma rede de 200 clientes com uns 100 clientes acessando simultaniamente

    qualquer duvida pode me adicionar ([email protected])

    qualquer duvida dou o suporte a todos do forum




    Bem bolado
    fiz aki com o debian
    depois coloquei o brazilfw 3.0
    nao notei diferença tao show de bola em paralelo

    uma dica No Maximum Object Size coloque 1
    pq assim ele nao vao fica gravando nada no hd do mikrotik
    o vem direto do squid achei mais rapido
    espero ter ajudado

  6. #86

    Padrão AJUDA - Squid consumindo toda memoria

    Consegui fazer normalmente o cache paralelo.. "POREM", o meu squid está consumindo toda memoria.
    Aqui a navegação melhora muito nas primeiras horas é bastante rapido.. mas depois de 5 a 10 hras, dos 512 Mb de ram sobram apenas 4 mb deixando a navegação lenta impossivel de se acessar e as vezes ate travando... (e recebendo broncas dos clientes afff..)

    [email protected]:/home/squire# free -m -k
    total used free shared buffers cached
    Mem: 506 499 4 0 7 41
    -/+ buffers/cache: 33 311
    Swap: 1004 0 1004

    Voltando ao normal quando dou um reboot..
    Estou usando Ubuntu server num P4 1,500 hz com rodando apenas o basico ssh, bind e squid 2.7 2.7.STABLE5, com cache_mem 64 MB, e 5 diretorios como esse de diskd no cache_dir
    cache_dir diskd /var/cache/squid01 750 16 32 Q1=64 Q2=72
    total de 3.750 Gb para cache_dir..

    alguem já passou por isso? já testei varias configurações e continua o problema
    já ouvi falarem q pode ser um loop infinito na maquina.. mas sera q pode ser isso mesmo?

    quem puder me ajudar segue meu squid.conf

    #SQUID.CONF
    http_port 5128 transparent
    visible_hostname squidserver
    cache_effective_user squid
    cache_effective_group squid
    cache_mgr [email protected]

    cache_mem 64 MB
    maximum_object_size 100 MB
    minimum_object_size 0 KB
    cache_swap_low 70
    cache_swap_high 80
    dns_nameservers 127.0.0.1 189.17.1.130 200.255.255.66 200.255.255.70
    dns_defnames on

    cache_dir diskd /var/cache/squid01 750 16 32 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid02 750 16 32 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid03 750 16 32 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid04 750 16 32 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid05 750 16 32 Q1=64 Q2=72
    cache_store_log none
    cache_access_log none
    error_directory /usr/share/squid/errors/Portuguese
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # swat
    acl purge method PURGE
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl redelocal src 192.168.0.0/16
    http_access allow localhost
    http_access allow redelocal
    http_access allow all
    http_reply_access allow all

    # Bloqueia acesso externo
    http_access deny all

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY

    #memory_replacement_policy heap LRU
    memory_replacement_policy heap GDSF
    #memory_replacement_policy heap LFUDA

    #cache_replacement_policy heap LRU
    #cache_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA

    half_closed_clients off
    detect_broken_pconn on
    pipeline_prefetch on

    refresh_pattern ^ftp: 30 20% 1140
    refresh_pattern ^gopher: 30 0% 1140
    refresh_pattern . 30 20% 1140

    zph_mode tos
    zph_local 0x02
    zph_sibling 0x02
    zph_option 136
    zph_parent 0

    forwarded_for off
    memory_pools_limit 0
    icp_hit_stale on
    store_avg_object_size 128 KB
    store_objects_per_bucket 20

    Estou usando Cache full com 50% da banda total pra não saturar
    será que dessa vez encontro uma solução??



  7. #87

    Padrão

    Consegui fazer assim como manda as configurações, mas depois de 5 a 8 horas de uso fica muitoo lento nao dá pra navegar, o cache_dir ufs fica muito lento.. quando uso diskd ou aufs fica bem mais rapido, porem depois de um certo tempo o squid toma a memoria toda da maquina ai da pau!
    já pesquisei isso em varios topicos, nas comunidade do orkut, e até criei topicos aki, mãs não foi ao ar.. ninguem conseguiu resolver o problema daki do squid... será q alguem já passou por isso e pode me ajudar.. se precisar dou mais detalhes das configurações..

    grato
    Última edição por Squire; 14-03-2009 às 11:50.

  8. #88

    Smile squid.conf

    Squire

    Então como esta as regras de policiamento de recursos de memoria e hd ? qual foi a proporção entre hd X ram que vc usou ?
    Posta ai suas regras do squid.conf pra ver se posso te ajudar

    abraços

    ps: quando comecei a trabalhar com squid ele levou 41 dias para abrir o bico ficando lento e ferrando com a navegação dos clientes reportava até uma mensagem de erro no navegador dos caras, ai pesquisei uns detalhes aqui e fiz uns ajustes e esta rodando desde janeiro com otimo desempenho e aliado as minhar regras de cache full ta otimo mas pode melhorar e muito.



  9. #89
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Então, aqui em casa já faz 2 meses sem limpar cache nem nada, e o squid funciona que é uma beleza, já nem consigo mais navegar sem ele, fica muito lento a internet sem cache. O problema foi só configura, tem que fazer os limites certos de memória, e aqui uso o aufs (diskd ainda não foi implementado no squidNT)

  10. #90

    Padrão

    Citação Postado originalmente por jeanfrank Ver Post
    Squire

    Então como esta as regras de policiamento de recursos de memoria e hd ? qual foi a proporção entre hd X ram que vc usou ?
    Posta ai suas regras do squid.conf pra ver se posso te ajudar

    abraços

    ps: quando comecei a trabalhar com squid ele levou 41 dias para abrir o bico ficando lento e ferrando com a navegação dos clientes reportava até uma mensagem de erro no navegador dos caras, ai pesquisei uns detalhes aqui e fiz uns ajustes e esta rodando desde janeiro com otimo desempenho e aliado as minhar regras de cache full ta otimo mas pode melhorar e muito.

    Segue as regras

    http_port 5128 transparent
    visible_hostname squidserver
    cache_effective_user squid
    cache_effective_group squid
    cache_mgr [email protected]
    #Configuracao do cache
    cache_mem 64 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    dns_nameservers 127.0.0.1 189.17.1.130 200.255.255.66 200.255.255.70
    dns_defnames on
    cache_dir aufs /var/cache/squid01 2048 16 256
    #cache_dir diskd /var/cache/squid01 2048 16 256 Q1=64 Q2=72

    cache_store_log none
    cache_access_log none
    #/var/log/squid/access.log
    error_directory /usr/share/squid/errors/Portuguese
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl redelocal src 192.168.0.0/16
    http_access allow localhost
    http_access allow redelocal
    http_access allow all
    http_reply_access allow all

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    # Bloqueia acesso externo

    http_access deny all

    #memory_replacement_policy heap LRU
    memory_replacement_policy heap GDSF
    #memory_replacement_policy heap LFUDA

    #cache_replacement_policy heap LRU
    #cache_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA

    half_closed_clients off
    detect_broken_pconn on
    pipeline_prefetch on

    # O que nao bater nas regras acima, os valores abaixo segura como padrao...
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    zph_mode tos
    zph_local 0x02
    zph_sibling 0x02
    zph_option 136
    zph_parent 0

    forwarded_for off
    memory_pools_limit 0
    icp_hit_stale on
    store_avg_object_size 128 KB
    store_objects_per_bucket 20

    já tem + ou - 2 semanas q 3 semanas q venho testando configurações.. antes mesmo usava 4 diretorios de diskd,
    cache_dir diskd /var/cache/squid01 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid02 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid03 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid04 750 16 256 Q1=64 Q2=72

    a navegação parecia q era ótima. muit rapido mesmo .. mas só aguantava 5 horas e consumia a memoria toda.. sobrava apenas 4 ate travar a maquina..
    hoje uso aufs consgue aguentar 15 horas..rsrs mas consome a memorias toda do mesmo jeito
    tenho q dar reboot's diarios .. as vzes da vontade de voltar ao webproxy do mk .. mas não gosto muito.. não tem nem comparação com squid.. a performace é outra coisa, as regras q eu uso acho q não pode ser mais.. já tentei de quase tudo... estou usando Ubuntu Server rodando apenas o basico na maquina.. (ssh, bind9, squid 2.7) mas mesmo assim 512mb não guenta.. só me resta isso agora, se não der jeito vou usar Debian, inclusive é minha preferida..

    grato se puder me ajudar..



  11. #91

    Padrão

    Sou meio que iniciante em linux mas me tira essa duvida:


    http_access allow all
    http_reply_access allow all

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    # Bloqueia acesso externo

    http_access deny all

    Quando voce deu total acesso acl all src all 0.0.0.0/0.0.0.0 e depois vem a negação na ultima linha, isto tã certo?, fiquei realmente confuso ja que a ordem de execusao das acls do squid é de cima para baixo.

    Antecipadamente agradeço a quem puder esclarecer. Tenham, o otimo fim de semana.
    Última edição por Mirandapb; 15-03-2009 às 14:27.

  12. #92

    Padrão

    Gostei de ñ ter desistido

    todos nesse forum tem que ajudar os outros
    e ñ ter conhecimentos so para si


    Citação Postado originalmente por ivovid Ver Post
    despois de muito tempo (desde novembro) hj com a sua ajuda consegui
    fazer esse proxy em paralelo rodar


    JEAN SEM SUA PRECIOSA AJUDA NAUM COSEGUIRIA

    MUITO OBRIGADO



    TO MUITO FELIZ



  13. #93

    Padrão

    essas regras e para mk 2.9.51
    e ñ para 2.9.27

    e o que eu vi

    deixa cache sem ser full
    pq colocar full ?
    Citação Postado originalmente por ivovid Ver Post
    pô naum deu certo

    as regras de nat deu certo porem as mangle e Queue tree naum deram

    qdo dou o comando pra executar da esse erro

    Terminal vt102 detected, using multiline input mode
    [[email protected]] > ip firewall mangle chain=forward action=mark-connection new-connection-mark=forward-hits passth
    rough=yes content=X-Cache: HIT
    no such command or directory (chain)
    [[email protected]] >

  14. #94

    Padrão

    vc usa mas memória
    e configura para toda noite reiniciar sozinha
    e em 15 horas da um restart no cache
    fica 100%
    Citação Postado originalmente por Squire Ver Post

    Segue as regras

    http_port 5128 transparent
    visible_hostname squidserver
    cache_effective_user squid
    cache_effective_group squid
    cache_mgr [email protected]
    #Configuracao do cache
    cache_mem 64 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    dns_nameservers 127.0.0.1 189.17.1.130 200.255.255.66 200.255.255.70
    dns_defnames on
    cache_dir aufs /var/cache/squid01 2048 16 256
    #cache_dir diskd /var/cache/squid01 2048 16 256 Q1=64 Q2=72

    cache_store_log none
    cache_access_log none
    #/var/log/squid/access.log
    error_directory /usr/share/squid/errors/Portuguese
    acl all src 0.0.0.0/0.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports

    acl redelocal src 192.168.0.0/16
    http_access allow localhost
    http_access allow redelocal
    http_access allow all
    http_reply_access allow all

    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY
    # Bloqueia acesso externo

    http_access deny all

    #memory_replacement_policy heap LRU
    memory_replacement_policy heap GDSF
    #memory_replacement_policy heap LFUDA

    #cache_replacement_policy heap LRU
    #cache_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA

    half_closed_clients off
    detect_broken_pconn on
    pipeline_prefetch on

    # O que nao bater nas regras acima, os valores abaixo segura como padrao...
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    zph_mode tos
    zph_local 0x02
    zph_sibling 0x02
    zph_option 136
    zph_parent 0

    forwarded_for off
    memory_pools_limit 0
    icp_hit_stale on
    store_avg_object_size 128 KB
    store_objects_per_bucket 20

    já tem + ou - 2 semanas q 3 semanas q venho testando configurações.. antes mesmo usava 4 diretorios de diskd,
    cache_dir diskd /var/cache/squid01 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid02 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid03 750 16 256 Q1=64 Q2=72
    cache_dir diskd /var/cache/squid04 750 16 256 Q1=64 Q2=72

    a navegação parecia q era ótima. muit rapido mesmo .. mas só aguantava 5 horas e consumia a memoria toda.. sobrava apenas 4 ate travar a maquina..
    hoje uso aufs consgue aguentar 15 horas..rsrs mas consome a memorias toda do mesmo jeito
    tenho q dar reboot's diarios .. as vzes da vontade de voltar ao webproxy do mk .. mas não gosto muito.. não tem nem comparação com squid.. a performace é outra coisa, as regras q eu uso acho q não pode ser mais.. já tentei de quase tudo... estou usando Ubuntu Server rodando apenas o basico na maquina.. (ssh, bind9, squid 2.7) mas mesmo assim 512mb não guenta.. só me resta isso agora, se não der jeito vou usar Debian, inclusive é minha preferida..

    grato se puder me ajudar..



  15. #95

    Padrão

    ñ uso web proxy
    faço um redirecionamento direto dos clientes para o proxy
    pq da muito erro nas paginas com o webproxy

    vou fazer outro tutorial ou o ivovid
    melhor de entender

    Citação Postado originalmente por KaLNet Ver Post
    Bem bolado
    fiz aki com o debian
    depois coloquei o brazilfw 3.0
    nao notei diferença tao show de bola em paralelo

    uma dica No Maximum Object Size coloque 1
    pq assim ele nao vao fica gravando nada no hd do mikrotik
    o vem direto do squid achei mais rapido
    espero ter ajudado

  16. #96

    Exclamation Desculpe a Todos membros do Tópico

    porque "abandonei" ele por falta de tempo
    mas de agora por diante bora deixar um tempo reservado para estudar,aprender e depois ensinar
    aqueles que querem aprender
    eu não sou dono do tópico

    mas dei a iniciativa para quem quer aprender (incluindo eu no meio) pq nunca fiz um curso para poder ensinar um pouco aqui no under linux aprendi bastante do viva o linux


    e uma coisa eu digo cada dia que passa vc aprende +


    um otimo final de semana para todos

    att: Adriano Linux
    Última edição por wifiinternet; 15-03-2009 às 17:40.



  17. #97

    Padrão

    Citação Postado originalmente por wifiinternet Ver Post
    vc usa mas memória
    e configura para toda noite reiniciar sozinha
    e em 15 horas da um restart no cache
    fica 100%
    Blz.. vou tentar, mas já comecei os testes aqui com debian.. dependendo vou fazer a substituição, gostaria q fosse bem estável, assim como de alguns colegas q já vi ficar até 1 mes sem reiniciar...rsrs

    vlw Obrigado

  18. #98

    Smile Debian

    Squire

    Realmente o debian é muito estavel muito bom mesmo de trabalhar, tentei aqui com o CentOS e slakware mas gostei mesmo foi do debian sei la depende muito de cada um tambem, comecei com debian ai passei pro centos ai passei slakware e depois voltei pro debian muito bom mesmo

    abraços



  19. #99

    Padrão redirecionar os clientes sem passar pelo webproxy do mk 2.9.27 ??

    Citação Postado originalmente por wifiinternet Ver Post
    essas regras e para mk 2.9.51
    e ñ para 2.9.27

    e o que eu vi

    deixa cache sem ser full
    pq colocar full ?
    Amigo desculpa + da pra explicar melhor??

    vc tem as regras pra redirecionar os clientes sem passar pelo webproxy do mk 2.9.27 ??

    AMIGOS DESCULPEM POR ESSES DIAS LONGE DO FORUM ,TIVE Q DA UM TEMPO PRA MIM PQ TAVA MUITO OBSECADO EM FAZER O PROXY FUNCIONAR JUNTO COM O HOTSPOT Q ESQUECI ATE A DATA DO MEU CASAMENTO !!!!!!!!


    AI AMIGOS F... TUDO ......

    QUEM HE CASADO SABE O Q TO FALANDO

    VOU REFAZER TUDO INSTALAÇÃO DO DEBIAN E DO MK 2.9.27


    JEAN TENHO UMAS FOTOS AKI DO A29(SUPERTUCANO)PRA VC


    AMIGOS TEM OUTRA COISA !!!
    SE NAUM ME ENGANO UM TOPICO AKI COM 20 PAGINAS E TRANCADO
    ACHO Q SERIA HORA DE ABRIR UM OUTRO TOPICO PARA CONTINUAÇÃO DESSE AKI OU SOLICITAR AOS ADMINS DO FORUM Q NAUM FECHEM ESSE .

    O Q VCS ACHAM??


    ALGUEM AI TEM AS REGRAS DO MK 2.9.27 PRA FAZER O REDIRACIONAMENTO DOS CLIENTES SEM PASSAR PELO WEBPROXY???

    SO FALTA ISSO TO BATENDO NA TRAVE !!!!!!!
    Última edição por ivovid; 17-03-2009 às 12:48.

  20. #100

    Padrão redirecionar os clientes sem passar pelo webproxy do mk 2.9.27

    Citação Postado originalmente por wifiinternet Ver Post
    ñ uso web proxy
    faço um redirecionamento direto dos clientes para o proxy
    pq da muito erro nas paginas com o webproxy

    vou fazer outro tutorial ou o ivovid
    melhor de entender

    AMIGO DESDE JA AGRADEÇO POR NOS AJUDAR

    vc tem as regras pra redirecionar os clientes sem passar pelo webproxy do mk 2.9.27 ??
    digo : as regras do firewall???


    aki com a ajuda do Jean consegui fazer o mk falar com o debian

    o problema todo he que qdo habilito o hotspot o squid para de fazer cache
    simplesmente o trafego da placa de rede q vai do mk pro debiam cai a 0(zero) a placa de rede fica tx e rx 00.00

    consigo me altenticar no hotspot pega ip do dhcp etc navego normalmete
    blz

    vou e desabilito o hotspot ai o trafego na placa de rede q vai do mk pro debiam volta a ter trafego