Página 1 de 16 123456 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Configurar BGP

    Amigos,

    Comprei uma range de IP /20 para minha ASN. Preciso configurar esses IPs em meu roteador que é feito em cima de Mikrotik.
    Gostaria de saber se alguem já fez essa configuração de BGP.
    Fico no aguardo.

    Grato.

    Att.,

  2. #2

    Padrão

    Oi amigo,

    estou na mesma situação!!
    ja obteve alguma solução nesse caso??!

    vlws



  3. #3

    Padrão

    Amigo,

    Ainda não. O pessoal fez muito em roteadores Cisco e tal, mas em mikrotik não achei nada na internet.
    Se descobrir alguma coisa, me manda.
    Abraços,

  4. #4



  5. #5

    Padrão

    Citação Postado originalmente por flaviobatistela Ver Post
    Amigos,

    Comprei uma range de IP /20 para minha ASN. Preciso configurar esses IPs em meu roteador que é feito em cima de Mikrotik.
    Gostaria de saber se alguem já fez essa configuração de BGP.
    Fico no aguardo.

    Grato.

    Att.,
    oi flavio,

    estou com uma duvida, nao sei se pode me ajudar...
    vc ja tem um AS neh?! Então, como podem ser relacionados os IPs? podem ser somente IPs privados na sua rede e pra saida no MK com a net usar um NAT para a tradução? Ou o AS exige que seja tudo IP válido na sua rede? tanto rede interna como externa?
    Estou organizando uma rede só no papel por enquanto, ja separei as vlans, agora faltou essa parte de IP! inválido (privado) ou válido!?

    obrigado!!!

  6. #6

    Padrão

    delmottos,

    Com a ASN você vai possuir seus próprios IPs, mas nada impede de você utilizar IPs privados (NAT) na sua rede.
    Abraços,



  7. #7

  8. #8

    Padrão

    voce tendo seu AS, o ideal eh colocar ip valido para cada cliente.. se possivel ip valido porem dinamico para cada vez o cliente conectar ele obter um ip diferente..

    para configurar o AS no mikrotik testa ai de acordo com as imagens do anexo.. lembrando que, voce precisa marcar com as suas operadoras para q ela configure o BGP nos routers tambem para propagar suas rotas adiante...

    solicite que seja feito um full-routing com multi-hop (porque o neighbor dos uplinks nao estao diretamente no seu router)

    veja as imagens ...

    levando algumas consideracoes:
    seu bloco: 189.200.0.0/20
    interface LAN onde vai colocar o 189.200.200.1 é ether1

    imagem01
    1- clique no +
    2- coloque um nome para identificar a instancia do bgp (pode ser qq nome)
    3- coloque o numero do seu AS
    4- router id geralmente é o primeiro ip do seu CIDR do AS (189.200.200.1)

    imagem02
    1- clique no +
    2- nome do peer, um nome para identificar a operadora
    3- instance é o nome usado no item 2 da imagem 1
    4- aqui voce coloca o ip do router da operadora (eles vao te fornecer quando voce fecha o bgp com eles)
    5- AS da operadora
    6- marcar multi-hop porque o ip do neighbor da operadora esta mais de 1 salto da sua rede
    clique na abada ADVANCED

    imagem03
    1- update source voce coloca a ether1
    2- interface coloca tambem a ether1 (se nao der certo, coloca a interface que esta ligada ao link da operadora)

    imagem04
    1- clique no +
    2- coloque o bloco do seu AS
    3- marque para sincronizar


    se a operadora ja estiver com o BGP ativo para seu AS, voce vai começar a receber as rotas...

    é basicamente isto, eu nao testei porque meu BGP é feito em roteadores da cisco.. mas o principio é o mesmo...


    até !!
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         bgp_mk001.jpg
Visualizações:	2128
Tamanho: 	49,8 KB
ID:      	2980   Clique na imagem para uma versão maior

Nome:	         bgp_mk002.jpg
Visualizações:	1929
Tamanho: 	73,0 KB
ID:      	2981  

    Clique na imagem para uma versão maior

Nome:	         bgp_mk003.jpg
Visualizações:	1835
Tamanho: 	30,0 KB
ID:      	2982   Clique na imagem para uma versão maior

Nome:	         bgp_mk004.jpg
Visualizações:	1727
Tamanho: 	37,2 KB
ID:      	2983  




  9. #9

    Padrão

    alexandrecorrea,

    Muito obrigado pela ajuda. Vou fazer dessa forma e posto os resultados aqui.
    Abraço.

    Att.

  10. #10

    Padrão

    Flavio,

    É basicamente isso, fique atento com filtros, talvez seja necessário criar filtros no roteamento do BGP para não publicar rotas invalidas.

    Dica

    Abre o console e digite 'routing bgp advertisements print' e vc verá seu router receber as rotas de sua operadora, fique atento também com o processamento e memória de seu hardware (não sei qual ira usar).


    Segue alguns links para maior conhecimento do BGP em Mikrotik

    BGP_Case_Studies_1

    Manual_2.7/Routing/BGP


    Só uma coisa talvez o Alexandre possa me ajudar, vc sabe como e quando usar 'redistribute-connected' e
    'redistribute-static' dei uma lida mas não entendi mto bem.


    Abraços a todos.

    Qualquer novidade faço um post aki.


    -KaLZ-



  11. #11

    Padrão

    redistribute-static ou connected define se o router vai distribuir TAMBEM as rotas setadas estaticamente .. e as diretamente conectadas...

  12. #12

    Padrão abaixo.

    # sep/06/2008 11:23:54 by RouterOS 3.9

    # software id = FHEK-IHT

    #

    /routing bgp instance

    set default as=28208 client-to-client-reflection=no comment="" disabled=no \

    ignore-as-path-len=no name="default" out-filter="" \

    redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=yes \

    redistribute-rip=yes redistribute-static=yes router-id=xxx.xxx.xxx.xxx



    /routing bgp network

    add disabled=no instance=default network=xxx.xxx.xxx.xxx/20 synchronize=yes



    /routing bgp peer

    add address-families=ip comment="" disabled=no hold-time=3m in-filter="" \

    instance=default interface=ether2 multihop=no name="Embratel" \

    nexthop-choice=propagate out-filter="" remote-address=xxx.xxx.xxx.x \

    remote-as=4230 route-reflect=no tcp-md5-key="" ttl=255 \

    update-source=ether2



  13. #13

    Padrão

    kalz,

    Muito obrigado pelos manuais. Já estou traduzindo.
    Sobre os filtros, onde é feito no MKT?

    Grato.

  14. #14

    Padrão

    Carinha,

    Instalei outro BGP hoje porem esse esta estranho, já faz 4 horas que instalei e só recebeu 3 mil rotas...lembrando que é parcial mas esta demorando um pouco.

    Vi com o provedor e informaram que divulgaram minha rede internacionalmente (acredito que isso demore alguns dias).

    Tem ideia de qto tempo demora para toda a publicação?

    Obrigado novamente.

    -KaLz-



  15. #15

    Padrão

    Em "IP > 'router filters'" , depende tambem se vc utilizou 'redistribute-static ou connected' ai sim vc deve criar os filtros.

    Abração

    -KaLz-

  16. #16

    Padrão

    mas as rotas nacionais (partial routing) sao umas 5.000 +-



  17. #17

    Padrão

    Falei com o pessoal de BGP e fui informado q é por volta de 4 mil mesmo......o problema que não estou conseguindo acessar varios sites como dell.com, hp.com.br, speedtest.net etc etc não existem rotas para os IPs resolvidos.

    Minha duvida é, será que isso é um problema ou é a demora para atualização do bloco de IPs para essas rotas internacionais talvez?


    Abraços

    -KaLz-

  18. #18

    Padrão

    quando ativei o bgp pela primeira vez demorou uns 2.. 3 dias pra publicarem fora do brasil



  19. #19

    Padrão

    Descobri, o Router da Telefônica só publica rotas de seu ASN e ASN vizinho da propria telefonica, logo algumas rotas não são publicadas. A solução da própria telefônica é criar uma rota default para seu roteador que resolverá os problemas heheheheeh ai ai aiiiiii viuuuu!!!!

    Agora sim tudo funcionando.......


    Valeu a todos e obrigado Alexandre, vamos sempre manter o Under-linux sendo um dos melhores foruns do Brasil.

    Fuiiiiiiiiiiii

  20. #20

    Padrão

    Citação Postado originalmente por kalz Ver Post
    Descobri, o Router da Telefônica só publica rotas de seu ASN e ASN vizinho da propria telefonica, logo algumas rotas não são publicadas. A solução da própria telefônica é criar uma rota default para seu roteador que resolverá os problemas heheheheeh ai ai aiiiiii viuuuu!!!!

    Agora sim tudo funcionando.......


    Valeu a todos e obrigado Alexandre, vamos sempre manter o Under-linux sendo um dos melhores foruns do Brasil.

    Fuiiiiiiiiiiii

    Lembrando que isso é para BGP PARTIAL-ROUTING !!!! O BGP FULL-ROUTING não tem esses problemas.

    Agora Fuiiiii