+ Responder ao Tópico



  1. #1

    Padrão Problemas com proxy

    Olá, tenho um servidor rodando Squid + Iptables, compartilhando a internet para toda a rede. Também possuo um servidor com Apache, que roda uma aplicação web em PHP.
    O problema é que quando vou acessar o servidor Apache via navegador, digitando o endereço ip, como http://192.168.0.63, as páginas estão demorando muito tempo para abrir.
    Quando retiro o navegador do proxy, as páginas abrem instantaneamente, sem apresentar qualquer problema de lentidão, mas é só colocar no proxy que a velocidade cai drasticamente.
    O interessante é que a internet está rápida, somente quando vou acessar um servidor web fica lento.
    Já instalei o Apache em outras máquinas da rede e ocorreu o mesmo problema. Quando acesso o Apache na máquina local ele funciona normalmente. No próprio servidor que está o Squid coloquei o Apache e aconteceu a mesma coisa.
    Acredito que não seja problema de rede, já que a internet está rápida. Problema de hardware também não é, porque a internet está normal, assim como outros serviços de rede. Preciso resolver este problema devido a aplicação web. Alguém tem alguma dica?

  2. #2

    Padrão

    Amigo,

    O problema é o seguinte como seu servidor ta dentro da rede o proxy tenta enviar para internet o o seu roteador manda de volta, causando um certo loop. O que você teria de fazer é o por suas maquinas para não ir para o proxy quando acessar esse endereço ou se for proxy transparente colocar esse IP fora do proxy enviando direto para o servidor.

    Abraços.



  3. #3

    Padrão

    Olá Ruyneto, obrigado pela resposta.

    Como já havia dito, possuo dois servidores rodando Apache, sendo um o próprio servidor squid+iptables. Coloquei o endereço ip do outro servidor no arquivo hosts em /etc, e ele agora está respondendo normalmente, sem apresentar lentidão. Só que o Apache que está no servidor squid continua apresentando demora na exibição das páginas.

    Se eu coloco o endereço ip da rede local, 192.168.0.1, ele demora para responder. Se eu coloco o ip da interface de rede externa(internet), as páginas abrem normalmente. Já pesquisei bastante e ainda não consegui encontrar nada que resolva este problema.

  4. #4

    Padrão

    Amigo,

    Se o apache está no mesmo servidor do Squid realmente fica complicado, o que você pode tentar fazer é colocar o apache para escutar em outra porta, ou separar esses servidores em 2.

    Abraços,