+ Responder ao Tópico



  1. Estava pronto para implantar meu Load Balance através de um script que fui editando a minha realidade.
    A linha é esta abaixo:

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Clientes
    add address=172.0.2.92/16 network=172.0.0.0 broadcast=172.0.255.255 interface=link_embratel
    add address=172.0.1.49/16 network=172.0.0.0 broadcast=172.0.255.255 interface=link_velox

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    / ip firewall mangle
    add chain=prerouting src-address-list=odd in-interface= Clientes action=mark-connection \ new-connection-mark=odd passthrough=yes
    add chain=prerouting src-address-list=odd in-interface= Clientes action=mark-routing \ new-routing-mark=odd
    add chain=prerouting src-address-list=even in-interface= Clientes action=mark-connection \ new-connection-mark=even passthrough=yes
    add chain=prerouting src-address-list=even in-interface= Clientes action=mark-routing \ new-routing-mark=even
    add chain=prerouting in-interface= Clientes connection-state=new nth=1,1,0 \ action=mark-connection new-connection-mark=odd passthrough=yes
    add chain=prerouting in-interface= Clientes action=add-src-to-address-list \ address-list=odd address-list-timeout=1d connection-mark=odd passthrough=yes
    add chain=prerouting in-interface= Clientes connection-mark=odd action=mark-routing \ new-routing-mark=odd passthrough=no
    add chain=prerouting in-interface= Clientes connection-state=new nth=1,1,1 \ action=mark-connection new-connection-mark=even passthrough=yes
    add chain=prerouting in-interface= Clientes action=add-src-to-address-list \ address-list=even address-list-timeout=1d connection-mark=even passthrough=yes
    add chain=prerouting in-interface= Clientes connection-mark=even action=mark-routing \ new-routing-mark=even passthrough=no

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=172.0.2.92 \ to-ports=0-65535
    add chain=srcnat connection-mark=even action=src-nat to-addresses=172.0.1.49 \ to-ports=0-65535

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    / ip route
    add dst-address=0.0.0.0/0 gateway=189.53.70.16 scope=255 target-scope=10 routing-mark=odd
    add dst-address=0.0.0.0/0 gateway=189.53.70.16 scope=255 target-scope=10 routing-mark=even
    add dst-address=0.0.0.0/0 gateway=192.168.254.254 scope=255 target-scope=10

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


    Tenho as seguintes questões:

    1) Quando a linha abaixo, ocorre o erro descrito na foto 1
    add chain=prerouting src-address-list=odd in-interface= Clientes action=mark-connection \ new-connection-
    mark=odd passthrough=yes


    OBS: me falaram que onde tem odd, é para ser add
    Mas mesmo assim, deu o seguinte erro:
    [admin@MikroTik] > add chain=prerouting src-address-list=add in-interface=Clientes action=mark-connection \ new-connection-mark=add passthrough=yes

    bad command name add (line 1 column 1)




    2) O link padrão embratel é discado (modem brigge), enquanto o velox é roteado
    Na linha onde atribuo router embratel, está certo eu colocar o IP da embratel ou devo colocar o IP da placa conectada ao modem embratel? ou nem preciso incluir essas duas linhas?
    add dst-address=0.0.0.0/0 gateway=189.53.70.16 scope=255 target-scope=10 routing-mark=odd
    add dst-address=0.0.0.0/0 gateway=189.53.70.16 scope=255 target-scope=10 routing-mark=even
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         foto1.jpg
Visualizações:	77
Tamanho: 	48,2 KB
ID:      	2995  
    Última edição por alencar2; 06-11-2008 às 16:07.






Tópicos Similares

  1. Erro no new terminal ao colar regras
    Por carneirinhobad no fórum Redes
    Respostas: 3
    Último Post: 12-11-2010, 09:09
  2. Erro de spool no terminal server do server 2003
    Por janeonascimento no fórum Sistemas Operacionais
    Respostas: 15
    Último Post: 22-01-2009, 14:44
  3. Erro no terminal
    Por terra_jr no fórum Servidores de Rede
    Respostas: 6
    Último Post: 02-10-2006, 22:13
  4. Menssagem de erro no qmail
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-02-2005, 20:41
  5. re: erro no linux
    Por haysar no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-06-2002, 17:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L