Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Amigos antes eu usava o mk 2.9.27 e funcionava normal essa regra...
    :log info "DDNS Begin"
    :global ddns-user "usuario"
    :global ddns-pass "senha"
    :global ddns-interface "interface de entrada do link"
    :global ddns-host "host cadastrado no ddns"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")


    essa regra não funciona na versão 3.x do mk, alguem sabe alguma regra que funcione..

  2. TESTA AEW
    Código :
    :log info "DDNS Begin"
    :global ddns-user ""
    :global ddns-pass ""
    :global ddns-interface ""
    :global ddns-host ""
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[:pick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")]
    Última edição por magrock; 10-11-2008 às 06:51.



  3. Bom aqui uso esse e funciona sem problemas.

    DDNS MK 3.xx
    Código :
    # Define User Variables
    :global ddnsuser "usuario"
    :global ddnspass "senha"
    :global ddnshost "host.changeip.org"
     
    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
     
    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )
     
    # Define Local Variables
    :local int
     
    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={ 
      :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
         :global ddnsinterface [/ip route get $int interface]
      } 
    }
     
    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]
     
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
       :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
     
      :if ($ddnsip != $ddnslastip) do={
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
     
      } else={ 
        :log info "DDNS: No update required."
      }
     
    }
     
    # End of script

  4. #int-DDNS.Info
    /tool dns-update name=usuario.ddns.info address=127.0.0.255 key-name=usuario key="senha"



  5. inclusive funciona tranquilo no meu 2.9.27 a um tempão.

    pode usar


    o neydourado mandou BEM.






Tópicos Similares

  1. DDNS com modem routeado no MK
    Por lhonay no fórum Redes
    Respostas: 9
    Último Post: 08-11-2013, 00:43
  2. Respostas: 1
    Último Post: 06-03-2010, 10:46
  3. Controle de COnteudo no MK
    Por helrs no fórum Redes
    Respostas: 3
    Último Post: 14-10-2006, 18:40
  4. Autenticação no MK é hotspot??
    Por voidmain no fórum Redes
    Respostas: 8
    Último Post: 29-04-2006, 18:39
  5. Desafio ; Colocando Script em Perl no MK
    Por tecpimenta no fórum Redes
    Respostas: 2
    Último Post: 15-03-2006, 13:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L