+ Responder ao Tópico



  1. Boa noite pessoal, tudo bem? Estou com alguns problemas que tem feito eu desgostar um pouco do Debian, mas gostaria de insistir um pouco mais nele. A minha instalação é a Netinst (absolutamente básica) do Debian ETCH.
    Bom, vamos aos problemas:

    No momento eu gostaria, por exemplo, de instalar o GTK+2.14, pois é necessário uma versão dessa biblioteca para instalar o Firefox (esse Iceweasel é muito ruinzinho), mas está dando o seguinte erro após descompactar e tentar instalá-lo: através do ./configure:

    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for native Win32... no
    checking for gcc... no
    checking for cc... no
    checking for cl.exe... no
    configure: error: in `/opt/gtk/gtk+-2.14.4':
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.

    E isso não ocorre apenas para esta biblioteca. É PARA QUALQUER BIBLIOTECA OU APLICATIVO, E ISSO FRUSTRA UM POUCO, POIS PARECE QUE O LINUX NÃO QUER QUE O CARA ESQUEÇA DAS FACILIDADES DO WINDOWS.

    Quando eu procuro por versões do gcc, cc e não sei mais o que, não consigo achar.

    Existe alguma forma de atualizar o Debian, e suas bibliotecas por completo? Esse Netinst é uma roubada? Seria melhor eu instalar o Debian a partir de um cd mais completo? Eu estou fazendo tudo errado?

    Obrigado a quem puder me audar e esclarecer estas dúvidas/problemas. É uma dificuldade GERAL que eu venho tendo há algum tempo.

    Eu jamais vou desistir do LINUX, hehehe. Um grande abraço a todos.

  2. experimenta instalar os pacotes kernel-package e build-essentials






Tópicos Similares

  1. Respostas: 3
    Último Post: 17-11-2013, 07:28
  2. problema com pacotes de atualização
    Por koenmah no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-04-2009, 06:48
  3. Openbsd 3.8 Problemas com pacotes icmp
    Por budairc no fórum Sistemas Operacionais
    Respostas: 4
    Último Post: 07-02-2006, 10:33
  4. Problemas com pacotes rpm
    Por atilarampazo no fórum Servidores de Rede
    Respostas: 3
    Último Post: 07-01-2006, 21:01
  5. IPTABLES - Problemas com Roteamento de Pacotes
    Por ATNunes no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-12-2002, 15:14

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L