+ Responder ao Tópico



  1. Estou com uma duvida para configurar minha placa eth0 que esta ligada na rede local, a eth1 esta ligada ao modem como dhcp e a eth0 com ip 10.1.1.0/24.

    Minha duvida é somente em relação com ao Gateway e DNS da eth0.

    Esta configurada as interfaces da seguinte maneira:

    Modem ADSL ==> Roteador ==> eth1 - Servidor Linux - eth0 ==> Rede local 10.1.1.0/24

    auto lo
    iface lo inet loopback
    # Primeira placa de rede eth0
    auto eth0
    iface eth0 inet static
    address 10.1.1.250
    netmask 255.255.255.0
    network 10.1.1.0
    broadcast 10.1.1.255
    gateway 192.168.0.1 #Ip do meu roteador que esta ligado a eth1
    dns-nameservers 200.165.132.147 200.149.55.140 # DNS do Oi velox
    dns-search xxx.servegame.com meu
    # Segunda placa de Rede eth1
    auto eth1
    iface eth1 inet static
    address 192.168.0.250
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1
    dns-nameservers 200.165.132.147 200.149.55.140

    Mas eu quero tirar o roteador e fazer com que o Servidor Linux faça o papel do roteador usando a interface ppp0 e então como ficaria a eth0 nessa topologia?

    Modem ADSL==> eth1 - Servidor Linux - eth0 ===> Rede local 10.1.1.0/24

    auto lo
    iface lo inet loopback
    # Primeira placa de rede eth0
    auto eth0
    iface eth0 inet static
    address 10.1.1.250
    netmask 255.255.255.0
    network 10.1.1.0
    broadcast 10.1.1.255
    gateway ???.???.???.??? # Aqui é minha duvida
    dns-nameservers ???.???.???.??? # E aqui tambem

    # Segunda placa de Rede eth1
    auto eth1
    iface eth1 inet dhcp

  2. Amigo, você só precisa de um gateway configurado na máquina, isso quer dizer que, se a sua interface ETH1 irá pegar IP e consequentemente gateway, você não precisa configurá-lo na ETH0.

    Ficando:

    auto lo
    iface lo inet loopback
    # Primeira placa de rede eth0
    auto eth0
    iface eth0 inet static
    address 10.1.1.250
    netmask 255.255.255.0
    network 10.1.1.0
    broadcast 10.1.1.255

    # Segunda placa de Rede eth1
    auto eth1
    iface eth1 inet dhcp



  3. Entendi cesarkallas.


    Mas nas estações eu coloco o gateway o ip da eth0 (10.1.1.250) neh ?



    E mais uma vez vlw msm pela ajuda.

  4. Sim, mas não esqueça de compartilhar a interface.

    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -j MASQUERADE

    Sds,



  5. Isso eu ja tinha feito...

    ...agora ta resolvido meu problema.


    Vlw msm !!!






Tópicos Similares

  1. probelma com placa de rede
    Por mcyberx no fórum Servidores de Rede
    Respostas: 10
    Último Post: 12-05-2006, 14:24
  2. Conectiva 10 - Com placa de rede, navegador não funciona.
    Por dbvilar no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-12-2004, 18:46
  3. Mandrake 10 official dando pau com placas de rede realtek
    Por overkill13 no fórum Servidores de Rede
    Respostas: 5
    Último Post: 18-11-2004, 15:36
  4. problemas com placas de rede
    Por daniel bonfim no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 11-09-2004, 05:35
  5. problemas com placa de rede rtl8139 no debian
    Por nathan_levy no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 12-04-2004, 08:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L