+ Responder ao Tópico



  1. Tipo to com um problema aqui na minha rede em casa... mo esquisito !
    Ja tentei ver o que pode ser mas n consigo achar o que é !!

    Seguinte tenho 1 pc com 2 placas de rede
    etho -> internet
    eth1 -> rede interna

    tenho squid instalado configurado pra n bloquea nada ... mas que que acontece quando abro o orkut pelo firefox ele da um erro.
    erro de ssl.
    coloquei ate script .pad pro computador da rede passa direto a navegação quando for acessa site do orkut e tudo mais e tanto o orkut como o gmail dao erros ao tentar abrir.
    nao tem nenhuma regra barrando isso.
    regra que tenho e de limitação de banda pra rede local.

    segue abaixo squid.conf
    http_port 3128 transparent
    visible_hostname server

    cache_mem 64 MB
    maximum_object_size_in_memory 64 KB
    maximum_object_size 512 MB
    minimum_object_size 0 KB
    cache_swap_low 90
    cache_swap_high 95
    cache_dir ufs /var/spool/squid 2048 16 256
    cache_access_log /var/log/squid/access.log
    refresh_pattern ^ftp: 15 20% 2280
    refresh_pattern ^gopher: 15 0% 2280
    refresh_pattern . 15 20% 2280

    acl all src 0.0.0.0/0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl redelocal src 192.168.0.0/24
    acl SSL_ports port 443 563
    acl Safe_ports port 21 80 443 563 70 210 280 488 59 777 901 1025-65535
    acl purge method PURGE
    acl CONNECT method CONNECT
    acl site dstdomain orkut.com
    #acl bloqueados url_regex -i "/etc/squid/bloqueados"
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 654688/654688 40348/40348
    delay_access 1 allow redelocal


    always_direct allow site
    #http_access deny bloqueados
    http_access allow localhost
    http_access allow redelocal

    http_access deny all



    segue abaixo script do iptables


    #!/bin/bash

    # Interface da Internet:
    ifinternet="eth0"

    # Interface da rede local
    iflocal="eth1"

    iniciar(){
    #nat - compartilhamento
    modprobe iptable_nat
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o $ifinternet -j MASQUERADE

    #aMule port
    iptables -A INPUT -i $ifinternet -p tcp --dport 4662 -j ACCEPT
    iptables -A INPUT -i $iflocal -p udp --dport 4667 -j ACCEPT

    #ftp port
    iptables -A INPUT -i $ifinternet -p tcp --dport 2121 -j ACCEPT
    iptables -A INPUT -i $iflocal -p tcp --dport 2121 -j ACCEPT

    #ssh port
    iptables -A INPUT -i $iflocal -p tcp --dport 22 -j ACCEPT
    iptables -A INPUT -i $ifinternet -p tcp --dport 22 -j ACCEPT

    #port proxy
    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128
    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 443 -j REDIRECT --to-port 3128
    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 563 -j REDIRECT --to-port 3128

    #proteções
    iptables -A INPUT -p icmp --icmp-type echo-request -j DROP
    echo 1 > /proc/sys/net/ipv4/conf/default/rp_filter
    iptables -A INPUT -m state --state INVALID -j DROP
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A INPUT -i $iflocal -j ACCEPT
    iptables -A INPUT -p tcp --syn -j DROP
    }

    parar(){
    iptables -F
    iptables -X
    iptables -t nat -F
    }

    case "$1" in
    "start") iniciar ;;
    "stop") parar ;;
    "restart") parar; iniciar ;;
    *) echo "Use os parâmetros start ou stop"
    esac




  2. ahh quando eu coloco o proxy manualmente no fire fox navega normalmente sem problemas ... so que pra mim isso e mto porco quero usar ele de forma "transparente" sem ter que fica setando nada no computador ... !
    e otra no internet explorer funciona normalmente sem ter que seta ip do proxy !
    alguem pode me da uma ajuda alguma ideia do que seje ?!?!?!
    script wpad.pat
    function FindProxyForURL(url, host) {
    if (shExpMatch(url,"*.orkut.com/*")) {return "DIRECT";}
    if (shExpMatch(url,"*.orkut.com.br/*")) {return "DIRECT";}
    if (shExpMatch(url,"*.gmail.com/*")) {return "DIRECT";}
    if (isInNet(host, "192.168.0.1", "255.255.255.0")) {return "DIRECT";}
    return "PROXY 192.168.0.1:3128";
    }

  3. transparente NÃO FUNCIONA com ssl; derive a porta 443 para NÃO passar pelo squid.



  4. Citação Postado originalmente por irado Ver Post
    transparente NÃO FUNCIONA com ssl; derive a porta 443 para NÃO passar pelo squid.
    opa eu nao tinha pensado nisso testei mais cedo funcionou perfeitamente como queria... obrigadao cara.. !!


    obrigado pela atenção !






Tópicos Similares

  1. php-bug
    Por marcfee no fórum Linguagens de Programação
    Respostas: 3
    Último Post: 01-04-2003, 11:45
  2. BUGs?
    Por PiTsA no fórum Linguagens de Programação
    Respostas: 0
    Último Post: 27-03-2003, 02:10
  3. Nuke so Bug
    Por PiTsA no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-03-2003, 20:10
  4. BUG no PHP 4.3.0
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-02-2003, 11:10
  5. Iptables com Bug...
    Por demiurgo no fórum Servidores de Rede
    Respostas: 10
    Último Post: 18-02-2003, 07:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L