Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão DDNS.

    Alguém tem tutorial para configuração DDNS?

  2. #2

    Padrão

    Caro amigo,
    Segue abaixo o script, lembre-se q tem q alterar o usuario, senha e dominio criado.
    Mas aconselho antes de fazer uma pergunta pesquisar no forum, pois tem mta informaçao sobre isso no forum.

    # Define User Variables
    :global ddnsuser "usuario DDNS"
    :global ddnspass "senha DDNS"
    :global ddnshost "xxxxxxxxxxxx.ddns.info"

    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )

    # Define Local Variables
    :local int

    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }

    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }

    # End of script



  3. #3

    Padrão

    desculpa amigo sou novo no forum, nem pensei nisso..

    mais obrigado...

  4. #4
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por corradini Ver Post
    Alguém tem tutorial para configuração DDNS?
    ou isso:

    https://under-linux.org/forums/mikro...oto-ao-mk.html



  5. #5

    Padrão

    então eu vi a video aula fiz exatamente como esta, mais não deu certo, o q será q fiz errado?

    ip: 189.29.95.232

    user: teste

    password: teste

    desde já agradeço..

  6. #6
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por corradini Ver Post
    então eu vi a video aula fiz exatamente como esta, mais não deu certo, o q será q fiz errado?

    ip: 189.29.95.232

    user: teste

    password: teste

    desde já agradeço..
    amigo pelo q eu vi, vc nao usa bridge
    entao onde vc colocou "bridge1" coloque "link" (esse é o nome da sua interface da net)
    testa ai!