+ Responder ao Tópico



  1. Fiz um programa em delphi para comunicar com o mikrotik consigo conectar!!

    Na hora de enviar o comando para criar um profile no hotspot:

    IdTelnet1.Writeln('/ip hotspot user profile add name='+ztable1nome_mikrotik.Value+' address-pool=hs-pool-3 shared-users=1 rate-limit="'+dbedit3.text+'/'+dbedit4.Text+'" open-status-page=always transparent-proxy=yes advertise=no');

    no Memo ele mostra:

    /ip hotspot user profile add name=VELOCIDADE 80K/128K address-p

    no such argument (80K/128K)


    Estranho que ele executa comandos pequeno no Mirkotik como desabilitar usuario normal!!
    Ja mandei esse comando normal sem os dados do banco de dados tb da o mesmo erro!!
    por exemplo:

    IdTelnet1.Writeln('/ip hotspot user profile add name=teste address-pool=hs-pool-3 shared-users=1 rate-limit="80k/128k" open-status-page=always transparent-proxy=yes advertise=no');

    Fiz esse mesmo comando no no telnet do windows conectando no mikrotik e da certo!!

    Alguem saberia o q eu estou errando???

  2. K <> k

    abraço!




    Citação Postado originalmente por brunosamuel Ver Post
    Fiz um programa em delphi para comunicar com o mikrotik consigo conectar!!

    Na hora de enviar o comando para criar um profile no hotspot:

    IdTelnet1.Writeln('/ip hotspot user profile add name='+ztable1nome_mikrotik.Value+' address-pool=hs-pool-3 shared-users=1 rate-limit="'+dbedit3.text+'/'+dbedit4.Text+'" open-status-page=always transparent-proxy=yes advertise=no');

    no Memo ele mostra:

    /ip hotspot user profile add name=VELOCIDADE 80K/128K address-p

    no such argument (80K/128K)


    Estranho que ele executa comandos pequeno no Mirkotik como desabilitar usuario normal!!
    Ja mandei esse comando normal sem os dados do banco de dados tb da o mesmo erro!!
    por exemplo:

    IdTelnet1.Writeln('/ip hotspot user profile add name=teste address-pool=hs-pool-3 shared-users=1 rate-limit="80k/128k" open-status-page=always transparent-proxy=yes advertise=no');

    Fiz esse mesmo comando no no telnet do windows conectando no mikrotik e da certo!!

    Alguem saberia o q eu estou errando???



  3. ja verifiquei isso não é o problema ele na é case sensitive! a o mesmo erro!!

  4. Citação Postado originalmente por brunosamuel Ver Post
    Fiz um programa em delphi para comunicar com o mikrotik consigo conectar!!

    Na hora de enviar o comando para criar um profile no hotspot:

    IdTelnet1.Writeln('/ip hotspot user profile add name='+ztable1nome_mikrotik.Value+' address-pool=hs-pool-3 shared-users=1 rate-limit="'+dbedit3.text+'/'+dbedit4.Text+'" open-status-page=always transparent-proxy=yes advertise=no');

    no Memo ele mostra:

    /ip hotspot user profile add name=VELOCIDADE 80K/128K address-p

    no such argument (80K/128K)


    Estranho que ele executa comandos pequeno no Mirkotik como desabilitar usuario normal!!
    Ja mandei esse comando normal sem os dados do banco de dados tb da o mesmo erro!!
    por exemplo:

    IdTelnet1.Writeln('/ip hotspot user profile add name=teste address-pool=hs-pool-3 shared-users=1 rate-limit="80k/128k" open-status-page=always transparent-proxy=yes advertise=no');

    Fiz esse mesmo comando no no telnet do windows conectando no mikrotik e da certo!!

    Alguem saberia o q eu estou errando???
    Tente acrescentar as aspas e ficaria assim ....add name="'+ztable1nome_mikrotik.Value+'"...., pois o name que vc está trazendo da tabela contém espaços em branco.

    sds.



  5. Valeu era so isso mesmo o problema!!






Tópicos Similares

  1. HotSpot DNS erro Pagina Youtube
    Por hasbr no fórum Redes
    Respostas: 6
    Último Post: 16-07-2012, 15:42
  2. Tela do HotSpot com Erro 404
    Por tizedosal no fórum Redes
    Respostas: 6
    Último Post: 03-01-2012, 03:25
  3. Thundercache4 + hotspot dando erro
    Por smith10 no fórum Redes
    Respostas: 1
    Último Post: 03-05-2010, 10:46
  4. não criar profile samba3.0.10
    Por tomlima no fórum Servidores de Rede
    Respostas: 1
    Último Post: 18-01-2005, 10:54
  5. Erro de Profiles
    Por linux_cobo no fórum Servidores de Rede
    Respostas: 3
    Último Post: 08-07-2004, 00:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L