Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Repassando Ip publico dinacamente para os clientes

    Salve salve a todos

    Pessoal seguinte estou pretendendo repassar ip publico para os cliente sem fazer nat, hoje tenho dois bloco de ips /26, so que não estou sabendo repassar isso para os clientes.

    Alguem ai ja trabalha assim, ou também pretende trabalhar?

    Desde Já desejo a todos um Feliz Natal e um Ano Novo cheio de Paz, Amor, Fraternidade e muitos clientes.

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Depende da sua infra Alcimar...

    Se sua tolopologia for roteada, poderá rotear uma faixa até o gateway do cliente. Se for bridge, só "levantar" um IP que será o gateway do cliente e configurar no equipamento do mesmo. Descreva o ambiente, se possível com um diagrama que a ajuda sairá mais precisa.



  3. #3

    Padrão

    Então Sérgio ai ta o diagrama da rede, eu falando com bruno da openline, ele mim falou que a rede dele trabalha desse jeito, essa rede que estarei montando é para um bairro o qual fica no maximo 40 usuario conectado e com esse range de ip eu consigo fazer.

    O bruno mim falou o seguinte eu deixo soltando dhcp na rede normalmente com ip privado e la eu crio um pool de ip 189.3.139.3-189.3.139.63, e seto ele no hotspot e desabilito o NAT, ainda não testei porque estou sem tempo de ir até meu ponto de distribuição., mas irei o mais rapido possivel.

    A rede como da pra observa ela é toda cabeada, e nesse mesmo servidor estarei colocando webproxy, a mesma ainda não está funcionando mas ja iniciei a estruturação dos switch e cabeamento so ta falantando mesmo a configuração desse servidor para poder ta disponibilizando ip publico para os clientes.

    Agradeço sua Ajuda.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         diagrama rede.jpg
Visualizações:	957
Tamanho: 	48,1 KB
ID:      	3235  

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Sim Alcimar, funciona da forma que o Bruno mencionou. Apenas não entendi o lance dos IPs privados... poderia comentar isso.

    Outra coisa, numa rede cabeada, creio seria mais interessante PPPoE ao invés de hotspot a não ser que irá utilizar switch com isolação de porta (até com pppoe esta é a opção mais funcional se quiser realmente isolar um cliente do outro).

    O roteador ficará conforme o diagrama ? depois dele é a Internet, certo?



  5. #5

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Sim Alcimar, funciona da forma que o Bruno mencionou. Apenas não entendi o lance dos IPs privados... poderia comentar isso.
    Certo, o cliente recebe o ip privado que o servidor dhcp liberou e após o cliente se conectar ele receber ip publico.

    Citação Postado originalmente por sergio Ver Post
    Outra coisa, numa rede cabeada, creio seria mais interessante PPPoE ao invés de hotspot a não ser que irá utilizar switch com isolação de porta (até com pppoe esta é a opção mais funcional se quiser realmente isolar um cliente do outro).
    Verdade PPPoE seria a solução mais ideal porém, no meu dhcp os cliente recebem /32 isolando tb.

    Citação Postado originalmente por sergio Ver Post
    O roteador ficará conforme o diagrama ? depois dele é a Internet, certo?
    Correto depois do roteador é a internet.

    No momento estou pedido ajuda a Bruno, pois fiz o que ele mim pediu e não funcionou.

    Agradeço a sua ajuda e agradeço mais ainda mais ajuda.

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por alcimarbezerra Ver Post
    Certo, o cliente recebe o ip privado que o servidor dhcp liberou e após o cliente se conectar ele receber ip publico.
    Não precisa ser exatamente assim, mas tb funciona. Poderia entregar direto o IP público. Desta forma normalmente é utilizado quando se faz nat 1:1


    Citação Postado originalmente por alcimarbezerra Ver Post
    Verdade PPPoE seria a solução mais ideal porém, no meu dhcp os cliente recebem /32 isolando tb.
    +- né... com pppoe vc pode liberar apenas pppoe-discover e pppoe-session, negando o resto.


    Citação Postado originalmente por alcimarbezerra Ver Post
    Correto depois do roteador é a internet.

    No momento estou pedido ajuda a Bruno, pois fiz o que ele mim pediu e não funcionou.

    Agradeço a sua ajuda e agradeço mais ainda mais ajuda.
    Certo.



  7. #7

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Não precisa ser exatamente assim, mas tb funciona. Poderia entregar direto o IP público. Desta forma normalmente é utilizado quando se faz nat 1:1
    Então sérgio eu coloquei para o cliente pega direto ip real, ele pega certinho desabilitei o NAT e ele não sai como ip real que ele pegou pelo dhcp. Estou estudando aqui bastante para ver se consigo fazer isso rodar hoje.
    Detalhe ele navega com o NAT desabilitado e não pega o Ip real certo



    Citação Postado originalmente por sergio Ver Post
    +- né... com pppoe vc pode liberar apenas pppoe-discover e pppoe-session, negando o resto.
    Poís é não tenho esperiencia com PPPoE seria mais facil de configurar o ip real para o cliente tb?

    vou coloca aqui as configurações que fiz no servidor, quem sabe não sera melhor de vc mim ajudar.

    /ip address
    add address=189.3.139.2/30 broadcast=189.3.139.3 comment="" disabled=no interface=Wan network=189.3.139.0
    add address=189.3.139.5/26 broadcast=189.3.139.63 comment="hotspot network" disabled=no interface=Lan network=189.3.139.0

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.3.139.1 scope=30 target-scope=10

    /ip pool
    add name="hs-pool-2" ranges=189.3.139.6-189.3.139.62

    /ip dhcp-server
    add add-arp=yes address-pool=hs-pool-2 authoritative=yes bootp-support=static disabled=no interface=Lan lease-time=1h name="dhcp1"
    /ip dhcp-server config
    set store-leases-disk=5m
    /ip dhcp-server network
    add address=189.3.139.0/26 comment="hotspot network" dns-server=189.3.139.5 gateway=189.3.139.5 netmask=32

    /ip hotspot profile
    set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap name="default" \
    rate-limit="" smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    add dns-name="189.3.139.5" hotspot-address=189.3.139.5 html-directory=hotspot http-proxy=0.0.0.0:0 login-by=http-chap,http-pap name="hsprof1" rate-limit="" \
    smtp-server=0.0.0.0 split-user-domain=no use-radius=no
    /ip hotspot user profile
    set default advertise=no idle-timeout=none keepalive-timeout=2m name="default" open-status-page=always shared-users=1 status-autorefresh=1m \
    transparent-proxy=yes
    /ip hotspot
    add address-pool=hs-pool-2 addresses-per-mac=2 disabled=no idle-timeout=5m interface=Lan keepalive-timeout=none name="hotspot1" profile=hsprof1
    /ip hotspot service-port
    set ftp disabled=no ports=21
    /ip hotspot user
    add comment="" disabled=no name="admin" password="admin" profile=default

    Creio eu que tudo.
    Última edição por alcimarbezerra; 19-12-2008 às 20:56.

  8. #8

    Padrão

    Agora exatamente 01:30 (em pernambuco) da madrugada, não consegue fazer funcionar corretamente o ip real.

    Estudando......

    Agradeço ajuda viu pessoal!!!
    Última edição por alcimarbezerra; 20-12-2008 às 02:53.



  9. #9

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Esse lance do proxy-arp, provavelmente o problema é que sua operadora não roteia a faixa de IPs para seu equipamento de borda (Mikrotik), apenas disponibiliza para o próprio roteador. Desta forma você não conseguirá passar as rotas adiante.

    Depois dou uma olhada no seu tópico e veremos o que passa. A próposito, poste lá em qual estágio está.
    Então Sérgio como no diagrama que mostrei na imagem tem um roteador cisco na frente do mikrotik, e creio eu que a operadora rotear sim os ips, no cisco eu sei que esta td Ok, nesse mesmo cisco tenho dois range de ips funcionando fmz, creio eu que seja eu mesmo que não esteja fazendo o roteamento correto dentro do mikrotik.

    como falei no outro topico so consigo passar o ip real alterando o arp da interface de saida para proxy arp e fazendo um regra de srcnat, porém sei que é possivel passar o ip real sem que se faça isso apenas com roteamento.

    Agradeceria mais uma vez se você posta-se como se faz para ter ip real na interface lan do mikrotik com roteamento, apenas rotemanto sem regra no firewall, assim eu consegueria fazer o restante.

    Fico no aguardo, e a proposito sérgio la no seu perfil vc respondeu a um membro do under que agora inicio desse ano iria ter curso de mk no recife, vc sabe mim informar qd vai ser e qual curso (basico ou avançado) ?


  10. #10

    Padrão

    eu fiz um post para um colega nosso mas so funciona se seu mk tiver em bridge e funciona certinho faz controle de banda e tudo das uma olhada nos ultimos posts desse link.

    https://under-linux.org/forums/11918...ikrotik-como-2

    espero ter ajudado..



  11. #11

    Padrão

    Citação Postado originalmente por isacloko Ver Post
    eu fiz um post para um colega nosso mas so funciona se seu mk tiver em bridge e funciona certinho faz controle de banda e tudo das uma olhada nos ultimos posts desse link.

    https://under-linux.org/forums/11918...ikrotik-como-2

    espero ter ajudado..
    agradeço sua ajuda, porém essa não é a solução que estou precisando. Passa ip real tranquilo, o problema é do jeito que é certo de se fazer.

    Grande abraço!

  12. #12

    Padrão

    para entregar ip real para o cliente voce precisa adicionar algumas rotas estaticas (dinamicas se voce ativar ospf por exemplo) ...
    apontando um bloco ou ips para o gateway..

    ja postei aqui no forum umas 10 vezes passo-a-passo de como fazer !! faz uma busca pelos meus posts que voce acha facil



  13. #13

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    para entregar ip real para o cliente voce precisa adicionar algumas rotas estaticas (dinamicas se voce ativar ospf por exemplo) ...
    apontando um bloco ou ips para o gateway..

    ja postei aqui no forum umas 10 vezes passo-a-passo de como fazer !! faz uma busca pelos meus posts que voce acha facil
    Então alexandre na verdade eu ja li realmente varios post seus para passa ip real para os clientes, porem não estou conseguindo fazer o que estou querendo, alem de ip real os clientes receber dinamicamente, eu expliquei direitinho no primeiro post o que quero fazer, sergio ele mim ajudou ja bastante juntamente com outro entendendo Bruno, porem não obteve exito.

    Obrigado pela ajuda, concerteza estou fazendo alguma coisa errada e isso não vai passar de um click.

  14. #14

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    para entregar ip real para o cliente voce precisa adicionar algumas rotas estaticas (dinamicas se voce ativar ospf por exemplo) ...
    So para complementar tem como entregar o ip real para os clientes sem ser com roteamento ospf, so não to sabendo como



  15. #15
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por alcimarbezerra Ver Post
    Então Sérgio como no diagrama que mostrei na imagem tem um roteador cisco na frente do mikrotik, e creio eu que a operadora rotear sim os ips, no cisco eu sei que esta td Ok, nesse mesmo cisco tenho dois range de ips funcionando fmz, creio eu que seja eu mesmo que não esteja fazendo o roteamento correto dentro do mikrotik.
    Nada disso Alcimar. Revendo novamente sua infra, a operadora disponibiliza os IPs públicos apenas no roteador. Esse é o problema. O Mikrotik não pode ser o gateway para os clientes, a não ser que você "quebre" esta faixa (no roteador) em sub-redes e faça o roteamento para o Mikrotik.

    Citação Postado originalmente por alcimarbezerra Ver Post
    como falei no outro topico so consigo passar o ip real alterando o arp da interface de saida para proxy arp e fazendo um regra de srcnat, porém sei que é possivel passar o ip real sem que se faça isso apenas com roteamento.
    Conforme o que expus acima, você só conseguirá com o proxy-arp mesmo.

    Citação Postado originalmente por alcimarbezerra Ver Post
    Agradeceria mais uma vez se você posta-se como se faz para ter ip real na interface lan do mikrotik com roteamento, apenas rotemanto sem regra no firewall, assim eu consegueria fazer o restante.
    Eu pediria à operadora para fazer a configuração no roteador para você, se o mesmo for responsabilidade dela, caso seja de sua responsabilidade: mãos à obra.



    Citação Postado originalmente por alcimarbezerra Ver Post
    Fico no aguardo, e a proposito sérgio la no seu perfil vc respondeu a um membro do under que agora inicio desse ano iria ter curso de mk no recife, vc sabe mim informar qd vai ser e qual curso (basico ou avançado) ?

    Este treinamento está em agenda, mas ainda não tenho a data exata. O treinamento é um médio/avançado, nos mesmos moldes do que você já conhece, mas apenas com versão 3.x.

  16. #16
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por alcimarbezerra Ver Post
    So para complementar tem como entregar o ip real para os clientes sem ser com roteamento ospf, so não to sabendo como

    Tem.

    No Mikrotik em ip routes basta adicionar em destination a rede que irá rotear, em gateway o host que irá receber esta rede.

    Mas pela sua topologia você precisa fazer o roteamento é no cisco, pois você não tem nenhum roteador depois do Mikrotik.

    O que eu faria no cisco é: configurá-lo para que o IP público final 2 (Mikrotik) fosse o "responsável" por essa rede /26.



  17. #17

    Padrão

    Para dividir sua faixa de ips publicos em várias sub-redes, existe um exelente artigo no blog do alexandecorreia, mas vou dar uma pincelada aqui seguindo algumas mudanças que estou fazendo na minha estrutura, pois tbm estou fazendo algo parecido onde tive a nescessidade de tornar o MK responsável pelas outras sub-redes na divisao ao receber uma faixa /24 (essa falxa /24 ainda nao recebi da embratel)

    Tenho hoje uma faixa de ips publicos /28 = 16 ips(vergonha, tenho 6MB de link e vivo com essa faixa ENORME de ips publicos) Para colocar em prática o que aprendi sobre roteamento com o sergio e alexandre resolvi dividir minha rede em 2 sub-redes /29 = 6 ips, note que na divisao vc perde alguns ips, entao no meu roteador cisco configurei da seguinte maneira:

    Divisao
    200.200.200.80/28 = 16 ips

    200.200.200.81/29 = 6 ips
    200.200.200.88/29 = 6 ips

    Sendo que no cisco esta configurado com 200.200.200.1/29 e o meu MK com 200.200.200.2/29

    #configure terminal
    #interface FastEthernet0/0
    #ip address 200.200.200.1 255.255.255.252
    control Z
    #configure terminal
    #ip route address 200.200.200.88 255.255.255.252 200.200.200.2 <<-- Nota

    Nota-->> após a divisão é aqui que submeto uma faixa a alguem, ou seja submeti a faixa 200.200.200.88/29 a 200.200.200.2 ip do MK

    Ainda sou cría de mama na questão, mas ja estou aprendendo alguma coisa, conforme for me interando mais vou postar resutados no topico que abrir aqui no under (principalmente depois de receber a maldita faixa /24 da emb)

    abraços
    Última edição por rrinfor; 16-03-2009 às 23:07.

  18. #18

    Padrão

    realmente.. subnetar /28 é fod* ... mas ipv4 tambem nao esta "a rodo" tambem heehe

    desviando um pouco do foco deste topico.. se as operadores fossem mais organizadas.. aqui no brasil sobrariam bastante ips.. por ex..

    um link meu da telemar de 1999/2000 que nao tenho mais.. faz muito tempo.. ainda o bloco esta no meu nome na fapesp.. e esta sem uso...

    o mesmo acontece com embratel, notifiquei-os que nao iria usar os ips deles (tenho meu proprio bloco) .. mesmo assim, os ips estao apontando para meu link (mesmo eu dizendo que nao uso mais e eles confirmando) ... sao 2 /24 .. e 2 /27

    falta eh controle :P



  19. #19

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    realmente.. subnetar /28 é fod* ... mas ipv4 tambem nao esta "a rodo" tambem heehe

    desviando um pouco do foco deste topico.. se as operadores fossem mais organizadas.. aqui no brasil sobrariam bastante ips.. por ex..

    um link meu da telemar de 1999/2000 que nao tenho mais.. faz muito tempo.. ainda o bloco esta no meu nome na fapesp.. e esta sem uso...

    o mesmo acontece com embratel, notifiquei-os que nao iria usar os ips deles (tenho meu proprio bloco) .. mesmo assim, os ips estao apontando para meu link (mesmo eu dizendo que nao uso mais e eles confirmando) ... sao 2 /24 .. e 2 /27

    falta eh controle :P
    concordo quanto a falta de organização das tele operadoras, e sei tbm que ipv4 não tá na feira, mas ja estou a quase 4 mêses brigando, sendo que à 1 mês atrás eles disseram que a minha solicitação foi atendia , enquanto isso minha rede cresce e o bicho pega, pois ja estou com 170 usuários onde 90% sao empresas, ou seja estou entupindo o MK de dstnat para o acesso remoto dos clientes kkkkkkkk

    abraços

  20. #20

    Padrão

    Citação Postado originalmente por rrinfor Ver Post
    concordo quanto a falta de organização das tele operadoras, e sei tbm que ipv4 não tá na feira, mas ja estou a quase 4 mêses brigando, sendo que à 1 mês atrás eles disseram que a minha solicitação foi atendia , enquanto isso minha rede cresce e o bicho pega, pois ja estou com 170 usuários onde 90% sao empresas, ou seja estou entupindo o MK de dstnat para o acesso remoto dos clientes kkkkkkkk

    abraços
    O ideal é fazer feito o alexandre fez ter o seu proprio bloco, o probleminha é para redes pequenas comprovar que vai usar 50% desses ips.