Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Pessoal estou migrando um servidor que usava IP X MAC + CACHE FULL, para PPPOE + CACHE FULL... é uma MK 2.9.27 crack -.-", que esta funcionando blzinha.

    Estou procurando aqui no forum a dias procurando uma solução, pois os clientes com acesso via PPPOE nao estao passando pelo CACHE. li varios posts dos amigos com a mesma duvida onde todos dizem que a solução é usar a excessao "!", entao foi o que eu fiz, porem os clientes via PPPOE ainda nao estao passando pelo CACHE.

    Abaixo estao minhas configurações atuais.

    / ip firewall nat

    add chain=srcnat out-interface="ether1 3com" action=masquerade comment="NAT" \
    disabled=no


    add chain=dstnat in-interface="!ether1 3com" protocol=tcp dst-port=80 \
    action=redirect to-ports=3128 comment="Direcionamento CACHE" disabled=no


    A unica forma quem consegui fazer com que os usuarios PPPOE passacem pelo CACHE foi com esta regra abaixo.

    add chain=dstnat in-interface="pppoe-kurtenet" protocol=tcp dst-port=80 \
    action=redirect to-ports=3128 comment="Direcionamento CACHE" disabled=no


    Esta regra funciona enquanto a conexao PPPOE estiver ativa, porem conexão cair ou o usuario deslogar e logar novamente ela deixa de funcionar, temdo que ser refeita no firewall.

    Se alguem tiver alguma ideia de como me ajudar fico grato desde já...

    Boa tarde a todos e bom trabalho.

    By Kurtenet

  2. Amigo... tambem estou com essa duvida.... tentei migrar meus clientes de hotspot para pppoe e nao passava pelo cache dai recuei.. procurei aqui no under e outros forun e nada... estarei acompanhando seu topico e manterei contato com duas pessoas que me auxilia no MK.... quem sabe logo terei a resposta por lá ou por ca... abraço.



  3. Eu estou pensando em criar algum script que identifique que o cliente esta logado criando a regra indivifual para o cache, e quando ele desconectar retira a regra do fire... porem acho que vai ser dificil escrever esta regra mais hj vo tentar c der certo posto aqui pra ajuda vc tambem.

    Bom trabalho a todos

    By kurtenet

  4. Resolvi usar o NETWATCH para monitorar os ip do cliente e sempre que o mesmo ficar online a opção up do meu netwatch adiciona uma regra no firewall.
    Até aqui blz esta funcionando legal...

    agora o problema ta na regra DOWN, quando o ip ficar off line, é o netwatch vai ficar criando regras imposibilitando de saber em qual linha esta a regra do cliente X... preciso de uma sintax que diga + ou - assim REMOVE "RICARDO - ricardoggadd"

    add comment="" disabled=no down-script="" host=172.27.1.2 interval=30s \
    timeout=1s up-script="/ip firewall nat add action=redirect chain=dstnat co\
    mment=\"RICARDO - ricardogg\" \\\r\
    \n disabled=no dst-port=80 in-interface=<pppoe-ricardogg> protocol=tcp \
    \\\r\
    \n to-ports=3128"

    Se alguem ai tiver alguma ideia ou ja use netwatch da uma ideia de como usar o DOWN ^^.

    Vlw


    By kurtenet



  5. Aeee... galera deu certo ... com esta regra quando o cliente esta on regra sob no firewall "regra especifica para o tunel dele" e quando fica off a regra e retirada do firewall.

    Esta regra fico chata de fazer ela individual cliente por cliente "rsrs vao ser apenas 500" esta sendo o remedio encontrado para o problema, pretendo continuar a procura de outras soluçoes c encontrar posto aki para ajudar.


    add comment="RICARDO - ricardogg" disabled=no down-script=\
    "/ip firewall nat remove \"RICARDO GALDIKS GARDIM - ricardogg\"" host=\
    172.27.1.2 interval=30s timeout=1s up-script="/ip firewall nat add action=r\
    edirect chain=dstnat comment=\"RICARDO - ricardogg\"
    \\\r\
    \n disabled=no dst-port=80 in-interface=<pppoe-ricardogg> protocol=tcp \
    \\\r\
    \n to-ports=3128

    By kurtenet






Tópicos Similares

  1. Respostas: 5
    Último Post: 28-03-2009, 16:42
  2. Web Proxy/cache duvida!!! ???
    Por alanvictorjp no fórum Redes
    Respostas: 10
    Último Post: 07-04-2007, 21:14
  3. PPPOE DUVIDAS
    Por MAKS no fórum Redes
    Respostas: 3
    Último Post: 11-11-2004, 15:15
  4. Duvida cache do Squid
    Por DevLocKe no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-09-2004, 15:48
  5. Dúvida quanto ao cache do squid!!!
    Por hawk23 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 02-09-2004, 08:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L