Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá!
    Pessoal, estou com a seguinte duvida, como criar um script para apagar e cache? Já fiz de varias formas aqui e não obtive sucesso,consigo parar o cache e etc, mas não consigo fazer o comando clear rodar e conseguentemente limpar meu cache. Quero deixa esse script rodando uma vez por mês. Desde já, obrigado pela ajuda.

  2. vamu la
    cria um arquivo com nome da sua escolha com o seguinte conteudo


    ex:

    vi /usr/local/bin/clear_cache


    #!/bin/sh

    # --- Regra para não parar a navegação dos clientes ---#
    iptables -t nat -I POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT

    #--- Parando squid ---#
    killall -9 squid

    #--- Apagando Cache ---#
    rm -rf /diretorio do cache
    ex:
    rm -rf /var/cache/squid/*

    #--- Apagando log ---#
    rm -rf /diretorio do log
    ex:
    rm -rf /var/log/squid/*

    #--- Criando Estrutura do cache ---#
    squid -z

    #--- Iniciando squid ---#
    squid -D

    #--- Direionamento para o squid ---#
    iptables -t nat -D POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT


    valde o arquivo
    de a permissão de escrita para ele
    chmod +x /usr/local/bin/clear_cache

    e adicione ele na crontab

    crontab -e
    0 0 1 * * /usr/local/bin/clear_cache



    assim ele ira rodar o script as 00:00 do dia 1 de cada mes



  3. Citação Postado originalmente por Benatto Ver Post
    vamu la
    cria um arquivo com nome da sua escolha com o seguinte conteudo


    ex:

    vi /usr/local/bin/clear_cache


    #!/bin/sh

    # --- Regra para não parar a navegação dos clientes ---#
    iptables -t nat -I POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT

    #--- Parando squid ---#
    killall -9 squid

    #--- Apagando Cache ---#
    rm -rf /diretorio do cache
    ex:
    rm -rf /var/cache/squid/*

    #--- Apagando log ---#
    rm -rf /diretorio do log
    ex:
    rm -rf /var/log/squid/*

    #--- Criando Estrutura do cache ---#
    squid -z

    #--- Iniciando squid ---#
    squid -D

    #--- Direionamento para o squid ---#
    iptables -t nat -D POSTROUTING -s SUA REDE -p tcp --doprt 80 -j ACCEPT


    valde o arquivo
    de a permissão de escrita para ele
    chmod +x /usr/local/bin/clear_cache

    e adicione ele na crontab

    crontab -e
    0 0 1 * * /usr/local/bin/clear_cache



    assim ele ira rodar o script as 00:00 do dia 1 de cada mes
    Muito orbigado pelo esclarecimento. Esse conteudo me será útil demais, pois também vou utilizar proxy em paralelo. Mas na realidade esqueci de especificar no topico que as regras eram para o mikrotik, por isso se puder me passar também, ficarei ainda mais agradecido.

  4. Olá amigo,
    Discordando da limpeza do cache. Tá o script para a limpeza.

    Para o mikrotik 2.9.x

    /system script add name=cache_clear source="/ip web-proxy set enabled=no; \ /ip web-proxy clear-cache;"


    Para o mikrotik 3.x

    /system script add name=cache_clear source="/ip proxy set enabled=no; \ /ip web-proxy clear-cache;"

    Executar no tempo programado

    /system scheduler add name=clear_cache interval=30d start-date=da
    ta start-time=tempo on-event=cache_clear



  5. Citação Postado originalmente por Mr. RG Ver Post
    Olá amigo,
    Discordando da limpeza do cache. Tá o script para a limpeza.

    Para o mikrotik 2.9.x

    /system script add name=cache_clear source="/ip web-proxy set enabled=no; \ /ip web-proxy clear-cache;"


    Para o mikrotik 3.x

    /system script add name=cache_clear source="/ip proxy set enabled=no; \ /ip web-proxy clear-cache;"

    Executar no tempo programado

    /system scheduler add name=clear_cache interval=30d start-date=da
    ta start-time=tempo on-event=cache_clear
    não é só ir la em web-proxy, settings e dar um clear cache???






Tópicos Similares

  1. Como criar um banner para divulgar o seu Provedor de Internet
    Por Buenano no fórum Assuntos não relacionados
    Respostas: 6
    Último Post: 17-11-2016, 13:13
  2. Alguem sabe como criar um script no mikrotik?
    Por maxwellsousa no fórum Redes
    Respostas: 12
    Último Post: 08-09-2009, 23:46
  3. Como criar um script ...
    Por sandroreis no fórum Linguagens de Programação
    Respostas: 5
    Último Post: 27-12-2005, 16:58
  4. Como criar um shell script para monitoramento de log(url)
    Por nozey no fórum Linguagens de Programação
    Respostas: 7
    Último Post: 30-10-2005, 20:12
  5. Como fazer um script para bloqueio de modem
    Por Renato2004 no fórum Servidores de Rede
    Respostas: 1
    Último Post: 08-03-2004, 15:13

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L