Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Página de bloqueio esse funciona melhor que desativar o folgado!!!

    Bom dia unders de plantão
    aqui vai uma solução para quem como eu tinha dificuldades de barrar aqueles clientes folgados que acha que nosso trabalho
    com internet e mole e nao pagam internet, melhor que bloquear a net deles e eles passarem o vexame de alguem ver que ele
    nao pagou a internet, e claro que so uso com clientes com mais de 20dias de atraso com 5 dias vou postar mais adiante.
    aqui tem solução para que quando eles logare, porque eles vão logar normalmente mas não navegaram pois
    esta configuração impede que ele seja redirecionado para qualque site mesmo que ele tente
    fechar o navegador, e outra dependendo do tempo de cookie ele não tem nem que logar e so recebera
    a tela de bloqueio.
    antes crie a pagina bloqueio.html, este nome pq é o que esta definido no codigo mas pode ser mudado
    mas nao se esqueça de alterar o nome no codigo tambem.
    agora copie o codigo coloque no terminal do seu mikrotik
    ------------------------------------- copie aqui -----------------------------------------
    / ip hotspot user profile
    add name="bloqueio" address-pool=pool-dhcp session-timeout=5m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m
    shared-users=1 incoming-filter="hs-unauth" outgoing-filter="hs-unauth-to" transparent-proxy=yes \
    open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never
    ------------------------------------- até aqui -----------------------------------------
    agora trasnfira a pagina copiando e colando no menu /file agora para que nao seja usado a pagina
    radvert.html pois mesmo que vc defina qual a pagina que vai usar o mikrotik sempre usa esta pagina
    para evitar isso faça um backup dela e delete-a do hotspot.
    pronto defina o profile para os clientes inadimplentes.
    ele nunca mais navega em site algum sem que pague pelo serviço.
    Ah! lembrando que o mesmo pode conseguir logar no MSN e P2p normalmente enquanto tiver valendo o session-timeout que neste
    caso é de 5m mas é só diminuir e ele nao conseguirar usar estes serviços, mas nunca coloque menos que 1m pois se nao a tela pode nao aparecer e sim a tela de erro do navegador.
    Duvidas estamos aqui!!!
    Última edição por underwanderson; 26-12-2008 às 20:59.

  2. #2

    Padrão Pode me ajudar? Sou iniciante em Mikrotik.

    Onde insiro aqueles scripts?

    / ip hotspot user profile
    add name="bloqueio" address-pool=pool-dhcp session-timeout=5m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m

    shared-users=1 incoming-filter="hs-unauth" outgoing-filter="hs-unauth-to" transparent-proxy=yes \
    open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never

    Vou precisar criar minha pagina de bloqueio



  3. #3

    Padrão

    Citação Postado originalmente por giovanniba Ver Post
    Onde insiro aqueles scripts?

    Onde insiro aqueles scripts?

    / ip hotspot user profile
    add name="bloqueio" address-pool=pool-dhcp session-timeout=5m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m

    shared-users=1 incoming-filter="hs-unauth" outgoing-filter="hs-unauth-to" transparent-proxy=yes \
    open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never


    Vou precisar criar minha pagina de bloqueio
    Onde insiro aqueles scripts?
    Você pode utilizar o New Terminal

    Vou precisar criar minha pagina de bloqueio
    Precisa sim, e deve colocar o nome bloqueio.html
    Última edição por cesarpsa; 28-12-2008 às 08:46. Razão: correção ortográfica

  4. #4

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    Onde insiro aqueles scripts?
    Você pode utilizar o New Terminal

    Vou precisar criar minha pagina de bloqueio
    Precisa sim, e deve colocar o nome bloqueio.html

    Obrigado, vou tentar hoje e obtendo sucesso posto aqui o resultados!!!



  5. #5

    Padrão devedor :: bloqueio

    Beleza,
    Pra quem tiver dificuldade em fazer usando os script, tenta fazer por essa foto, ela foi tirada daqui mesmo do under a um tempo atraz.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         devedor.JPG
Visualizações:	3104
Tamanho: 	53,5 KB
ID:      	3269  

  6. #6

    Padrão

    Amigo quando se coloca o usuario no perfil bloqueado, é preciso excluir ele da lista de cookies e se estiver conectado da lista de HOSTS no Hotspot.

    Teria alguma forma de fazer com que ele bloqueie sem ter a necessidade de fazer isto??
    vlwww



  7. #7

    Padrão

    Aproveitando, consegui fazer funcionar a pagina de bloqueio do jeito que o amigo passou....

    mais essa do Mr.RG não consegui sobre pagina de aviso

    Para quem está com mensalidade atrasada:

    /ip hotspot user profile add name="Aviso" address-pool=pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s


    Dupliquei os perfis que tenho atualmente, apenas adicionando a pagina de aviso, mais não funfo por aqui não....se alguem tiver algum sugestao por gentileza poste ae tmbm...
    vlww

  8. #8

    Padrão

    Citação Postado originalmente por giovanniba Ver Post
    Onde insiro aqueles scripts?

    / ip hotspot user profile
    add name="bloqueio" address-pool=pool-dhcp session-timeout=5m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m
    shared-users=1 incoming-filter="hs-unauth" outgoing-filter="hs-unauth-to" transparent-proxy=yes \
    open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never

    Vou precisar criar minha pagina de bloqueio

    sim você vai criar uma pagina comum em html e salvar com o nome bloqueio.html retirar a pagina radvert.html (faça um backup pois pode precisar dela para fazer telas de advertencia por atraso com menos de 5dias) pois como disse se deixar esta pagina na pasta hotspot o mikrotik em vez de usar sua pagina de bloqueio ele ira usar a pagina radvert.html do sistema, depois disso tudo abra um New Terminal e cola este codigo


    / ip hotspot user profile
    add name="bloqueio" address-pool=pool-dhcp session-timeout=5m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m
    shared-users=1 incoming-filter="hs-unauth" outgoing-filter="hs-unauth-to" transparent-proxy=yes \
    open-status-page=always advertise=yes advertise-url=bloqueio.html advertise-interval=1s advertise-timeout=never


    de enter para finalizar a colagem e pronto e so ir em / ip hotspot users e escolher o cliente que vai ficar bloqueado e escolher o profile apropriado para ele ou seja bloqueio.
    Lembrando que este bloqueio e muito agressivo pois eu so uso para clientes com mais de 20dias de atraso e colocar e esquecer nao adianta ficar cobrando verbalmente ele pois, se ele esta afim de ficar serio na sua rede ele vai te procurar e acertar e da mais moral a rede pois ó cliente vai pensar que so ele atrasa na rede e sente uma certa vergonha por receber aquela tela no seu pc, veja o exemplo que uso pode até copiar.
    acho que é isso.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         exemplo da pagina de bloqueio.JPG
Visualizações:	3397
Tamanho: 	128,1 KB
ID:      	3275  



  9. #9

    Padrão

    Citação Postado originalmente por cesarpsa Ver Post
    Beleza,
    Pra quem tiver dificuldade em fazer usando os script, tenta fazer por essa foto, ela foi tirada daqui mesmo do under a um tempo atraz.

    Certo cesarpsa, mas o objetivo aqui é não dar mole pro inadiplente e fazer algo mais profissinal e com essas configurações da imagem que vc postou ele fica dando loop no navegador e como vai estar utilisando o radvet.html ele gera um popup de conexao se o cliente nao fechar nem a tela de aviso e nem o pop e ele abrir outra pagina ele pode ate navegar a nao ser pelos 20s da session time out que derruba ele, pois foi isso que consegui nos meus testes.
    No caso desta que configurei a tela fica statica sem loop (por isso a retirada do arquivo radvert.html ela adverte e redireciona) e com session time out de 5m onde da tempo de criar cookie onde por 6Hs ele entra sem logar mas nao pode abrir paginas a nao ser a designada pelo hotspot.
    obrigado

  10. #10

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Amigo quando se coloca o usuario no perfil bloqueado, é preciso excluir ele da lista de cookies e se estiver conectado da lista de HOSTS no Hotspot.

    Teria alguma forma de fazer com que ele bloqueie sem ter a necessidade de fazer isto??
    vlwww

    Certo gustavinho69, mas ele ainda é seu cliente e é preciso saber se ele esta tentando navegar, mesmo sem pagar se excluir ele da lista de cookies ele nao tentara logar nunca mais e saira da sua rede (e claro ninguem quer cliente assim ruim de pagamento, mas se puder recuperar esta alma melhor pro seu bolso, to certo?) e ele logando pode tomar consciencia de aquela rede e seria pois tem bloqueios severos, por isso ele tem que logar e gerar cookies e quando ele loga gerando este cookie de 6hs nao quer dizer que esta navegando pois se reperar na hora que voce fizer utilizaçao desta configuraçao em host ele nao ficara como "A" de autenticado e sim como "H" onde so quem gerou ip foi o servidor dhcp e o hotspot nao designou ip para completar o ritual logico para navegação.
    obrigado



  11. #11

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Aproveitando, consegui fazer funcionar a pagina de bloqueio do jeito que o amigo passou....

    mais essa do Mr.RG não consegui sobre pagina de aviso

    Para quem está com mensalidade atrasada:

    /ip hotspot user profile add name="Aviso" address-pool=pool idle-timeout=5m keepalive-timeout=2m status-autorefresh=1m shared-users=1 transparent-proxy=yes open-status-page=always advertise=yes advertise-url=aviso.html advertise-interval=20m advertise-timeout=15s

    Dupliquei os perfis que tenho atualmente, apenas adicionando a pagina de aviso, mais não funfo por aqui não....se alguem tiver algum sugestao por gentileza poste ae tmbm...
    vlww

    tente este

    / ip hotspot user profile
    add name="Aviso" session-timeout=30m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    rate-limit="20k/128k" transparent-proxy=yes open-status-page=always advertise=yes advertise-url=radvert.html \
    advertise-interval=29m55s advertise-timeout=immediately

    mas nao se esqueca de alterar o nome do arquivo advert.html pois fiz mais uma vez o teste com a pagina de bloqueio e este arquivo estiver no hotspot o mesmo da preferencia para o radvert.html entao remomeie como no exemplo.
    Obs: vejo que no codigo citado acima nao existe velocidade de acesso com isso o cliente mesmo atrasado navegaria com toda banda da sua rede, sera que ele ia achar ruim...
    lembrando que o arquivo radvert mesmo com nome alterado nao muda as propriedades internas do seu codigo ele mostrara a advertencia ao cliente mas redireciona para a pagina status.html do hotspot ai o cliente tem que digitar o endereço novamente e isso e um trastorno para o cliente pois se o mesmo nao tiver intençao de atraso ou so esqueceu o dia do pagamento e capaz que voce perca tal cliente para outra rede entao fica uma dica, use apenas tela de bloqueio e com atrasos acima de 15 dias pois nao terao disculpas quando for bloqueado.
    veja o exemplo de uma pagina de advertencia nela fala em 15 dias mas coloque com 5 dias
    obrigado
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         exemplo da pagina de aviso.JPG
Visualizações:	1209
Tamanho: 	24,3 KB
ID:      	3277  

  12. #12

    Padrão

    Citação Postado originalmente por underwanderson Ver Post
    tente este

    / ip hotspot user profile
    add name="Aviso" session-timeout=30m idle-timeout=none keepalive-timeout=2m status-autorefresh=1m shared-users=1 \
    rate-limit="20k/128k" transparent-proxy=yes open-status-page=always advertise=yes advertise-url=radvert.html \
    advertise-interval=29m55s advertise-timeout=immediately

    mas nao se esqueca de alterar o nome do arquivo advert.html pois fiz mais uma vez o teste com a pagina de bloqueio e este arquivo estiver no hotspot o mesmo da preferencia para o radvert.html entao remomeie como no exemplo.
    Obs: vejo que no codigo citado acima nao existe velocidade de acesso com isso o cliente mesmo atrasado navegaria com toda banda da sua rede, sera que ele ia achar ruim...
    lembrando que o arquivo radvert mesmo com nome alterado nao muda as propriedades internas do seu codigo ele mostrara a advertencia ao cliente mas redireciona para a pagina status.html do hotspot ai o cliente tem que digitar o endereço novamente e isso e um trastorno para o cliente pois se o mesmo nao tiver intençao de atraso ou so esqueceu o dia do pagamento e capaz que voce perca tal cliente para outra rede entao fica uma dica, use apenas tela de bloqueio e com atrasos acima de 15 dias pois nao terao disculpas quando for bloqueado.
    veja o exemplo de uma pagina de advertencia nela fala em 15 dias mas coloque com 5 dias
    obrigado

    Obrigado amigo pelas respostas.....vou fazer o teste e reporto aqui os resultados.

    Em relação a velocidade, eu fiz um perfil de aviso para cada velocidade tipo:

    250
    500
    1MB
    ========
    250 aviso
    500 aviso
    1MB aviso

    assim ele continuaria na sua velocidade apenas tendo a tela de aviso.



  13. #13

    Padrão

    Cara estou fazendo alguns testes com a pagina de bloqueio e eu coloquei o session timeout como 1 segundo....

    mesmo ele me mostrando a tela de bloqueio, eu consigo digitar outro site e abrir normalmente.

    teria como deixar sempre fixo esse bloqueio, de forma que não libere nada de navegação?

  14. #14

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Cara estou fazendo alguns testes com a pagina de bloqueio e eu coloquei o session timeout como 1 segundo....

    mesmo ele me mostrando a tela de bloqueio, eu consigo digitar outro site e abrir normalmente.

    teria como deixar sempre fixo esse bloqueio, de forma que não libere nada de navegação?


    se seguir o topico do inicio dara tudo certo, como foi dito a outro usuario aqui nunca coloque menos que 1min pois o session-time-out e quem derruba a conexao ativa a cada 5m para que ela se renove a cada atualização do navegador (abrindo e fechando o mesmo ou pressionando F5) e colocando 1s nunca que iria dar tempo de mostrar a pagina de bloqueio pois ela e resultado da uniao de varios fatores configurativos, e a pagina quem vai barrar ele em qualquer navegador se essa pagina nao tiver tempo de ser mostrada entao e como se existisse uma brecha para ele navegar.
    ah! lembrando que o cookie setado para 6hs e para que ele nao nescessite ficar digitando seu login deixando um serviço mais profissional, e que o inadiplente nao pensse que a conexao dele esta sempre caindo.
    obrigado



  15. #15

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Obrigado amigo pelas respostas.....vou fazer o teste e reporto aqui os resultados.

    Em relação a velocidade, eu fiz um perfil de aviso para cada velocidade tipo:

    250
    500
    1MB
    ========
    250 aviso
    500 aviso
    1MB aviso

    assim ele continuaria na sua velocidade apenas tendo a tela de aviso.
    blz!
    isso seria bom pois ele so recebera as advertencia mas o serviço continua firmeza como contratado, pois ninguem sabe a intenção dele né?
    legal!

  16. #16

    Padrão

    Citação Postado originalmente por underwanderson Ver Post
    se seguir o topico do inicio dara tudo certo, como foi dito a outro usuario aqui nunca coloque menos que 1min pois o session-time-out e quem derruba a conexao ativa a cada 5m para que ela se renove a cada atualização do navegador (abrindo e fechando o mesmo ou pressionando F5) e colocando 1s nunca que iria dar tempo de mostrar a pagina de bloqueio pois ela e resultado da uniao de varios fatores configurativos, e a pagina quem vai barrar ele em qualquer navegador se essa pagina nao tiver tempo de ser mostrada entao e como se existisse uma brecha para ele navegar.
    ah! lembrando que o cookie setado para 6hs e para que ele nao nescessite ficar digitando seu login deixando um serviço mais profissional, e que o inadiplente nao pensse que a conexao dele esta sempre caindo.
    obrigado

    Vlww amigo underwanderson pela resposta

    Mais que nem, do jeito que eu fiz por aqui a tela de bloqueio aparece certinha....só que por exemplo, nos teste que eu fiz numa maquina aqui da minha rede, quando ia navegar e abria a pagina de bloqueio eu atualizava e mesmo assim continuava a bloquear....até ai blza...só que quando eu tentava digitar algum site e colocava IR no navegador eu conseguia pelo menos carregar a pagina....mais quando ia acessar algum link....ele caia denovo no bloqueio...

    tipo:
    bloqueava a page inicial do TERRA mais quando eu digitava o YAHOO no navegador e ficava tentando acessar ele carregava a pagina do yahoo por inteiro e depois bloqueava quando eu acessava algum link.

    por isso gostaria de saber se teria algo que dropasse a conexão de efetuar o acesso.
    vlwwwwww



  17. #17

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Vlww amigo underwanderson pela resposta

    Mais que nem, do jeito que eu fiz por aqui a tela de bloqueio aparece certinha....só que por exemplo, nos teste que eu fiz numa maquina aqui da minha rede, quando ia navegar e abria a pagina de bloqueio eu atualizava e mesmo assim continuava a bloquear....até ai blza...só que quando eu tentava digitar algum site e colocava IR no navegador eu conseguia pelo menos carregar a pagina....mais quando ia acessar algum link....ele caia denovo no bloqueio...

    tipo:
    bloqueava a page inicial do TERRA mais quando eu digitava o YAHOO no navegador e ficava tentando acessar ele carregava a pagina do yahoo por inteiro e depois bloqueava quando eu acessava algum link.

    por isso gostaria de saber se teria algo que dropasse a conexão de efetuar o acesso.
    vlwwwwww
    Este teste que voce esta fazendo e com session-time-out a 1s? se for e isso que esta acontecendo dependendo do momento que o cliente der enter apos digitar um url e dependendo de quanto bytes a pagina tiver ela ate pode carregar toda como a do google e sempre caira no bloqueio mas para isso nao acontecer use o session-time-out a partir de 5m acima porque o time out como ja disse ele e quem dita ate quando aquela sessao iniciada tera vida ate estourar o tempo e derruba a conexao forçando o redirecionamento da conexao para o bloqueio novamente, se colocar 12hs nunca ira redirecionar e sim teria que logar pois terminaria a vida do cookie que era de 6hs, entendeu? um depende do outro pra dar certo, mas de todas configuraçoes essa foi a que mais deu certo e evita carregamento inesperado do site pra depois ir pro bloqueio, acho que nao tem nescessidade de alterar o modo do funcionamento eu uso aqui e o folgado pia rsrsrs.
    obrigado

  18. #18

    Padrão

    vlwww Cara mais uma vez pela atenção....

    Então só pra ver se eu entendi bem...se eu deixar o session-time-out em 5m ele vai ter navegação de 5 minutos e vai cair na tela de bloqueio certo?



  19. #19

  20. #20

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    vlwww Cara mais uma vez pela atenção....

    Então só pra ver se eu entendi bem...se eu deixar o session-time-out em 5m ele vai ter navegação de 5 minutos e vai cair na tela de bloqueio certo?
    nao, ele nao navegara por 5m e depois caira na tela de bloqueio, a configuração aqui mencionada da direito de uma seção de 5m para que ele possa ser derrubado no link e a unica pagina que ele deve ver todo tempo mesmo que ele digite qualquer endereço ou mude de navegador e a pagina de bloqueio, refiz os testes aqui e nao tem quem faça aparecer outra pagina a nao ser a de bloqueio, da uma verificada na sua coniguração ai aqui funciona blz.
    obrigado