Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Lightbulb 3 tipos de Load Balance

    galera tenho um ano de Experiencia com o mikrotik
    vou passar o q eu sei de balanceamento espero que ajudem muitas pessoas

    LOAD BALANCE 1


    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!

    exemplo:

    Interfaces


    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra

    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra

    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10


    LOAD BALANCE 2

    Esse vc separa por grupos de usuarios da sua rede.

    Exemplo:

    Interface


    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    regras:


    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10

    galera agora vou colocar uns sripts para se for o caso de algum link cair:

    Regras:

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on


    exemplo 2

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24

    Regras

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.64
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.65-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupC" \
    disabled=no new-routing-mark=GrupC passthrough=no src-address=\
    192.168.0.129-192.168.0.192
    add action=mark-routing chain=prerouting comment="GrupD" \
    disabled=no new-routing-mark=GrupD passthrough=no src-address=\
    192.168.0.193-192.168.0.254

    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10

    LOAD BALANCE 3

    esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.

    Mikrotik Versão 2.9

    exemplo:

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24

    Regras

    / ip firewall mangle
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no

    add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no


    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no

    add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no

    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes

    Mikrotik 3.10 contendo 5 Links

    Interfaces

    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24
    Link5 ip - 50.50.50.1/24

    Regras

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment=Link1 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link1 nth=4,0 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link1 \
    disabled=no in-interface=Rede new-routing-mark=link1 passthrough=no
    add action=mark-connection chain=prerouting comment=Link2 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link2 nth=4,1 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link2 \
    disabled=no in-interface=Rede new-routing-mark=link2 passthrough=yes
    add action=mark-connection chain=prerouting comment=Link3 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link3 nth=4,2 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link3 \
    disabled=no in-interface=Rede new-routing-mark=link3 passthrough=no
    add action=mark-connection chain=prerouting comment=Link4 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link4 nth=4,3 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link4 \
    disabled=no in-interface=Rede new-routing-mark=link4 passthrough=no
    add action=mark-connection chain=prerouting comment=Link5 connection-state=\
    new disabled=no dst-address-list=!ips in-interface=Rede \
    new-connection-mark=link5 nth=4,4 passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=link5 \
    disabled=no in-interface=Rede new-routing-mark=link5 passthrough=no
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=link2 passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=link2 passthrough=yes routing-mark=link2
    add action=add-src-to-address-list address-list=ips address-list-timeout=0s \
    chain=prerouting comment="" disabled=no in-interface=Rede

    /ip firewall nat
    add action=src-nat chain=srcnat comment="" connection-mark=link1 disabled=no \
    to-addresses=10.10.10.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link2 disabled=no \
    to-addresses=20.20.20.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link3 disabled=no \
    to-addresses=30.30.30.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link4 disabled=no \
    to-addresses=40.40.40.1 to-ports=0-65535
    add action=src-nat chain=srcnat comment="" connection-mark=link5 disabled=no \
    to-addresses=50.50.50.1 to-ports=0-65535

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=link1 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=link2 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=link3 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=link4 scope=30 target-scope=10
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    50.50.50.1 routing-mark=link5 scope=30 target-scope=10


    Espero que ajude muita gente, qualquer duvida e so postar obrigado

    Última edição por isacloko; 28-12-2008 às 16:22.

  2. #2

    Padrão

    pessoal, tenho 1 adsl de 1mb e um proxy paralelo rodando bem legalzin
    pedi o segundo adsl, de 600k, gostaria de saber dos experientes ai, quel desses load se da melhor com um proxy paralelo?
    tb estou pensando em jogar o link 1mb no proxy e o 600k no mk,, seria uma gambiarrra de load?
    rsrsr

    desde ja, grato!



  3. #3

    Padrão

    Bom dia! vou postar minha opinião,

    quem usa o método ctrl+c/ctrl+v provavelmente terá problemas (calma aí vou explicar rss)
    isso por que cada rede tem suas particularidades, mas pelo menos a pessoa tem algo pra trabalhar em cima... e com um pouquinho de esforço dá pra adaptar e aprender sim.. e dps compartilhar!

    obrigado a todos que tem contribuído com seu tempo, atenção e conhecimentos, parabéns pela iniciativa isacloko!

  4. #4

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    pessoal, tenho 1 adsl de 1mb e um proxy paralelo rodando bem legalzin
    pedi o segundo adsl, de 600k, gostaria de saber dos experientes ai, quel desses load se da melhor com um proxy paralelo?
    tb estou pensando em jogar o link 1mb no proxy e o 600k no mk,, seria uma gambiarrra de load?
    rsrsr

    desde ja, grato!

    vc me poderia me passar suas regras no mikrotik pra mim da uma analizada do seu proxy paralelo?



  5. #5

    Padrão

    Citação Postado originalmente por egservice Ver Post
    Bom dia! vou postar minha opinião,

    quem usa o método ctrl+c/ctrl+v provavelmente terá problemas (calma aí vou explicar rss)
    isso por que cada rede tem suas particularidades, mas pelo menos a pessoa tem algo pra trabalhar em cima... e com um pouquinho de esforço dá pra adaptar e aprender sim.. e dps compartilhar!

    obrigado a todos que tem contribuído com seu tempo, atenção e conhecimentos, parabéns pela iniciativa isacloko!

    ctrl+c/ctrl+v aiii dentoooo papai noel, vai dormir q teu mal eh sono
    aoskoasksakoasko
    Última edição por alanvictorjp; 30-12-2008 às 15:50.

  6. #6

    Padrão

    Citação Postado originalmente por isacloko Ver Post
    vc me poderia me passar suas regras no mikrotik pra mim da uma analizada do seu proxy paralelo?
    iae brow, rapaz so estou usando apenas um redirect para o proxy

    add chain=dstnat protocol=tcp dst-port=80 src-address-list=clientes action=dst-nat to-addresses=192.168.2.8 to-ports=3128 \
    comment="dst_proxy" disabled=no

    soh isso msm
    obs, a list clientes nao consta o ip do proxy,, claro hehe
    estou usando isso transparente, o proxy logando ip dos clientes, tudo bem redondinho,

    estou com 2 opçoes na cabeça,..
    um load no mk, ou 1 link no proxy e outro no mk
    qual sua opiniao?
    vlww



  7. #7

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    iae brow, rapaz so estou usando apenas um redirect para o proxy

    add chain=dstnat protocol=tcp dst-port=80 src-address-list=clientes action=dst-nat to-addresses=192.168.2.8 to-ports=3128 \
    comment="dst_proxy" disabled=no

    soh isso msm
    obs, a list clientes nao consta o ip do proxy,, claro hehe
    estou usando isso transparente, o proxy logando ip dos clientes, tudo bem redondinho,

    estou com 2 opçoes na cabeça,..
    um load no mk, ou 1 link no proxy e outro no mk
    qual sua opiniao?
    vlww
    olha eu tbm fiquei meio em duvida mas era bom vc fazer um teste qual ficaria melhor?
    mas vou lhe passar como vc fazer o load para seu clientes no mk

    vamos supor que o ip do seu mk seja 192.168.2.1 e do seu proxy 192.168.2.8

    e seu clientes da faixa 192.168.0.10 ate 192.168.0.250

    se vc no meu caso eu faria um load por grupo de usuario (load balance 2)

    Vc dividiria a quantidade de clientes de acordo com a quantida de usuario na que faixa de ip

    exemplo

    clientes do ip 192.168.0.10 ate 192.168.0.180 - ficaria com 1 mb
    clientes do ip 192.168.0.181 ate 192.168.0.250 - ficaria com 600kbs

    e so seguir a regra ai encima que da certinho e se for fazer n esqueça de fazer os scripts q anotei la tambem e muito importante para se alguma linha cair a outra supre.

    blz ai ta a minha opniao espero te ajudado.

  8. #8

    Padrão

    eh estou pensando em fazer por grupos tb, e creio q de todo geito vai ficar praticamente 1 link pra proxy e outro pro resto,,
    seguinte

    tenho 1 range de ips aqui 192.168.2.1/24 que eu uso para os aps, outros servers aqui e o proxy
    os clientes estao em subredes
    tpw
    / ip address
    add address=192.168.2.1/24 network=192.168.2.0 broadcast=192.168.2.255 interface=bridge1 comment="RANGE LOCAL e APS" disabled=no
    add address=10.0.1.1/30 network=10.0.1.0 broadcast=10.0.1.3 interface=bridge1 comment="" disabled=no
    add address=10.0.2.1/30 network=10.0.2.0 broadcast=10.0.2.3 interface=bridge1 comment="" disabled=no
    add address=10.0.3.1/30 network=10.0.3.0 broadcast=10.0.3.3 interface=bridge1 comment="" disabled=no
    add address=10.0.4.1/30 network=10.0.4.0 broadcast=10.0.4.3 interface=bridge1 comment="" disabled=no
    add address=10.0.5.1/30 network=10.0.5.0 broadcast=10.0.5.3 interface=bridge1 comment="" disabled=no
    add address=10.0.6.1/30 network=10.0.6.0 broadcast=10.0.6.3 interface=bridge1 comment="" disabled=no
    add address=10.0.7.1/30 network=10.0.7.0 broadcast=10.0.7.3 interface=bridge1 comment="" disabled=no

    cada um no seu quadrado kkkk

    poderia ser link 1mb saindo para 192.168.2.1/24 - onde ta o proxy
    e o outro link, para 10.0.0.0/16?

    e.. na verdade os clientes 10.0.x.x vai usar de todo geito o link 1mb por causa do redir do proxy
    correto
    ?



  9. #9

    Padrão

    soh queria fazer um load, em vez de jogar 1mb no proxy, pro causa dos logs do squid que ta gerando os ips dos clientes bunitinho, se eu jogar o link no proxy direto, creio q nao vai mais logar os ips dos cliente nao, e sim o ip do gw mk

  10. #10

    Padrão

    Cara parabens pela iniciativa....
    no meu caso eu gostaria de utilizar o Load Balance 1, mais eu tenho Virtua e Speedy

    Virtua através de DHCP e Speedy roteado....teria como eu fazer deixando o virtua recebendo através do DHCP_CLIENT ?

    vlwwww



  11. #11

    Padrão

    Citação Postado originalmente por alanvictorjp Ver Post
    soh queria fazer um load, em vez de jogar 1mb no proxy, pro causa dos logs do squid que ta gerando os ips dos clientes bunitinho, se eu jogar o link no proxy direto, creio q nao vai mais logar os ips dos cliente nao, e sim o ip do gw mk

    pq vc nao usa o proxy do mk acho tao mais simples e facil faz tudo ate gera log no seu pc, se quizer ajuda eu te passo as regras

  12. #12

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Cara parabens pela iniciativa....
    no meu caso eu gostaria de utilizar o Load Balance 1, mais eu tenho Virtua e Speedy

    Virtua através de DHCP e Speedy roteado....teria como eu fazer deixando o virtua recebendo através do DHCP_CLIENT ?

    vlwwww
    sim, so que preciso saber se o gateway do virtua e sempre o mesmo, verifica pra mim e te passo as regras certinho blz..



  13. #13

    Padrão

    Humm beleza cara...vou verificar....caso não seja tera que ser roteado mesmo neh?

  14. #14

    Padrão

    Citação Postado originalmente por isacloko Ver Post
    sim, so que preciso saber se o gateway do virtua e sempre o mesmo, verifica pra mim e te passo as regras certinho blz..
    nao troco meu proxy server por mk nopz, e ate pq uso 2.9.27 ai q n troco msm
    meu proxy eh um p4 3.2 3gb ddr2 1 sata de 80gb cacheando 35gb, bem redondo e legal, pretendo deixar ele por aki, quando o adsl da linha ativar vou começar os tests ehehe
    por enquanto soh pesquisas
    vlww



  15. #15

    Padrão

    Amigo verifiquei por aqui e o virtua não mantem o mesmo gateway....neste caso terei que rotear mesmo neh?

    vlww

  16. #16

    Padrão

    Citação Postado originalmente por gustavinho69 Ver Post
    Amigo verifiquei por aqui e o virtua não mantem o mesmo gateway....neste caso terei que rotear mesmo neh?

    vlww
    e parece q sim, so se vc arrumar algum scrpit q copia o gateway toda vez q ele atualizar, tentei fazer aqui n consegui n, acho melhor vc colocar um roteador antes, aqui eu o meu funciona discando no mk, so aqui n muda o gateway.



  17. #17

    Padrão

    Ahhhh beleza entao...vou fazer um teste colocando o roteador antes....

    Ai no seu não é virtua não neh???

    No caso eu deixaria o speedy discando no MK e iria colocar o virtua roteado.

  18. #18
    cleivon
    Visitante

    Padrão load balance

    Amigos agradeço a ajuda dos colegas, eu ja uso o load balance n. 2 e estou tentando apenas fazer as regras do script, para quando um link cair o outro assuma,, porem não consegui fazer copiando e mudando para a minha rede que usa o gat 1 - 192.168.1.254 e o gateway 2 192.168.10.1// as regras de netwatch deram certo as links cai e fica dawn quando ligado figa up poren as regras do script não consigo inserir pelo terminal, e manualmente não entendi como fazer para funcionar,



  19. #19

    Padrão

    Citação Postado originalmente por cleivon Ver Post
    Amigos agradeço a ajuda dos colegas, eu ja uso o load balance n. 2 e estou tentando apenas fazer as regras do script, para quando um link cair o outro assuma,, porem não consegui fazer copiando e mudando para a minha rede que usa o gat 1 - 192.168.1.254 e o gateway 2 192.168.10.1// as regras de netwatch deram certo as links cai e fica dawn quando ligado figa up poren as regras do script não consigo inserir pelo terminal, e manualmente não entendi como fazer para funcionar,
    aqui esta pronto e so copiar e colar no seu new terminal
    so nao esquece de colocar la em /ip route ( o comentario na rota 192.168.10.1 - GrupA e na rota 192.168.1.254 - GrupB)

    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=192.168.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=192.168.1.254 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=192.168.1.254 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=192.168.10.1 }"

    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    192.168.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=192.168.1.254 interval=5m timeout=1s up-script=link2-on

    tente ai pra ver se funviona blz qualquer duvida e so postar..

  20. #20
    cleivon
    Visitante

    Padrão load 2

    Amigo quero agradecer jua ajuda, e dizer que eu sou novo no mk, porem no meu não funcionou, digitei os script manualmente pois não consegui inserir pelo teminal,, mais gostaria de perguntar porque temos estes nomes todosolicy=\ftp,reboot,read,write,policy,test,w inbox,password,sniff
    no meu não encontrei o ftp e o w inbox? e resto fica marcado ou desmarcado? onde coloco este source=\
    "/ip route {set [find comment=GrupA] gateway=192.168.10.1 }´ colo o que esta entre aspas no campo abaixo. como maco o comemt do router?? os links estão ok quando cai conta o tempo e aparece down, porem não redireciona para o outro link. estou somente com uma máquina no link 1 para teste o link 2 e o mais usado, assim deixei todos nela até testar a regra. para depois dividir legual.

    abraço..